All Activity

This stream auto-updates     

  1. Yesterday
  2. I'm trying to run resilio in a docker on UNRAID and the encrypted file names are +255 characters in length which is causing problems for XFS and BTRFS file system. Is this something that resilio can limit?
  3. So I'm trying to sync the files via a Docker on UNRAID. But now I'm running into a file name length issue Resilio is creating encrypted files with 255+ characters in their file name. I see that there is a really old post about this that I'm about to resurrect.
  4. Last week
  5. Unfortunately, I also have such folders. I have 3 Synology servers (DS1815 +, 415+, 412+), 3 Windows computers, 2 smartphones, on which Resilio is installed. It happens again and again that not all data is synchronized, especially between the Synology servers. I was able to fix this time and again by optimizing the permissions for groups and owners on the servers in the affected directories. But for some time now I have 3 directories that are complet for 99%, 98%, 99% and so apparently are not completely synced. Any files in the peer list that are pending syncing will not be synced because they already exist. As a rule, another measure is that I separate and reconnect the peers. In this case this did not help either. However, I did not delete the .sync directory, which contains sync data. Does that even benefit?
  6. @Alex, Yes of course, for creating a new certificate I tried several methods (installing openssl on windows, but also creating a certificate on my readynas) and because if the defined files/certificates do not exists Resilio-Sync will not start 🙂 After some more digging and tries, I get my self-signed certificate working, but the result is still the same.... webgui is working under Firefox and Chrome, but within Edge and IE still resulting in a blanc page.... 😞 part of the logging: see attachment sync.log
  7. @Hans# Did you actually generate SSL certificate? Do the following files exist in you system /home/ssl/sync.crt /home/ssl/sync.key ?
  8. The Setup: I have three licenses, one Server and two regular licenses two regular, I'll call LocalSync and RemoteSync. Server is WinServer2016, LocalSync is Windows10Pro, and RemoteSync is a Synology NAS. WinServer2016 is the "owner" (or more actually the source of all data) of 4 folders configured as encrypted folders. LocalSync syncs those 4 folders in Read only modeand is located one gigabit switch away from WinServer2016. Additionall LocalSync is also the source of 2 encrypted folders. So LocalSync has 4 Read Only syncs, and 2 read/write syncs. RemoteSync is located 30 miles away from my business in my home. I have two pfsense routers on either side with a permenant OpenVPN connection. RemoteSync has all six folders configured as encrypted. All three machines think they are on a local LAN (and two are..) and thus go full speed, limited by my businesses upload speed of 20mbps. In all three locations in all folders, I DO NOT have "Store Deleted files in folder archive", i.e. delete ANYTHING that should not be there so I can compare folder size and number of files more easily (except the couple of extra files in ".sync"..np). I also have "Overwrite any changed files", again so I can more easily compare folder size and number of files. The four folders between WinServer2016 and LocalSync are always 100% synced, no problem. Three of the Four folders from WinServer2016 sync fine to RemoteSync. One out of Two folders from LocalSync have finished syncing to RemoteSync The last folder from LocalSync I've had paused to allow the other ones to finish syncing because they are very large volume backups (hundreds of gigabytes in a couple of files), so this one is not relevant...yet...unless it doesn't finish in a few days, then I'll be back So my problem is the two folders, one from WinServer2016 and one from LocalSync that just seem to be stuck. On RemoteSync I took some screenshots to remember where the sync was on each day: On 1/21 the folder from WinServer2016 was 98% complete, and the folder from LocalSync was 60% On 1/22 the folder from WinServer2016 was still 98% complete, and the LocalSync folder was 83% On 1/23 (today) the WinServer2016 was 98% and Local sync was still 83% (Note that on LocalSync, it thinks its only 42% complete. LocalSync folder should have 58,121 files. On RemoteSync it only has 57,950. A picture is worth 1000 words so I made a diagram What type of troubleshooting steps can I take to figure out what the problem is? One thing I'm thinking of doing is configuring a windows 10 Server at home for syncing, instead of my Synology NAS, as I think the problem may be my NAS. Although its not out of resources or anything and isn't throwing any errors.
  9. @Alex, I tried the self signed SSL certificate, but when I added the 2 statements for the certificate : "ssl_certificate" : "/home/ssl/sync.crt" and "ssl_private_key" : "/home/ssl/sync.key" it results in a non-functional webui.... The web-page is trying the TLS-handshake but ultimate it ends with a time-out, so now also firefox and chrome are failing... So no success yet in getting
  10. Fixed. Missed one of my systems that still had this annoying tempparent folder. purged and system calmed down and sync'd up.
  11. I am getting this error in my logs repeatedly: [20200123 13:00:28.334] API: --> getperformancewarnings(t=1579806028311) [20200123 13:00:28.418] TF[84B2] [0x00007fc4bb9b6e00][/Volumes/Traveler/Pics/Friends and Family/2019/20190201-Deans_4th_Birthday_Party/TempParent/Temporary Folder 6C53B790-C659-4399-9FC0-0E28C08E90B3/DSC_3558.JPG]: state:DOWNLOAD error: meta:1 conns:5 io:0 disk:0% mt:0% net: 0% [20200123 13:00:28.418] PC[0x00007fc4cb7162b8][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:28.418] PC[0x00007fc4cb756178][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:28.418] PC[0x00007fc4cb736648][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:28.418] PC[0x00007fc4cb613718][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:28.418] PC[0x00007fc4cb616148][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:29.064] API: --> setlocalstorage [20200123 13:00:29.071] API: <-- setlocalstorage({"id":"<async message id>","response":{"status":200}}) [20200123 13:00:29.338] API: --> getperformancewarnings(t=1579806029336) [20200123 13:00:29.338] API: <-- getperformancewarnings({"id":"<async message id>","response":{"status":200,"value":[]}}) [20200123 13:00:29.424] TF[84B2] [0x00007fc4bb9b6e00][/Volumes/Traveler/Pics/Friends and Family/2019/20190201-Deans_4th_Birthday_Party/TempParent/Temporary Folder 6C53B790-C659-4399-9FC0-0E28C08E90B3/DSC_3558.JPG]: state:DOWNLOAD error: meta:1 conns:5 io:0 disk:0% mt:0% net: 0% [20200123 13:00:29.424] PC[0x00007fc4cb7162b8][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:29.424] PC[0x00007fc4cb756178][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:29.424] PC[0x00007fc4cb736648][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:29.424] PC[0x00007fc4cb613718][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:29.424] PC[0x00007fc4cb616148][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:30.368] API: --> getperformancewarnings(t=1579806030366) [20200123 13:00:30.433] TF[84B2] [0x00007fc4bb9b6e00][/Volumes/Traveler/Pics/Friends and Family/2019/20190201-Deans_4th_Birthday_Party/TempParent/Temporary Folder 6C53B790-C659-4399-9FC0-0E28C08E90B3/DSC_3558.JPG]: state:DOWNLOAD error: meta:1 conns:5 io:0 disk:0% mt:0% net: 0% [20200123 13:00:30.433] PC[0x00007fc4cb7162b8][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:30.433] PC[0x00007fc4cb756178][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:30.433] PC[0x00007fc4cb736648][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:30.433] PC[0x00007fc4cb613718][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:30.433] PC[0x00007fc4cb616148][0x00007fc4bb9b6e00] pending:0 requests:0 unwirtten:0 [20200123 13:00:31.051] API: --> setlocalstorage the DSC_3558.JPG file is the one in question. However lightroom creates this "Tempparent" folder and that gets erased after it's done importing pictures... That folder doesn't actually exist on any of my five other sites (I checked them all) so I'm not sure how to "ignore" this error as it never pops up with that option (to ignore).
  12. I just tried to send in some logs from my laptop and will send the logs from my main server in a bit. However I get the error "Failed to send feedback": The conf file seems to have prevented the low disk space warning as I haven't seen that yet today. However, this one file persists to eat up cpu cycles since it's constantly trying to download the file I guess. Can I manually attach some log files or such to this post? Or is there private info in there? Thanks again.
  13. @gleep52 it would be easier to understand why it happens if you gather logs from both peers Meanwhile you can put attached config to ~/Library/Application Support/Resilio Sync and you will get rid of out of space warning sync.conf
  14. Well it finally gave me an error on my laptop - claiming I'm out of space and that's why the file won't download...? I have 500gb out of 2TB free on this SSD... where is it getting the idea I'm out of space?
  15. It looks like it IS working... sort of. New items sync, but it says I'm missing ONE file and is stuck at 98% for most of the day now. I created a new folder and put some files in there and it DOES seem to sync both ways which I thought it wasn't last night. Perhaps I was impatient? BUT, All five other library locations say they are trying to send this ONE picture to my new laptop, but it just hangs there... I have the filename, but there are dozens of files with the same name scattered about in the 2+TB of pictures. How do I reindex or fix this? On my primary server (Alpha) I make all my folder changes, etc. That server says that it has some 400K files to upload to Varmint too - and I'm not sure why that's hung up - but it's been that way for ages. I've run beyond compare (program) on the two servers to compare files and they are 100% in sync, so not sure what I can do to rectify the bugs here... Any ideas?
  16. Obrigado pelo retorno, efetuei ps procedimentos que você me passou, agora esta funcionando certinho. Obrigado.
  17. @gleep52 unfortunately, this is the only way to do this... did you get an error? what was wrong with it?
  18. That's the only thing I could think of too... No dice. Or at least it didn't detect things like I'd hoped. Any other ideas?
  19. @RobM Thank you! We're alive and kicking. Happy to hear that you like sync, stay tuned for new sync updates.
  20. @gleep52 try to move '~/Library/Application Support/Resilio Sync' from old mac to a new one.
  21. Right now I have a portable HD on my old Mac that Resilio sync's my pictures too in "selective sync" format. There are thousands of folders and only some are sync'd. I bought a new Mac. Is there a way to migrate all the settings I have on my old Mac to my new Mac in regards to the selective sync folder selection? I don't want to go through thousands of folders if there is already an index file or config file that exists that I can just transfer... Anyone know how to do that?
  22. Sync is an excellent and unique product. I am hoping your company succeeds. Please give your user base an opportunity to pay more if that's what it takes to keep you moving forward.
  23. Yes, my android mobile did not sync the apk file of games.
  24. Earlier
  25. Turning off Antivirus during install did the trick. I should have thought of that, but it's really rare that it gives me trouble. Thanks!
  26. @Steerider Could you please go to %LOCALAPPDATA%\Temp and check for btsyncsvc_*.log files? Which version of Windows do you use? Do you use any antivirus? Could you please try to install service manually using the following command? cd "%APPDATA%\Resilio Sync" ; "Resilio Sync.exe" /svcinstall -a -u %username% %password%
  1. Load more activity