UmedaBound

Members
  • Content Count

    10
  • Joined

  • Last visited

About UmedaBound

  • Rank
    Member
  1. Edit: Never mind. Wrong thread, and I can't delete, it seems.
  2. Just wanted to report that I've been having the same problem with a Samsung Galaxy Note running 1.4.63 and multiple PCs running 1.4.103. Even deleting the files on the phone side only sometimes helps fix the problem.
  3. Still no luck. Occasionally one or more files just seems to get stuck going from PC in Canada to Server in Japan. The workaround (moving the file out of the sync path on the PC, restarting btsync on the Server, and then copying the file back in) is getting annoying, particularly when the file in question is huge. Incidentally, I solved the log problem. It turns out that the debug.txt file was still sitting in the .sync director. I renamed it and the log returned to normal size. I did also send this issue (and logs) to support. Have not heard back yet.
  4. Pere, Thanks for the response. Sadly, the folder that I'm having problems syncing with is shared between two machines. One in Canada, and one in Japan. So the LAN trick won't work for me. Also, it's not practical to use my Linux box (the one in Japan) as a central server. For me, the point in general is to have certain folders sync'd between multiple machines at the same time, and not have to rely on a central box for my day-to-day syncing needs.
  5. I would post these two problems separately, but I think they are related. Some background: I've been using sync for months now and love it. One of the directories I've started syncing recently is my photos folders: 450GB in 66,000+ files between a Windows 7 64-bit machine and my Linux server at home. Problem 1. I noticed that the sync was taking a long time and that the speed was really slow. That's when I noticed that the 300MB sync of current files was creating a lot of .!sync files and not finishing the sync on them. I tried moving the files in question out of the folder, allowing the .!sync files to get deleted, and then trying again, but no luck. I tried stopping and restarting sync on both machines. I tried combinations in various orders of all of the above. No joy. I noticed that my Linux version was still the previous stable version (1.1.82 or whatever), so I upgraded to the most recent 1.2.82. Didn't help. Eventually, I solved the problem by removing the photos folder on both machines and allowing them to reindex. As of yesterday, the problem has reoccurred. I don't want to spend half a day re-indexing the folders every time this happens. All other folders sync with no problems. Problem 2. While investigating the first problem, I inspected the log files on each machine. There were a fair number of errors on the Linux side. I turned on debug logging on the Linux machine. Shortly after that, I noticed that my sync.log file was getting huge. So I removed that switch from the init script and restarted the sync service. The logs continue to be huge. Like 9GB+ for 24 hours of operation. I've been running for less than 30 minutes and my sync.log on the Linux box is over 50MB! The log is quite verbose, and looks to me like it's still running in debug mode. I've searched through the forums, but haven't found anything relevant. Maybe my search terms are wrong? Anyway, apologies if I'm retreading anything, but any help would be much appreciated. I'm sure this is just a config issue.
  6. No, I was dumber than even that. I edited the wrong conf file. Derrr... Thanks for the help anyway!
  7. Hi again! Another newb question. I want to secure the webmin interface with a password and username, but I can't seem to get it to work. I've probably just formatted my .conf file wrong, but it would be great if someone could eyeball it for me and let me know where I've screwed up: { // use relay server when direct connection fails "use_relay_server" : true, "use_tracker" : true, "use_dht" : false, "search_lan" : true, "lan_encrypt_data" : true, "lan_use_tcp" : true, "webui" : { "listen" : "0.0.0.0:8888", "login" : "name", "password" : "blahblahpassword" } } I set this up, restarted the service and... still doesn't work. Connecting to the server on port 8888 still goes straight to the webui without asking for a password. Any help appreciated. Much thanks!
  8. Found the solution! I remembered having configured my backup software to always use eth0, and I managed to find the little text file I wrote myself. Here was the solution: Download bind.c from http://daniel-lange....searchButton]=> Copy to a temp dir and do: gcc -nostartfiles -fpic -shared bind.c -o bind.so -ldl -D_GNU_SOURCE strip bind.so cp -i bind.so /usr/lib/ Then change the start line for any software needing to go out on local to: BIND_ADDR="[local adapter address]" LD_PRELOAD=/usr/lib/bind.so [full path & command line] Example: BIND_ADDR="10.0.0.99" LD_PRELOAD=/usr/lib/bind.so /usr/bin/btsync restart Voila! Problem solved!
  9. Thanks for the responses! @Stephan: I thought the default broadcast address was x.y.z.255 on a /24 network? The "known hosts" feature is a good suggestion. I had tried it before, but I thought I needed to configure it on the Linux box. Turns out, it's the other peers who needed the Linux box's address. That works for me because I use static addressing assigned via DHCP, but the mobile client doesn't seem to have a "known hosts" option. I forgot to mention that one device is an Android phone that backs up its Titanium Backup folders to the Linux box. As for finding out how OpenVPN handles broadcasting, I think I can't figure out the right search terms, as I've come up with nothing useful. Also, in this case, the remote OpenVPN server is 3rd party; I have no control over settings server-side, which complicates my google search on how to set this up. @Alajjana: Routing tables are a bit beyond me. This is mine now: 93.114.45.13 via 10.77.77.254 dev eth0 10.8.0.1 via 10.8.0.237 dev tun0 10.8.0.237 dev tun0 proto kernel scope link src 10.8.0.238 10.0.0.0/24 dev eth0 proto kernel scope link src 10.0.0.9 0.0.0.0/1 via 10.8.0.237 dev tun0 128.0.0.0/1 via 10.8.0.237 dev tun0 default via 10.0.0.254 dev eth0 metric 100 I use tun rather than tap. 10.0.0.254 is my router. 10.8.0.238 is the address assigned by the remote OpenVPN server Any advice you can provide (along with CLI commands to implement) would be welcome.
  10. I have BTsync running on several boxes, all of them Windows 7, except one. That one is running on an Ubuntu server which functions as my NAS. I also run OpenVPN on that server (outgoing). I have set up routing so that any requests to the LAN (e.g. 10.0.0.0/24) are routed through eth0 instead of tun0 (OpenVPN's virtual adapter). sudo ip rule add from 10.0.0.9 table 128 sudo ip route add table 128 to 10.0.0.0/24 dev eth0 sudo ip route add table 128 default via 10.0.0.254 This works for all the other applications I run on that server... except for BTsync. When the OpenVPN daemon is running, it cannot find the other machines running BTsync. I have enabled lan_use_tcp in the config file, and have Search Lan turned on for all sync'd folders. I'm a bit of a Linux newb, particularly when it comes to networking/firewall/router rules. Any advice would be appreciated. It's kind of a PITA to have to stop my OpenVPN daemon every time I want the server to rediscover the other machines. (Once they're discovered, they work, even with OpenVPN turned on... until the next time they go offline for a while, or until the next time I stop and start BTsync on the Linux box.)