Ragnar

Members
  • Content Count

    10
  • Joined

  • Last visited

About Ragnar

  • Rank
    Member
  1. Hi, i have several Friends and Famility where i use BTSync to have a backup of their files without requiring them to do anything. Now if i imagine one of them catches an encryption trojan like Locky...how would i go about restoring them? i have them all set up with a RO copy with activated Archive. so i'd expect all files to show up in .sync\Archive\... but some might have different versions already so i would have to identify the last archived version for each -> the one with the highest *.<Number>.<Extension> or maybe all from a certain Date and Time Range? i guess sooner or later a BTSync user will be hit and it might be nice if there were some guidance or FAQ for that issue. Thanks Rag
  2. i have a lot of files that are already at the BackupLocation and i want to add it as ReadOnly. But unfortunately it will not recognize them and resync all of them as i have just tested (both with v1.4.7.2) My Steps: created 2 Folders on each PC with identical files PC\1TEST-RO PC\1TEST-RW PC\2TEST-RO PC\2TEST-RW added both on PC1, closed BTSync on PC1 started BTSync on PC2 and added the ReadOnly Key for TEST-RO and ReadWrite Key for TEST-RW TEST-RW gets indexed but TEST-RO does not seconds after i start BTSync on PC1 TEST-RW is done, but TEST-RO is doing a full-pull from PC1 to PC2 would be great to enable the PreCopy also for RO Syncs. Thanks for any help and gerally for this great tool! Ragnar
  3. will this also work if the other side will becom a read-only copy? for me its a pure backup location so i dont want it writable. in the past that hasent worked for me with read-only. does 1.4 fix that? //UPDATE: i just tested and it seems that this is still the case. My Steps: created 2 Folders on each PC with identical files PC\1TEST-RO PC\1TEST-RW PC\2TEST-RO PC\2TEST-RW added both on PC1, closed BTSync on PC1 started BTSync on PC2 and added the ReadOnly Key for TEST-RO and ReadWrite Key for TEST-RW TEST-RW gets indexed but TEST-RO does not seconds after i start BTSync on PC1 TEST-RW is done, but TEST-RO is doing a full-pull from PC1 to PC2 would be great to enable the PreCopy also for RO Syncs. Thanks
  4. +1 i had a Folder Synced via BTSync ReadOnlySecret and because of an error it was suggested to remove and readd it. Are existing files ignored when using a ReadOnlySecret?
  5. i did that and removed the Folder at the remote peer and readded it. but it seems like that this advice does not work for Read Only Hashes? As it is ignoring the 56GB sitting in the Folder an seems like it wants me to transmit it all over again! im just lucky that i'll be at the remote Systems Location this week to sync there via LAN.
  6. for the impatient among us: on large Folders it will stay on "FolderXY 0 MB in 0 files" for quite a while until it has completely received the FileList etc. So give it time!
  7. display the found peers with same secret maybe in the Folders properties page? This would make troubleshooting the connections easier. maybe like this: D:\myFolder -> properties -> Tab "peers" PeerName - IP:Port - found via: Tracker/DHT/LAN/.. - has Read/ReadWrite Secret - lastconnectTime - lastErrorTime - ... maybe even keep a history of peers that have ever synced cheers Ragnar
  8. Hello, using Sysinternals procmon.exe i see that my BTSync Clients are not trying to connect to the correct Internet port and am wondering why. Client1 (LabServer at my company) ListeningPort=64881, UPNP:yes, FolderConfig: use tracker, Search DHT no Portforwarding and i dont think UPNP is enabled at my company Client2 (laptop at Home) ListeningPort=44253, UPNP:yes, FolderConfig: use tracker, Search DHT On my Arcor Easybox A 300 at home i have configured Portforwarding 44253 to the IP of my laptop (192.168.15.15) and have enabled UPNP So i expected to see the LabServer connect to 192.168.15.15(MyLaptopLocalIP):44253 but it seems only to connect to random Ports. BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 22.33.44.55(MyHomeInternetIp):44298 BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 22.33.44.55(MyHomeInternetIp):44436 BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 22.33.44.55(MyHomeInternetIp):44445 BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 22.33.44.55(MyHomeInternetIp):44502 BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 22.33.44.55(MyHomeInternetIp):44574 BTSync.exe - UDP Send - 10.1.2.3(MyServerLocalIP):64881 -> 192.168.15.15(MyLaptopLocalIP):44253 any ideas? additional: -from my LabServer i can successfully telnet 192.168.15.15(MyLaptopLocalIP):44253 -using another Router at home it had worked flawlessly, i guess due to UPNP. funny enough: my laptop is trying the correct InternetIp:Port 33.44.55.66(MyCompanyInternetIP):64881 but as i wrote i dont have portforwarding on the LabServer side. Thanks in advance Ragnar
  9. Hi, i will soon get a new computer and am wondering if i need to transfer everything over the Internet again to the target BTSync. current Situation: MyPC\FolderX is "Master" RemoteHost\Sync-FolderX uses ReadOnlySecret to sync now i get a new computer and FileCopy all from MyPC to NEWPC New Situation: NEWPC\FolderX is "Master" and has to generate new Secrets RemoteHost\Sync-FolderX already contains all the Data. How to use the NEWPC-ReadOnly-Secret but not Transfer all content of FolderX again? Is that possible? could i for example use the FullAccess Secret to transfer from MyPC to NEWPC? then remove MyPC so that NEWPC is the new Master of FolderX and RemotHost still uses it's ReadOnlySecret? RemoteHost is far away so i cant just go into its LAN for 1st Sync. Thanks Rag
  10. Hello, For many programs i use the Win7 (Enterprise x64) Firewall to block outgoing connections when on a Network that is marked public. Thats to conserve my 3G DataVolume and not (try to) sync when on a customers Network. But even when i configure the windows firewall BTSync.exe can still sync. Windows Firewall Rule config: This Program: C:\Program Files (x86)\BitTorrent Sync\BTSync.exe Protocol: Any Profiles: Public Any idea why? or how i can make sure it doesn't? Thanks Rag