scus

Members
  • Content Count

    7
  • Joined

  • Last visited

About scus

  • Rank
    New User
  1. Tanks for your reply. If it is necessary to escape those characters, they should be escaped by \uXXXX and not \u00XX\u00XX. The escaped characters above represent ä and not ä as it should.
  2. I am trying to use the API to write a simple CLI. Unfortunately the API escapes unicode characters in a strange way. Example: [ { "dir": "\/home\/scus\/Universit\u00c3\u00a4t", "error": 0, "files": 10813, "indexing": 0, "secret": "--------------------------------", "size": 2211998011, "type": "read_write" } ]I think the solution might be to not escape those characters (complies RFC 4627) and to send an "charset=utf-8" header with the response. Side note, the content-type header should say "application/json". If it is necessary to escape non-ascii characters, the character ä for example should be escaped by "\uc3a4". Regards, scus This bug is mentioned already here: http://forum.bittorrent.com/topic/25839-bug-returned-json-escapes-utf-8-in-messages/. But since this is the "Bug-Forum"...
  3. The current version is 1.3.87!? And in this version the API returns an encryption secret.
  4. I stumbled upon the same problem, while writing a python api wrapper. A fix would be nice, as it regards also directory names, if they contain umlaute/non ASCII characters.
  5. Hi, thanks for the replies. @d9nut: Disabling the tracker search helps. But as soon as I reactivate this option, the old behavior is back... I would prefer to use tracker servers, since some of my peers don't have fixed IPs/Domain names... @RomanZ: 1), 2) are fulfilled. I will try 3). Is there a way to see connected peers/progress when the WebUI is disabled? I have an API key.
  6. Edit: Seems not to be caused by using SSH tunnels. Changed title. Original Text below. I have two NAS boxes (arm), a Laptop (ubuntu) and two PCs (win8 and debian) running BitTorrent Sync. On both the NAS boxes I have two instances of BitTorrent Sync running (two different users; WebUI Ports 8881 and 8880). At the moment the Laptop and the Windows PC are turned off. The Debian PC is showing that the folder is completely synced to both the NAS boxes. So it seems that everything is fine. But the WebUI on the NAS boxes shows three peers. The first one is the NAS box itself (i.e. the NAS box named turing is listing a peer named turing). The second one is a local IP address, the IP of the NAS itself. The third one is the Debian PC. The other NAS box isn't showing up. Edit 2: The NAS box (named turing) asserts that it has to upload 8GB to the two "self-peers". The Debian PC peer is completely synced. Regards scus Original Post: Hi there, I am trying to manage several BitTorrent Sync instances via WebUI, and I am seeing strange effects. My configuration: NAS 1 (arm): + user1 instance with WebUI on port 8881 + user2 instance with WebUI on port 8882 NAS 2 (arm): + user1 instance with WebUI on port 8881 + user2 instance with WebUI on port 8882 Laptop (ubuntu) + user1 instance with WebUI on port 8888 When I connect to NAS 2 (on a remote site) via SSH tunnel (ssh <ipaddr> -L 8881:localhost:8881), it seems like the WebUI of NAS 2 is mixing things up with the WebUI on my local laptop. Same when I managed NAS 1, then connecting to NAS 2 (both via the ssh command above). For example NAS 2 pretends, that it is syncing with itself. Is this a known issue? Is there a workaround? Best regards, scus
  7. Hi everybody, I stumbled upon the "encrypted peer mode" for API users (here: http://forum.bittorrent.com/topic/24846-few-questions-about-encryption/?hl=%2Bencrypted+%2Bnode)... I am using BitTorrent Sync for my NAS, PC and mobile and this is (at the moment) the only feature I miss... Will it be available to the ordinary people in the future? If yes, when? It would be great to get an "official" answer! Best regards scus