Eric0

Members
  • Content Count

    3
  • Joined

  • Last visited

About Eric0

  • Rank
    New User
  1. Ok, I´ve tried the following again. When I boot with btsync debug 0000There is no process starting. Executing this after this boot: pgrep -u $(id -u) -f btsyncindicator.pyGives no number. The file ~./btsync/debug.txt was created with the boot timestamp. The logfile ~./btsync-user.log was unchanged! (timestamp from before the boot) Now: when I boot with: btsync startThe following is noticed: pgrep -u $(id -u) -f btsyncindicator.pyIt gives a pid nr. So it is running but with an exclamation mark. The logfile ~./btsync-user.log changed. The following text was added. 2014-02-19 08:38:09+01:00 User specific files and directories created2014-02-19 08:38:10+01:00 start_frontend: begin2014-02-19 08:38:10+01:00 start_frontend: starting frontend with default config file /home/eric/.config/btsync/btsync-auto.conf2014-02-19 08:38:10+01:00 start_frontend: end2014-02-19 08:38:10+01:00 btsync-starter: btsync-agent pausedNext thing I tried was starting with the little script I made: #!/bin/sh/usr/lib/btsync-user/btsync-startersleep 10/usr/lib/btsync-user/btsync-stopper sleep 10btsync startThen the indicator shows a normal status. To the logfile was added (I selected the debugging option in the indicator): 2014-02-19 08:32:33+01:00 User specific files and directories created2014-02-19 08:32:33+01:00 start_frontend: begin2014-02-19 08:32:33+01:00 start_frontend: starting frontend with default config file /home/eric/.config/btsync/btsync-auto.conf2014-02-19 08:32:33+01:00 start_frontend: end2014-02-19 08:32:33+01:00 btsync-starter: btsync-agent paused2014-02-19 08:32:54+01:00 User specific files and directories created2014-02-19 08:32:54+01:00 start_frontend: begin2014-02-19 08:32:54+01:00 start_frontend: starting frontend with default config file /home/eric/.config/btsync/btsync-auto.conf2014-02-19 08:32:54+01:00 start_frontend: end2014-02-19 08:32:54+01:00 btsync-starter: forking runner...2014-02-19 08:32:54+01:00 btsync-starter: end2014-02-19 08:32:54+01:00 agent_runner: begin2014-02-19 08:32:54+01:00 agent_runner: starting up components...2014-02-19 08:32:54+01:00 User specific files and directories created2014-02-19 08:32:54+01:00 start_frontend: begin2014-02-19 08:32:54+01:00 start_frontend: end2014-02-19 08:32:54+01:00 start_agent: begin2014-02-19 08:32:54+01:00 start_agent: starting agent with default config file /home/eric/.config/btsync/btsync-auto.confLast thing: When I boot with btsync debug 0000, nothing happened as said before. But when I open a terminal and to manually execute: btsync startThe indicator shows up with this exclamation mark. In the terminal the following text is looping: WARNING:requests.packages.urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'error(111, 'Connection refused')': /gui/token.html?t=1392797019.99WARNING:root:Connection Error caught, displaying error messageWARNING:requests.packages.urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'error(111, 'Connection refused')': /gui/token.html?t=1392797022.0WARNING:root:Connection Error caught, displaying error messageWARNING:requests.packages.urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'error(111, 'Connection refused')': /gui/token.html?t=1392797024.0WARNING:root:Connection Error caught, displaying error messageetc...Then I end the process and execute btsync start in the same terminal. Everything is fine then.
  2. There was this in the btsync-user.log (after booting with btsync debug 0000): 2014-02-18 10:55:22+01:00 User specific files and directories created2014-02-18 10:55:22+01:00 start_frontend: begin2014-02-18 10:55:22+01:00 start_frontend: starting frontend with default config file /home/eric/.config/btsync/btsync-auto.conf2014-02-18 10:55:22+01:00 start_frontend: end2014-02-18 10:55:22+01:00 btsync-starter: btsync-agent pausedSo nothing special, it was paused. But btsync indicator didn´t show up on my ubuntu 12.04. After starting manually with btsync start. nothing changed in the log. But the following showed up in the terminal: WARNING:requests.packages.urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'error(111, 'Connection refused')': /gui/token.html?t=1392717328.94WARNING:root:Connection Error caught, displaying error messageThen exit btsync again and restarted. Then works fine after the restart. Hope this helps. Grz Eric
  3. I have the same startup problem in Ubuntu 12.04. Until this is solved, I´ve made a temporarily poor man´s workaround script which seems to work for me. Run this script on boot with Ubuntu´s "Startup Applications" (Also deactivate for the time the regular Btsync boot/start command in "Startup Applications" ) #!/bin/sh/usr/lib/btsync-user/btsync-startersleep 10/usr/lib/btsync-user/btsync-stopper sleep 10btsync startGrz Eric