gmosquera

Members
  • Content Count

    9
  • Joined

  • Last visited

About gmosquera

  • Rank
    New User
  1. Hmmm, ok. This seem to work on the LAN now. Thank you for checking. Now, I have a estrange behavior: LAN | |--- Linux 1 (RO key) ---------------- < ---- | | | VPN Tunnel | Connection ok | | | | > Connection NOT ok | | | |--- Linux 2 (RO key) ----------------
  2. I see the two boxes with Linux talking to each other just fine (they have read-only key). but the FreeBSD does not find the other boxes, neither the other boxes find the FreeBSD one. The setup is as follows: LAN | |--- Linux 1 (RO key) ---------------- | | Connection ok |--- Linux 2 (RO key) ---------------- | X Does not connect |--- FreeBSD 1 (RW key) ----------- No firewalls or any other problem that I can see other than the error I saw on the log: [20140701 08:31:16.254] UDP setsockop
  3. I am running into the same problem here. Receiving the following errors on FreeBSD: UDP setsockopt(SO_RCVBUF, 2097152) failed: 55UDP setsockopt(SO_SNDBUF, 2097152) failed: 55 And nothing seem to sync. My config file should be simple enough: { "device_name": "my device", "listening_port" : myport, "storage_path" : "/folderlog/.sync", "check_for_updates" : false, "lan_encrypt_data" : true, "use_upnp" : false, "download_limit" : 50, "upload_limit" : 50, "rate_limit_local_peers" : true, "shared_folders" : [ { "secret" : "my
  4. Now you can put the option on the config file under the folder config to sync: Overwrite_Changes = true
  5. I know this is an old post, but just for the record to answer the questions here: Q1: Where do I put ("overwrite_changes" : true,) in the client config or server config? Just the Client Config. Q2: When setting up the server config file do I need both the read write and read only secrets in the shared folders section or can I just have the read only secret there? RW key on Master and RO on slaves. But remember also that slaves will sync between them once they know each other.
  6. Both systems are Ubuntu servers. There is no other peer connected to it, and just the log from Main system shows this error. The other node does not show any information about this !sync files. So my guess is that the Main system creates the !sync files back (I don't know where it's getting the info to recreate it) and the Client system is just trying to sync it. If I delete those files looks like they don;t show up again, but I was just wondering why should they reappear.
  7. Kind of the same problem here. I created 2 nodes: Main and Client for Read Only. - Set it up and both working ok. - I delete both Main and Client folders, including .Sync files - I setup new folder to sync (same keys) Everything start syncing, but suddenly I see old folder re-appearing with all .!sync files and with the log showing: [20140616 14:22:02.319] Blocked downloading file oldfoder/file due Connection closed[20140616 14:22:02.319] Blocked downloading file oldfoder/other_file due Connection closed[20140616 14:22:02.319] Blocked downloading file oldfoder/another_file due Connection
  8. I am using 2 Linux systems (ubuntu 12.04) to copy files from one to another. So my "master" server has: { "device_name": "TEST", "listening_port" : 1234, "storage_path" : "/storagepath/.sync", "check_for_updates" : false, "lan_encrypt_data" : true, "use_upnp" : false, "download_limit" : 200, "upload_limit" : 200, "rate_limit_local_peers" : true, "shared_folders" : [ { "secret" : "my secret key", "dir" : "/mydir", "use_relay_server" : false, "use_tracker" : false, "use_dht" : false, "search_lan"
  9. Same here. It would be nice to have that for the config file. Maybe next release?. Thanks dwerder for the finding. At least that will keep my setup going until there is another option.