CVBruce

New Members
  • Content Count

    1
  • Joined

  • Last visited

About CVBruce

  • Rank
    New User
  1. Hi, I was wondering if there are older versions of BTSync that support Mac OS X 10.5.8 (Leopard) running on a PowerPC G5 iMac. And if so, how would I get them. Thanks, Bruce