kaiser

Members
  • Content Count

    4
  • Joined

  • Last visited

Posts posted by kaiser

  1. Can no longer edit previous post so posing here.

    Basically I've learned to point BTSync to config file. But still WebUI doesn't work. UPnP is dissabled, config file edited, port forwarded in router. Tried many different ports - no luck.

     

    Log file:

    [20140612 11:36:27.204] total physical memory -1 max disk cache 2097152[20140612 11:36:27.206] Using IP address 192.168.1.5[20140612 11:36:27.207] Unable to listen for HTTP traffic on port 8765[20140612 11:36:27.208] Loading config file version 1.2.67[20140612 11:37:13.212] Received shutdown request via signal 15[20140612 11:37:13.213] Shutdown. Saving config sync.dat
  2. Working on Buffalo Linkstation Duo (LS-WXL). You need to change the port of the WebUI however, as you will not get any response from 8888. 8080 works fine. You will also need root access to the device of course, more info at http://buffalo.nas-c...Category:LS-WXL

     

    > wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_arm.tar.gz> tar zxvf btsync_arm.tar.gz> chmod u+x btsync> ./btsync --dump-sample-config > config.txt> nano config.txtChange:listen: 0.0.0.0:8888tolisten: 0.0.0.0:8080> ./btsync
    you might also have problems with the UPNP port mapping, then just port forward a port on your router, then change:

    listening_port: 0use_upnp: truetolistenning_port: YOUR_FORWARDED_PORTuse_upnp: false
    If anyone finds a way around the "change the web ui port" thing, please tell me. I have tried adding the ports to /etc/services, but that did not do anything... And you don't have access to iptables on the original firmware.

     

    Noob problems.

    Folowed instructions Wizt's post. Btsync is runing on my Buffalo Linkstation LS-XHL, Can't access WebUI though.

    My config file:

    {   "device_name": "My Sync Device",  "listening_port" : 8080,                       // 0 - randomize port  /* storage_path dir contains auxilliary app files   if no storage_path field: .sync dir created in the directory    where binary is located.   otherwise user-defined directory will be used */  "storage_path" : "/home/user/.sync",// uncomment next line if you want to set location of pid file// "pid_file" : "/var/run/btsync/btsync.pid",  "check_for_updates" : true,   "use_upnp" : false,                              // use UPnP for port mapping/* limits in kB/s   0 - no limit*/  "download_limit" : 0,                         "upload_limit" : 0, /* remove "listen" field to disable WebUI   remove "login" and "password" fields to disable credentials check*/  "webui" :  {    "listen" : "0.0.0.0:8080",  }/* !!! if you set shared folders in config file WebUI will be DISABLED !!!   shared directories specified in config file   override the folders previously added from WebUI.*//*  ,  "shared_folders" :  [    {//  use --generate-secret in command line to create new secret      "secret" : "MY_SECRET_1",                   // * required field      "dir" : "/home/user/bittorrent/sync_test", // * required field//  use relay server when direct connection fails      "use_relay_server" : true,      "use_tracker" : true,       "use_dht" : false,      "search_lan" : true,//  enable SyncArchive to store files deleted on remote devices      "use_sync_trash" : true,//  specify hosts to attempt connection without additional search           "known_hosts" :      [        "192.168.1.2:44444"      ]    }  ]*/// Advanced preferences can be added to config file.// Info is available in BitTorrent Sync User Guide.} 

    My log file:

    [20140611 19:08:04.211] total physical memory -1 max disk cache 2097152[20140611 19:08:04.213] Using IP address 192.168.1.5[20140611 19:08:04.214] Unable to listen for HTTP traffic on port 8888[20140611 19:08:04.215] Loading config file version 1.2.67[20140611 19:08:05.369] UPnP: Device error "http://192.168.1.35:2869/upnphost/udhisapi.dll?content=uuid:677f837c-c1e6-436c-a6e3-984c43289498": (-2) [20140611 19:09:05.239] Received shutdown request via signal 15[20140611 19:09:05.240] Shutdown. Saving config sync.dat 

    Restarted many times trying various port and setting combination. But every time I see port 8888 in log file. Maybe there's a copy of it elsewhere and BTSync uses it? 8080 port is forwarded.

    What did I miss?