Mrath

Members
  • Content Count

    28
  • Joined

  • Last visited

Everything posted by Mrath

  1. lol checking that box fixed it. Embarrassing... Thanks!
  2. The button "Get Started" when entering computer name when launching the program for the first time is greyed out. The text entry box starts with red edges, but changes to blue after I enter a few characters. But the Get Started button stays greyed out so can't click it, and enter, it does nothing. Win 7 Ultimate 64-bit, latest version of Sync. I tried both 32-bit and 64-bit versions.
  3. The latest Android app update has better support for devices with no camera according to release notes. So I scanned the QR code from my Walkman using my Xperia phone. Now both my Walkman and desktop app show the Walkman as green and connected. But I still can't get past the welcome splash screen on the Walkman, as it just asks to link an existing user or make a new one.
  4. I have Sync 2.0 set up on Raspberry Pi, transferring files to Linux Mint also running 2.0. When I delete files from Mint directory, the files are not moved to Archive directory on the RPi, and are transferred again to Mint. I guess the workaround is to delete them on both locations at the same time. How can I fix this so it works properly? Worked fine with the same setup in Sync 1.x.
  5. I have a Sony Walkman NWZ-F886, which is an Android device. After installing, I get the screen asking me to connect to an account or start a new identity. When I tap on the connect, nothing happens. Starting a new identity goes to the next screen, but I don't want to do that. Is this possibly because the device doesn't have a camera? Sync prior to 2.0 worked fine with the Walkman.
  6. I'm running the forced 30-day trial, so I believe I should be using the Pro version. I can't find an option to disable automatic sharing of folders, only that they are added in disconnected state by default, which I have enabled.
  7. I shared a folder in 2.0, which showed up and synced on my other 2.0 devices, except for one. I added that same folder manually on that machine, and now it works, also. Is the end result the same when sharing folders manually vs automatically on 2.0, or is there something I should be wary of?
  8. Sync 1.4 worked fine without having to muck about with permissions, but 2.0 gives Don't have permissions to write to selected folder.error when adding folders. I presume this is due to different way to handle permissions between the versions. I'm quite unfamiliar with Linux permissions, but I guess I could set Sync to run as root, but that would be a rather big security risk. Another option would be to add Sync to a group which has access to said folders. Any suggestions on best practices?
  9. Thanks. I already had uninstalled it, and re-installed using the link provided by WilliamL, and it works flawlessly.
  10. I copy the key starting with M from my unRAID box 2.0 client from "My Devices", "Link Device", "Link a desktop device manually", and paste it into the "link device already running 2.0" under "link a desktop manually" prompt on my Linux machine. The key is the same as on my Android and RPi, and it should be, reading the link you provided. So I think I've been doing it right. I successfully linked my RPi using the above steps, but the Linux client refuses to go past the "connecting" window following the same steps. Tangential topic: the terminology Sync is using is vague and inconsistent with previous versions. "Key for linking devices" starting with M is more like a (public?) encryption key or (public?) identity, rather than a string to link files or devices like it was in 1.4? Why not call it (public/private) user identifier, then? The Android tip worked, thanks! It takes a good minute for the list of devices to show up, and I didn't know to wait for that. A prompt saying "updating device list" would avoid this oversight. While I'm at it: back button doesn't work properly on Android client, and Sync stops Spotify intermittently. edit: nevermind. After restarting, the Linux desktop link worked Thank you, Helen!
  11. I have successfully upgraded my Linux Mint desktop, Android phone, unRAID box and RPi to Sync 2.0, but am having trouble linking the devices. First, when I scan the QR code on my Android phone, I get the following error: Both devices are already connected to a user identity. To connect these devices with a single identity, you must first disconnect one of them. You will lose access to all folders (except classic folders) and all linked devices on that deviceHow do I disconnect devices in 2.0? Also, when I try to link devices using the alphanumeric string given by Sync, my Linux Mint desktop doesn't go past "Connecting, please ensure the other device is online", although the other device is online. File syncing works fine with my RPi using the same exact alphanumeric string on the same LAN. In general, the upgrade/installation process of 2.0 is quite complicated, and if I'm to pay close to 40 EUR a year, I expect a much smoother user experience.
  12. I have 1.4 up and running on my RPi. Should I uninstall it and install 2.0?
  13. Does Sync 2.0 work with unRAID? I'm eager to upgrade and support the project, but my NAS of choice is unRAID is not listed on the official list of NASes.
  14. I can't connect to the client mode via web UI at http://127.0.0.1:8888/ (default settings), and I don't get any GUI when clicking the Bittorrent Sync from start menu. Rebooting doesn't help. Runnin pgrep -lf btsync I get the following: 2213 python /usr/bin/btsync-gui2282 /usr/lib/btsync-common/btsync-core --config /home/user/.config/btsync/btsync-agent.confwhich suggests that the GUI is running, though. I noticed there is no file /home/user/.config/btsync/btsync-agent.conf Is this as intended? Any ideas?
  15. What should I remove? I tried both sudo apt-get remove btsyncand sudo apt-get remove btsync-daemonand Sync is still installed and working after reboot. Below what pgrep -lf syncgives: 1438 /usr/lib/btsync/btsync-daemon --nodaemon --config /etc/btsync/debconf-default.confAlso, I still don't know whether I'm running the server or desktop version. How can I tell?
  16. My Sync is 1.2.67, and claims to be up-to-date, and apt-get update doesn't do anything. This might be related to the lack of updates: how do I find out whether I have installed the Server or the Desktop version? If I have the server installation, I should probably uninstall as I should be using desktop instead - how do I uninstall this?
  17. Thanks, Helen. I guess I'll have to rebuild my setup. My permissions haven't changed, and Sync survived several reboots before this happened. This is a rather big issue, as if that happens occasionally I have to rebuild my entire Sync setup, which is a major PITA. Where does Sync save folders synced on Linux systems so I can back up my config? If Sync doesn't have a robust crash recovery and a way to avoid this, or at least rebuild easily, might need to go with a more reliable solution like rsync. This thread seems to be a similar issue, and especially Tuxpoldo's response.
  18. I have Sync set up on my Raspberry Pi running Raspbian. I access it with my Linux desktop browser on my home network. All of a sudden I can't log into Sync, and was requested to create a new user. I did so, but when I go to add a folder which was previously assigned to the old non-functioning Sync, I get the error "This folder is already owned by another Sync instance. Do you want to reset ownership?" So it appears my old Sync installation is still somewhere on the Raspi, but not accessible. Can I reset the ownership to the new instance of Sync, or is there a way to recover the old installation?
  19. Got it to work! Starting with the command ./btsync --webui.listen 0.0.0.0:8888 worked, as long as you are in the btsync folder on your Pi. For me that is ~/.btsync Another option is starting with the sample config file using command ./btsync --config ./btsync.config , and that works as well. Incidentally the sample config file I received by running command ./btsync --dump-sample-config >btsync.config has webUI enabled by default. Thank you! Now I have to figure out how to change permissions to the external HDD on RPi, as folder permissions are a nightmare in Linux.
  20. I'm a newbie, so I don't know what "loopback" is I gather I need to enable the WebUI so I can control Sync on my (headless) Raspi? Reading through the FAQ in your sig, should I add the following to my btsync config file? ./btsync --webui.listen 0.0.0.0:8888 If so, where is that file located, and what IP should I use to connect to the WebUI using my desktop? The IP doesn't really matter to me, so whatever works is fine
  21. I followed the instructions to install Sync on Raspberry Pi on the blog. wget fails as I believe the Amazon link in the blog entry to the ARM build is dead, so I downloaded 1.4.103 ARM build from getsync.com. I got it to install on my RPi, confirmed by the CLI entry "BitTorrent Sync forked to background. pid = 2372. default port = 8888". But when I use the browser on my Linux Mint desktop to go to 192.168.1.219:8888/gui , I get a "Unable to connect" error. I have confirmed that the IP is correct by double-checking ifconfig on my RPi, and I am successfully running Sync on my Linux desktop with other machines on the LAN. Any tips?