cbeckerle

New Members
  • Content Count

    1
  • Joined

  • Last visited

About cbeckerle

  • Rank
    New User
  1. Hello! I has Sync 2.0 (dont remember wich version) running on OSX 10.7, i updated today to latest and OSX 10.7 is not supported anymore. Where i can get Sync past versions? Thanks Cristian