Search the Community

Showing results for tags 'Linux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 213 results

  1. I have a key for a filesync folder: https://link.getsync.com/#f=Base&sz=...&v2.2 I want to share it from my laptop to my server. My server has no GUI (graphical user interface) - Ubuntu command line only. How do I sync the folder to my server without installing a graphical user interface?
  2. I think it could be useful to set a custom selection of columns on the webui (linux) and to keep it in a persistent way until a new configuration is set. Thank you.
  3. Hi guys, I am having a strange problem, after I ran some updates (I think) on my ubuntu server that is running btsync on I am unable to access the webui. When I go to http://192.168.1.14:8888 or http://192.168.1.14:8888/gui/ all I get is "invalid request". It was all working fine before but now I can't seem to be able to access it no matter what I do. My other btsync devices are still connected to that server so it is working as it should. Only the webui is broken. Do you guys have any idea what the problem might be? Thanks, Gilli
  4. I had an old version (1.4) installation running in my ubuntu 14.04 installation. After I got a notification in the web-frontend to upgrade, I downloaded the new 2.0 version of Bittorrent Sync and tried to install it. As the old version was still installed I initially failed to do so. So I removed the Binaries (=the file I installed wtih 1.4), removed the btsync packages I found in the software manager and several hidden folders connected to Bittorrent sync (hope I got all). I could finally install the 2.0 version and start the webgui but seem to have misspelled the password I set up for the webgui as I now cant login to the localhost:8888 gui anymore. I fail to remove the 2.0 installation in a way that i could after reinstallation setup the password again. After each re-installation I am asked to enter the password which I dont have. Therefore my question: How can I remove the bittorrent sync installation completely under ubuntu? (Folders so far removed the folder with the binaries and all hidden folders within. the hidden btsync folder one hierachy higher (user folder))Or how can I reset the password for the webgui? (is there a config file? And where?) Thanks a lot for helping me out!
  5. Hello, we deployed BTSync 1.2.91 (i386 linux version) on 4 linux machines, 1 CentOS and 3 NAS TS-269 (linux-based operating system QTS). I noticed that on various occasions CPU load as dislayed by the top utility shows btsync running at the top with high cpu loads over 85%, often peaking to 99.9%. Some machines reached a consistent 99.9% level after about a day. When the porcessed reached 99.9%, GUI responds slowly, some synced folders appear not to be synchronized (at least in GUI) and there seem to be hanging (infinitely pending) transfers. I noticed similar behavior with version 1.2.82, where CentOS process often crashed with segfault and QTS machines as if "accumulated" load until 99.9% when they stopped working, although the process itself did not crash. Temporary solution implemented is periodical restart of btsync every two hours. After restart, btsync starts at low CPU loads (1 to 10%) and is getting busier as time passes. Before it becomes completely dead it is gracefully restarted by a cron job. Could this be answer to some of you guys who reported insanely slow download speeds? Regards, Jindrich Vavruska
  6. Hello, I need sync the same folder but in different computers, Is it possible?. Thanks.
  7. Hello QNAP Model: TS-809U Firmware version: 4.1.0 Bittorrent Sync verison: 1.3.109 Linux version: 3.4.6 (root@NasX86-13) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 Normally, by default, Bittorrent Sync runs on linux as the user: “root” and group: “administrators” and writes these owner:group permissions to syncronized files and folder that it creates. In the case of the QNAP NAS, Bittorrent Sync writes files and runs as the user “admin”. I have successfully managed to enforce all sub-folders and files in my sync folder to inherit the group “btsync” in the file permissions by using: chown admin:btsync /syncchmod g+s /syncThe problem is that Bittorrent Sync creates new files and folders with read-only permissions for the group “bysync” (i.e. wxr-xr-x / octal 0755). From researching I have found that the 2 ways to change this normally would be: 1) Add this line to the btsync.conf file and restart btsync: // DAEMON_UMASK=0022) Use the following command and when prompted enter "002" as the umask dpkg-reconfigure btsyncNeither of the 2 above methods resolve the issue. In the case of item 1, this setting seems to be ignored by btsync. With item 2, “dpkg-reconfigure” is not a command available on the version of linux used by the QNAP NAS. Thank you in advance for your help!
  8. Update: midway through this post I tried running BT Sync as root, group btsync, and it works. I don't like it, but it works. There is some awful permission-hell happening but I hope this helps someone. Hi, I've spent four days trying to resolve this, and I really am stumped. I can't get BTSync to write to a CIFS mount which is in my home directory, and which is used by various other programs and scripts perfectly fine. What's odd is that when creating a new folder in BT Sync's Web Gui, this is created in the CIFS share correctly, but no files can be synced and it displays the error "Don't have permissions to write to selected folder". I've tried changing the mount parameters to include 0777 file_mode and dir_mode (as listed here). After chmodding 777 to the folder I've also tried, successfully, in SSH: sudo -u btsync touch boo.cBut, still, the error above persists.
  9. Hello I downloaded the latest stable version of bittorrent sync for linux to my VPS. I used this howto: https://whatbox.ca/wiki/Bittorrent_Sync Here is my configuration file: { "device_name": "My Sync Device", "listening_port" : 0, // 0 - randomize port/* storage_path dir contains auxilliary app files if no storage_path field: .sync dir created in the directory where binary is located. otherwise user-defined directory will be used */"storage_path" : "/home/roberth1990/.btsync",/* set location of pid file */// "pid_file" : "~/btsync/btsync.pid",/* use UPnP for port mapping */ "use_upnp" : true,/* limits in kB/s. 0 - no limit */ "download_limit" : 0, "upload_limit" : 0,/* proxy configuration */// "proxy_type" : "socks4", // Valid types: "socks4", "socks5", "http_connect". Any other value means no proxy// "proxy_addr" : "192.168.1.2", // IP address of proxy server.// "proxy_port" : 1080,// "proxy_auth" : false, // Use authentication for proxy. Note: only username/password for socks5 (RFC 1929) is supported, and it is not really secure// "proxy_username" : "user",// "proxy_password" : "password", "webui" : { "listen" : "0.0.0.0:49539" // remove field to disable WebUI/* preset credentials. Use password or password_hash */ ,"login" : "roberth1990" ,"password" : "******"// ,"password_hash" : "some_hash" // password hash in crypt(3) format// ,"allow_empty_password" : false // Defaults to true/* ssl configuration */// ,"force_https" : true // disable http// ,"ssl_certificate" : "/path/to/cert.pem"// ,"ssl_private_key" : "/path/to/private.key"/* directory_root path defines where the WebUI Folder browser starts (linux only). Default value is / */ ,"directory_root" : "/home/roberth1990/files/"/* directory_root_policy defines how directory_root is used (linux only). Valid values are: "all" - accepts directory_root and its subdirectories for 'getdir' and 'adddir' actions "belowroot" - accepts directory_root's subdirectories for 'getdir' and 'adddir' actions, but denies attempts to use 'adddir' to create directories directly within directory_root Default value is "all". */// ,"directory_root_policy" : "all"/* dir_whitelist defines which directories can be shown to user or have folders added (linux only) relative paths are relative to directory_root setting */// ,"dir_whitelist" : [ "/home/user/MySharedFolders/personal", "work" ] }/* !!! if you set shared folders in config file WebUI will be DISABLED !!! shared directories specified in config file override the folders previously added from WebUI. *//*, "shared_folders" : [ { "secret" : "MY_SECRET_1", // required field - use --generate-secret in command line to create new secret "dir" : "/home/user/bittorrent/sync_test", // * required field "use_relay_server" : true, // use relay server when direct connection fails "use_tracker" : true, "use_dht" : false, "search_lan" : true, "use_sync_trash" : true, // enable SyncArchive to store files deleted on remote devices "overwrite_changes" : false, // restore modified files to original version, ONLY for Read-Only folders "known_hosts" : // specify hosts to attempt connection without additional search [ "192.168.1.2:44444" ] } ]*//* Advanced preferences can be added to config file. Info is available at http://sync-help.bittorrent.com */}I started bittorrent sync and tried to access it via http://taurus.whatbox.ca:49539/ as instructed in the howto, but it just loads for a long time and returns with "This webpage is not available" EDIT: Okay, I checked top, and it is obvious that it is shutting down as soon as webui tries to access it but, the webui doesn't return with "This webpage is not available" after while, so it wasn't obvious to me at the same time as I didn't check top. Here is the log: platform: Linux 3.15.2-hardened-whatbox #1 SMP Wed Jul 2 05:37:50 UTC 2014 x86_64version: 2.0.105[20150420 15:14:28.170] Can't copy file /home/roberth1990/.btsync/settings.dat - 2 No such file or directory[20150420 15:14:28.179] total physical memory 536870912 max disk cache 2097152[20150420 15:14:28.189] Using IP address 95.211.194.178[20150420 15:14:28.190] Unable to listen for HTTP traffic on port 49539. Exiting...[20150420 15:14:28.193] My PeerID: 10A4082A41D3A52DDC5B965B004F6BEAA954FE02[20150420 15:14:28.209] Can't copy file /home/roberth1990/.btsync/sync.dat - 2 No such file or directory[20150420 15:14:28.209] Can't copy file /home/roberth1990/.btsync/history.dat - 2 No such file or directory[20150420 15:14:29.210] Shutdown. Saving config sync.dat[20150420 15:16:57.063] total physical memory 536870912 max disk cache 2097152[20150420 15:16:57.073] Using IP address 95.211.194.178[20150420 15:16:57.073] Unable to listen for HTTP traffic on port 49539. Exiting...[20150420 15:16:57.076] Loading config file version 2.0.105[20150420 15:16:57.076] My PeerID: 10A4082A41D3A52DDC5B965B004F6BEAA954FE02[20150420 15:16:58.107] Shutdown. Saving config sync.datWhat am I doing wrong?
  10. Hi, I have a problem with btsync triggering my external usb disk to spin up when there is no transfers going on. I'm using BitTorrent Sync to sync some folders that usually don't change much. I'm running it on a Raspberry pi, Windows and Android. Since the Raspberry pi doesn't consume much power, I leave it on all of the time. However, since there are some days in which the content of the folders don't change at all, I am very interested in getting the USB hard disk connected to the pi to spin-down. The spinning-down works well, I am using a tiny program called hd-idle. The problem is that btsync seems to spin-up the disks every half an hour... This is an extract of the logs from hd-idle: date: 2013-07-31, time: 16:30:57, disk: sda, running: 901, stopped: 900 date: 2013-07-31, time: 17:01:00, disk: sda, running: 903, stopped: 900 date: 2013-07-31, time: 17:31:07, disk: sda, running: 907, stopped: 900 date: 2013-07-31, time: 18:01:14, disk: sda, running: 907, stopped: 900 date: 2013-07-31, time: 18:31:21, disk: sda, running: 907, stopped: 900 date: 2013-07-31, time: 19:01:30, disk: sda, running: 908, stopped: 901 date: 2013-07-31, time: 19:31:36, disk: sda, running: 906, stopped: 900 As you can see, the disk is spinning ("running" in the logs) for around 900 seconds. As per the configuration, the disk is spun down after 900 seconds idle, but it only remains so for 900 seconds, when it's awaken by an application. If I stop btsync this behaviour also stops, and the disk sleeps much much longer, so I know that btsync is causing this. I've tried changing some setting in the config file, specifically I've added the "advanced" option "folder_rescan_interval" : 86400, but it has not changed anything. Any ideas to keep btsync from from spinning up my disk every 30 minutes?
  11. Currently have a running system between two computers (two Ubuntu servers) running v1.4. I have resisted upgrading to v2.0 until I added my third computer (Debian server) to the mix. That third computer is now functional. I intend to add the third computer with v1.4. After I am sure everything is functioning properly (and the third computer bittorrent directory is populated) then I would upgrade all machines to v2.0. (All computers are non-gui cammand line servers.) Does this computer addition/upgrade sequence seem illogical? Am I overlooking anything?
  12. So, running btsync on linux (64bit nixos), it is creating a new identity everytime I reboot the server. The btsync user: btsync:x:113:498:Bittorrent Sync Service user:/srv/data/btsync2:/run/current-system/sw/bin/nologin His home directory: drwx------ 1 btsync btsync 252 Apr 14 14:48 /srv/data/btsync2 The config file: { "device_name": "fancydevicename", "storage_path": "/srv/data/btsync2", "listening_port": 45654, "use_gui": false, "check_for_updates": false, "use_upnp": false, "download_limit": 0, "upload_limit": 0, "lan_encrypt_data": true, "webui": { "login": "admin", "password": "reallysecurepasswordhere", "listen": "0.0.0.0:9000" } } I start btsync: btsync --nodaemon --config btsync.conf and look in it's home directory. [btsync@albion:~]$ ls -lA /srv/data/btsync2 total 2356 -rw-rw-rw- 1 btsync btsync 222 Apr 14 14:48 13083713615926578068.1429022881.journal -rw-r--r-- 1 btsync btsync 7168 Apr 14 14:48 ECF22524AAD0FADACEA007EAECD9926EB62196AC.db drwxrwxr-x 1 btsync btsync 2 Apr 14 14:48 License -rw------- 1 btsync btsync 1778 Apr 14 14:48 settings.dat -rw-rw-r-- 1 btsync btsync 121207 Apr 14 14:48 sync.lng -rw-r--r-- 1 btsync btsync 5 Apr 14 14:48 sync.pid -rw-rw-r-- 1 btsync btsync 2267622 Apr 14 14:48 webui.zip login, accept the licence + create identity (hitting the first bug: it prompts me that there is a new version despite "check_for_updates" being false), the directory now looks like: [btsync@albion:~]$ ls -lA /srv/data/btsync2 total 2396 -rw-rw-rw- 1 btsync btsync 222 Apr 14 14:48 13083713615926578068.1429022881.journal -rw-rw-rw- 1 btsync btsync 542 Apr 14 14:49 18374772040707393072.1429022966.journal -rw-r--r-- 1 btsync btsync 7168 Apr 14 14:49 4253E36490F603239A065B33DFD1EAE52029F861.db -rw-r--r-- 1 btsync btsync 2128 Apr 14 14:49 4253E36490F603239A065B33DFD1EAE52029F861.db-wal -rw-r--r-- 1 btsync btsync 7168 Apr 14 14:48 ECF22524AAD0FADACEA007EAECD9926EB62196AC.db -rw-r--r-- 1 btsync btsync 4224 Apr 14 14:49 ECF22524AAD0FADACEA007EAECD9926EB62196AC.db-wal drwxrwxr-x 1 btsync btsync 2 Apr 14 14:48 License -rw------- 1 btsync btsync 2168 Apr 14 14:49 settings.dat -rw------- 1 btsync btsync 1778 Apr 14 14:48 settings.dat.old -rw------- 1 btsync btsync 5376 Apr 14 14:49 sync.dat -rw-rw-r-- 1 btsync btsync 121207 Apr 14 14:48 sync.lng -rw-r--r-- 1 btsync btsync 5 Apr 14 14:48 sync.pid drwxrwxr-x 1 btsync btsync 78 Apr 14 14:49 .SyncUser1429022966 -rw-rw-r-- 1 btsync btsync 2267622 Apr 14 14:48 webui.zip I add a test share; all seems good. Restart the service: yup, all OK here. Reboot the machine and when logging into the gui, I get the licence box again. If I click through (the only option), my shares are gone, and looking in ~btsync a new SyncUser dir has been created: drwxrwxr-x 1 btsync btsync 78 Apr 14 14:49 .SyncUser1429022966 drwxrwxr-x 1 btsync btsync 0 Apr 14 14:59 .SyncUser1429023540 How do I stop it generating a new ID for itself? Log files (from a recreate) uploaded as gists here: https://gist.github.com/cwoac/c1b7e14ccca831f2ab0e
  13. Hallo, as I haven't found an answer to this question I'll just try it here. My assumption is that the "Sync with..." status of peers is chaining such that peers appear as synced (and online) even though this information is only available through one of the peers. Can somebody confirm that? Let me explain my setup. I am using BitTorrent Sync without tracker and relay server. Those are disabled for every folder on every machine and instead predefined hosts are used to talk to the other peers. I am using two 24/7 linux servers behind a NAT-router without upnp where only one of the servers has the BitTorrent Sync port forwarded through the router firewall. Currently me and my MacBook are in a totally different city. I resolve the mentioned NAT router through DynDns and only added the forwarded port to the predefined host list of the MacBook client. Interestingly I can see 2 relays synced (and online) even though my MacBook should only be able to talk with 1. I'd love to see this chaining feature confirmed. Or is there something I am missing? -- ankoh
  14. Hey Loving what you've done, saw a thread which mentioned emailing in with tech questions. I'm an Ubuntu developer and wanted to have a play with Sync on our Ubuntu Touch image on an ARM device to test syncing files between desktop and phone. https://wiki.ubuntu.com/Touch I grabbed the arm build and upacked it on the phone, but it fails to start:- phablet@localhost:~$ file ./btsync ./btsync: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, stripped phablet@localhost:~$ ./btsync -bash: ./btsync: No such file or directory Perhaps I'm missing a library? We only support ARMv7, maybe it's a v6 binary? Maybe it's non-multiarch? Would love to get this working. Happy to test further.
  15. Hi All What is the easiest / best way to get btsync to start when a CentOS server starts up? Thanks David
  16. The problem I manually rsynced a large mp3 directory to an ext4-formatted micro SD card on my Linux computer, proceeded to mount the card on my Cyanogenmod 11-equipped Galaxy S5 with correct permissions, and added the directory to the Sync app with a read-only key. When syncing it manually on the phone, it will start "Receiving" but never finish, with a minimal ~7B/s transfer rate. Details The music folder in question contains 17.07GB and 2872 files. The files are mostly mp3s ranging from 1 to 10 MB in size.The folder syncs successfully between two Linux computers running Ubuntu 14.10, Ubuntu 14.04, and Sync 1.4.103 in the same local (Wifi) network.There's nothing encrypted in the directory.It's music, so filenames vary wildly. There are no characters that are illegal to FAT32 (even though the SD card is now formatted as ext4).The phone is running Cyanogenmod 11 (based on KitKat 4.4.4), but the Cyanogenmod developers have reverted the SD card permission restrictions. I did have to manually change the permissions of the files/directories on the SD card, though (chown -R media_rw:media_rw /media_rw/sdcard1, chmod -R ug+rw /media_rw/sdcard1).Things I tried This problem originally appeared on the Galaxy S5's stock KitKat 4.4.2 ROM. Rooting it and editing /system/etc/permissions/platform.xml solved the (then FAT32) SD card permissions issue, but Sync wasn't able to finish syncing the mp3 folder either. Figuring this might be due to some other arbitrary restriction imposed by Samsung or my carrier, I flashed the latest Cyanogenmod 11 nightly available for my phone, and tried again: no luck. I resorted to formatting the card with ext4, thinking the problem might be related to a FAT32 limitation. One again, no luck. Finally, I tried enabling the tracker server and relay server options for this folder on the Linux boxes. No good, either. What next? Any ideas as to what I might try next? Thanks!
  17. Running btsync on Linux will by default create a *publicly-accessible, unprotected* WebUI, allowing anyone on the web to create a sync folder to view and edit files your files (i.e. files in directories writable by you). Could the defaults (used when running btsync without a config file) be changed to prevent this unintended data leak? A temporary workaround is to run `killall btsync` to turn off the WebUI, and then use --config with a config file that sets webui > password to a secure password. You can use `lsof -i` to verify that the WebUI is not running.
  18. I'm trying to run btsync on my NAS which runs linux on an ARM processor. Here's what I get. root@fileserver:/mnt/HD_a2/btsync# ls -l total 6688 -rw-rw-r-- 1 nobody 502 155 May 7 09:16 LICENSE.TXT -rwxrwxr-x 1 nobody 502 3412684 May 15 08:41 btsync -rw-r--r-- 1 admin 500 3420160 Jun 21 21:25 btsync_arm.tar root@fileserver:/mnt/HD_a2/btsync# ./btsync -sh: ./btsync: No such file or directory Any thoughts as to why this is? Thanks.
  19. I've set up a linux server with bittorrent sync. The folders are on an external HDD drive. After almost 24h it finally finished indexing - yes the server is slow - but the HDD still doesn't spin down. This is a little troubling, I'm sure the external HDD is not supposed to run non-stop. Apparently this is connected to the indexing intervals. Sync will check the folder for changes every 10 minutes and that keeps the HDD from spinning down. I need to adjust this indexing interval. This seemed perfect: http://help.getsync.com/customer/portal/articles/1570790-can-i-change-how-often-sync-checks-for-file-changes- Unfortunately in my advanced settings there is no option to change the interval (linux web ui). I've read that the interval can also be set by a config file which is given to the executable via the --config flag. Great, but I still need to get that config file. I dumped a sample config file, which would need to be adapted, but before I do that, I have two questions : 1. Is it possible to get the "current" config file ? Which contains the configuration, that btsync uses right now, eg correct folders, correct ports, correct user-name ? I'm afraid that passing a config file will mess up the folders that are already indexed. It would be a shame if another 24h were lost on that. 2. If the "current" config file is not available, if I have to adjust the sample config, what do I need to change ? Which settings are important and which are dangerous ? I tried to find a tutorial which tells me where to be careful, but so far, I haven't found it.
  20. I have an Illumos NAS at home (OmniOS) as a VM. Another VM is an Ubuntu 12.04.4 LTS x64 VM. On OmniOS I have a userdir (ZFS DataSet) that has 3 folders (Documents, Pictures, Videos). Each of these folders is NFS shared to my Ubuntu VM as my user (same UID=1000). That same OmniOS zfs dataset/userdir is shared via CIFS. So as an example: OmniOS Ubuntu CIFS from OmniOS /tank/joltman/Documents /home/joltman/Documents \\10.0.0.50\joltman\Documents I have btsync (1.3.92) on the Ubuntu headless server VM. It shares out the /home/joltman/Documents to other btsync devices (my Windows 8.1 x64 Pro laptop). I can successfully, add/change/remove a file on my laptop and the file will get pushed to the Ubuntu server and it's changed successfully. Awesome! However, if from another Windows machine, I push a file to \\10.0.0.50\joltman\Documents\, my laptop will not update the file (even after 10 minutes). If I restart the btsync daemon, the file gets updated. If I login to the btsync webpage on Ubuntu, the file gets updated. It doesn't seem to happen automatically. I don't think this is a huge issue, but it's something I noticed. It's most likely an issue because I'm pushing a file to the CIFS link (which runs through OmniOS) and not to a SMB share from the Ubuntu VM. I'm just curious if others have had this issue and if there's anything I can do to solve it? Thanks!
  21. I'm using sync 1.4 on linux systems. It works very well except on one box. This particular box has just rebuilt with a fresh in stall of linux and bittorrent sync and we are having the same problem. I'm trying to have a number of systems sync to a common directory on a server (since the server is up 24/7). 2 of the 3 systems work flawlessly moving back an forth the few files that have changed. But one of the system takes many minutes (as many as 30) to sync up even though there are just a handfull of files that have changed. While the sync is happening bittorrent sync says "out of sync" indexing. When I check the peer list - it shows that there are 5.5 gigs in 4979 files. But only a few files representing a few hundred megs have changed. Is there some special configuration that I should be implementing to create this centralized cloud environment? Thanks, Wayne
  22. Hello, Quick question here. Also, new to this forum and really like the advances in this sites tec have taken of late with being the most impressive in my eyes. My current set up is centos/linux digital ocean mac air. I have a non SSL (could not configure with after many tries) running for the VPN with my mac. Ideally, what i want to do is make it so that my files are removed from my mac air as soon as the sync with the linux preventing my storage to be full. Is it just a matter of me not disconnecting to the folder with the mac? I tried to move the files out from the shared of the server to another folder on my ftp but it did not work and lost the files. Also, should i really look into setting up the ssl? how do i know my current operation is safe? any tests i can run to have peace of mind? of course privacy is a concern and i'm not very tech. any assistance is greatly appreciated.
  23. I've been using BTSync for a while now and it's absolutely fantastic! I've just set it up to sync a load of my files between my computer, an external hard drive in my house connected to a Raspberry Pi, and a second Raspberry Pi and external hard drive in my parents house. This had been working very well but today I rebooted the Pi at my parents house and when it came on the GUI (ipAddress:8888/gui) prompted for an account to be created and then showed the no folders message. On the other syncing devices it shows it as offline. I copied the contents of the .sync folder somewhere else so I could preserve it. Looking inside I saw that there were files called history.dat.old, settings.dat.old and sync.dat.old along side the same files without the .old extension. history.dat.old and sync.dat.old contain different things to their "new" counterparts but settings.dat.old appears to be the same (although it is just one long line so I may well have missed something). I tried renaming the .dat.old files to be the .dat files and the .dat files to be the .dat.old files and then restarting again but basically the same happened again. I've got quite a number of large folders synced between the two so I'd really rather not have to redo all the syncing if I can possibly avoid it. More than that I'd like to know how it happened and how I can stop it from happening again. Any help would be greatly appreciated.
  24. Hi there! My btsync service will no longer start on my Arch laptop. systemctl status shows: btsync[4925]: Can't open pid file /usr/bin/.sync//sync.pid. Permission denied There is a file at /usr/bin/.sync/sync.pid, so I guess the double slash is just wrong. How do I point btsync to the correct location? Thanks for any help.
  25. Hi, I've been using btsync since the very early beta days, and it's great for my needs. One thing that I noticed was that I had migrated my data from an old system to the new system, and the system name still reflects the old system. Upon going into the configuration in 1.4.103 (updated yesterday), I went to change the name of the system, only to find the Edit button wasn't there. Doing a little research, it seems that there are two formats for the config file - an old (binary) format, and a new text-based format. My systems all use the binary format. Is there a way to convert the configuration to the new text format so I can change the system name? I've got a number of directories set up to sync, and would rather not have to set them all up again. Thanks!