Search the Community

Showing results for tags 'raspbian'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 9 results

  1. I wanted to get Sync working on my Raspberry Pi, and used this guide to help me: https://www.resilio.com/blog/sync-wd-raspberry-pi I was able to get the web Gui to work so I could access the sync with Windows, but it wouldn't grant me access to any of the folders I wanted to sync. Using a different guide on this forum, I edited my config file to be this: { "listening_port" : 0, "storage_path" : "/home/pi/data/.syncsystem", "pid_file" : "/home/pi/data/.syncsystem/btsync.pid", "use_upnp" : true, "download_limit" : 0, "upload_limit" : 0, "delete_folder_from_disk" : true, "folder_defaults.delete_to_trash" : true, "webui" : { "directory_root" : [ "/home/pi/share", "shares" ] "listen" : "0.0.0.0:8888", }, "vendor" : "PiDrive", "display_new_version": false } After a reload, the web gui was gone, and this showed up instead: I reinstalled the btsync service, deleted it (and installed again), rebooted several times, and tried to play around with the config, and I could never get back to the web gui that I had originally. It seems not even the Raspberry Pi itself can reach it, and I wonder if it's even on. I'm still fairly new to the Pi, if anybody have any suggestions to solve this, let me know.
  2. I have been trying to run resilio-sync as a personal backup cloud for my phone for a few weeks, using a raspberry pi 2 and an external HDD. I've installed following the instructions here: https://www.resilio.com/blog/official-linux-packages-for-sync-now-available and made sure I enabled automatic startup with: sudo systemctl enable resilio-sync no problems so far, until I try to acess the webgui and setup my folders in the HDD (permission error) So I edited the file in /etc/resilio-sync/config.json and added the line "directory_root" : "/pathtodrive", I stopped the service, and used the config file with: sudo rslsync --config /etc/resilio-sync/config.json At that time everything looks fine and I can add my folders without any problem. Unfortunately, whenever I reboot the pi, or it gets powered down, I always need to stop the service and point it to the config file on reboot, because the configurations get "lost" somehow. My directory_root folder disappers from the preferences in the webgui, and the folders I setup are not longer there. Shouldn't my configurations be used everytime the service starts? Why do I always have to configure sync manually? I think I'm missing something. This is my status report BTW: sudo service resilio-sync status ● resilio-sync.service - Resilio Sync service Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled) Active: active (running) since Mon 2017-01-02 23:14:15 GMT; 8h ago Docs: http://help.getsync.com/ Process: 577 ExecStart=/usr/bin/rslsync --config /etc/resilio-sync/config.json (code=exited, status=0/SUCCESS) Process: 571 ExecStartPre=/bin/chown -R rslsync:rslsync /var/run/resilio-sync (code=exited, status=0/SUCCESS) Process: 561 ExecStartPre=/bin/mkdir -p /var/run/resilio-sync (code=exited, status=0/SUCCESS) Main PID: 657 (rslsync) CGroup: /system.slice/resilio-sync.service └─657 /usr/bin/rslsync --config /etc/resilio-sync/config.json Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable. I've been trying to solve this for weeks now...
  3. Hi, I've recently moved from Sync to Resilio on a Raspberry Pi running Raspbian. I had to restart the computer it's installed on and now when I go to the WebGui there aren't any of the settings or folders I had configured. This includes the licence file to upgrade to Pro. I followed the instructions at: https://help.getsync.com/hc/en-us/articles/206178924 and all of the folders being synced are owned by the same user. Is there anything I can do to refresh to the previously set settings or is there anything I have overlooked in the install to prevent this happening next time I restart? Resilio and it's predecessor are great and I use it all the time. I don't want to migrate away from it if settings don't persist after a restart! Harold
  4. Hi, I recently purchased Sync Pro from Resilio, but it seems to be having issues on my headless Raspberry Pi 3 backup server. My setup is as follows: Raspberry Pi 3 with Raspbian Jessie Lite Resilio Sync 2.4.1 for Linux ARM During the install process, I've created the following Sync configuration file: { "device_name": "Raspberry Pi Backup", "listening_port" : 0, "pid_file" : "/var/run/btsync.pid", "use_upnp" : true, "download_limit" : 0, "upload_limit" : 0, "webui": { "listen" : "0.0.0.0:8888", "login" : "admin", "password_hash" : "MY_HASH_HERE" }, "recv_buf_size" : 64, "send_buf_size" : 64, "max_file_size_for_versioning" : 250 } I've successfully synced a few folders, but now the process seems to die about midway through new folders. The only way to get it back is to reboot the Raspberry Pi because restarting the process asks for a Sync id again rather than using the already existing id. I've read in the forums that Sync has some issues with memory management. Does this mean Raspberry Pi devices should not be used? I thought NAS drives have low memory too, so how come those work? Any information would be helpful. My goal here was to back up the various directories in my Mac user directory to the Raspberry Pi. Thanks,
  5. Hello! I've tried to update from bittorrent sync to resilio sync on my Raspberry Pi today. When I try to install it (using the official instructions https://help.getsync.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux), it does not launch, providing the following error: pi@raspberrypi:~ $ /usr/bin/rslsync Illegal instruction I've tried both arch=armhf and default packages. Is it possible to launch the resilio sync on Raspberry Pi?
  6. Hi folks, I was wondering if there is an official and recent guide (2016) to install Btsync on Raspberry Pi. From what I could gather, there are two ways: 1. Via official repo. Info source: http://blog.bittorrent.com/2016/02/18/official-linux-packages-for-sync-now-available/ This method installs fine for me, but web ui is not accessible sudo sh -c 'echo "deb http://linux-packages.getsync.com/btsync/deb btsync non-free" > /etc/apt/sources.list.d/btsync.list' wget -qO - http://linux-packages.getsync.com/btsync/key.asc | sudo apt-key add - sudo apt-get update sudo apt-get install btsync 2. Via dpkg and official deb package. Source: https://forum.resilio.com/topic/42569-latest-desktop-build-238/ This method assume "pi" as a default user, and I haven't figured it out how to run and install on OSMC. I tried editing /etc/init.d/btsync but confused as I believe Debian is not using init.d anymore and it is all via systemd? cd ~/ sudo mkdir Temp cd Temp sudo wget https://download-cdn.getsync.com/2.3.8/PiWD/bittorrent-sync-pi-server_2.3.8_armhf.deb sudo dpkg –i ~/Temp/bittorrent-sync-pi-server_2.3.8_armhf.deb Your help is appreciated.
  7. I have a raspberry pi where I'm attempting to install btsync using the official deb package from here. I downloaded the deb using wget. Ran as sudo dpkg -i http://syncapp.bittorrent.com/2.2.2/bittorrent-sync-pi-server_2.2.2_armhf.debPackage appears to install but the btsync service start silently fails. When I run 'service btsync status' I get 'btsync for USER pi: not running'. When I try and start it via command line with either 'service btsync start' or 'sudo service btsync start' it tries to start but silently fails. Status once again reveals 'btsync for USER pi: not running'. Any ideas of what could be going wrong here?
  8. Hello it's me again. I sill have some issues (while it's been a while since I had to complain) edit : fixed with: dpkg-reconfigure btsync select run as : root/root I have a internet box whith NAS function. So I started d/l my 100GB music on this NAS, using btsync 1.3.93 on my laptop with ubuntu 14.04 x86-64 I downloaded some 30 GB before I received my raspberry pi, for the sole purpose of handling this task. I just installed raspbian on it, it is working very good. HOWEVER I installed btsync, using the repository available for my Pi, and after reindexing the files, it started downloading the missing GB. It's not doing anything actually, and the log files contain several of this two-line error (actuallyone for each file remaining to download) : [20140521 22:15:51.129] TorrentFile: Failed to create empty suffix for file "/media/freebox/Musiques/flac/Poncho Sanchez/1999 - Latin Soul/02 - Ven Pa Bailar.flac" - 13 [20140521 22:15:51.130] SyncFilesController: failed to load torrent for file "/media/freebox/Musiques/flac/Poncho Sanchez/1999 - Latin Soul/02 - Ven Pa Bailar.flac" I tried to restart the daemon, but as soon as it is ready it spams those errors. Am I supposed to delete the full NAS directory to get my files back ? I made a sudo chmod a+rwx -R in the mounted directory but this does not work.
  9. Hello everyone. I got my Raspberry Pi today and I followed the following instructions followed on this website. http://jack.minardi.org/raspberry_pi/replace-dropbox-with-bittorrent-sync-and-a-raspberry-pi/ The instructions were really easy to follow. But I ran into a few issues that I'd like to hear your opinion about. I would like to change the trash time. On windows and Mac OS it's easy to change from 30 days to 45 or 180 or whatever. How can I modify it? I ran into a storage problem. I used the following command lines to format the USB drive to test it out. df -h # find your drive here, e.g. `sda1`sudo umount /dev/sda1 # replace sda1 with your drive name !sudo mkfs.ext4 /dev/sda1 -L BTSync # replace sda1 with your drive name ! It created a volume called BTSync just like in the guide. I didn't have BTSync_ until after I restarted. I don't understand why there are these 2 folders were created (BTSync and BTSync_). Can someone explain why there are these 2 folders when I only created one? Well, to the main issue: I have multiple folder secrets and I want to sync multiple secrets! I can't. I went into the file explorer and tried to create the folder and it said I didn't have permission. So the next thing I did was with my very little knowledge of the OS I opened the command line and moved myself to the BTSync folder and used "mkdir Documents" and it said the same thing, no access. How can I create a folder in that drive? I want to create multiple folders. One for each "Secret" that I have: One for documents, one for pictures, one for mobile, etc. Thank you very much for your time. Kind regards.