Search the Community

Showing results for tags 'btsync'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Found 95 results

  1. I need to share a key with other resilios... I can create a link. I can create a key I can NOT create a qrcode !! Think: there is no fastest way to share a link with someone and you can read a qrcode but noone can generate it... seems foolish...
  2. I have installed on my Raspberry Pi 2 Btsync version 2.0.93, it is set to automatically check for updates on the preferences panel, but as far as I can tell it never did update. Is there any automated process to update BtSync or do I need to remove it and install the latest version of Resilio Sync? Thanks
  3. Well, Im trying to follow this guide: https://help.getsync.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux Everything ok, but the problem is that i cannot see the gui in the explorer. When i enter this command sudo service resilio-sync start It says Starting Resilio Sync But nothings happen, ok, trying to fix it, i did a apt-get purge resilio-sync to try to do a fresh install of it, but the point now is, THERE IS NO WIZARD like in btsync, and now Im not able to configure the program, where must i put the config file?? I read here: that the file is in: /etc/resilio-sync/config.json So I configure again my Config File: { "device_name": "My Seedbox", // "listening_port" : 0, // 0 - randomize port /* storage_path dir contains auxilliary app files if no storage_path field: .sync dir created in current working directory */ // "storage_path" : "/home/user/.sync", /* set location of pid file */ // "pid_file" : "/var/run/btsync/btsync.pid", /* use UPnP for port mapping */ "use_upnp" : true, /* limits in kB/s. 0 - no limit */ "download_limit" : 0, "upload_limit" : 0, /* proxy configuration */ // "proxy_type" : "socks4", // Valid types: "socks4", "socks5", "http_connect". Any other value means no proxy // "proxy_addr" : "192.168.1.2", // IP address of proxy server. // "proxy_port" : 1080, // "proxy_auth" : false, // Use authentication for proxy. Note: only username/password for socks5 (RFC 1929) is supported, and it is not really secure // "proxy_username" : "user", // "proxy_password" : "password", /* directory_root path defines where the WebUI Folder browser starts (linux only). Default value is / */ // "directory_root" : "/home/edu/", /* directory_root_policy defines how directory_root is used (linux only). Valid values are: "all" - accepts directory_root and its subdirectories for 'getdir' and 'adddir' actions "belowroot" - accepts directory_root's subdirectories for 'getdir' and 'adddir' actions, but denies attempts to use 'adddir' to create directories directly within directory_root Default value is "all". */ // "directory_root_policy" : "all", "webui" : { "listen" : "0.0.0.0:8888" // remove field to disable WebUI /* preset credentials. Use password or password_hash */ // ,"login" : "admin" // ,"password" : "password" // ,"password_hash" : "some_hash" // password hash in crypt(3) format // ,"allow_empty_password" : false // Defaults to true /* ssl configuration */ // ,"force_https" : true // disable http // ,"ssl_certificate" : "/path/to/cert.pem" // ,"ssl_private_key" : "/path/to/private.key" /* dir_whitelist defines which directories can be shown to user or have folders added (linux only) relative paths are relative to directory_root setting */ // ,"dir_whitelist" : [ "/home/user/MySharedFolders/personal", "work" ] } /* !!! if you set shared folders in config file WebUI will be DISABLED !!! shared directories specified in config file override the folders previously added from WebUI. */ /*, "shared_folders" : [ { "secret" : "MY_SECRET_1", // required field - use --generate-secret in command line to create new secret "dir" : "/home/user/bittorrent/sync_test", // * required field "use_relay_server" : true, // use relay server when direct connection fails "use_tracker" : true, "search_lan" : true, "use_sync_trash" : true, // enable SyncArchive to store files deleted on remote devices "overwrite_changes" : false, // restore modified files to original version, ONLY for Read-Only folders "selective_sync" : false, // add folder in selective sync mode "known_hosts" : // specify hosts to attempt connection without additional search [ "192.168.1.2:44444" ] } ] */ /* Advanced preferences can be added to config file. Info is available at "http://help.getsync.com/customer/portal/articles/1902048-sync-advanced-preferences--more-options" For example see folder_rescan_interval below */ //, "folder_rescan_interval" : "86400" } I need help to run again the program in the server... I tried too with the command rslsync --webui.listen 0.0.0.0:8888 And nothing.
  4. Cloud for btsync

    Hello Does anyone know of a cloud for btsink ? Does anyone need is the cloud?
  5. No Web UI?

    I've been beating my head against the wall for 2 days straight trying to get this to work. I've performed a fresh installation of btsync. From what I can read, after the install, the webui should be available immediately after install so that it can be configured further. However, I can't get it to show up at all. Here is my config: { "storage_path" : "/var/lib/btsync/", "vendor": "tuxpoldo", "display_new_version": false, "disk_low_priority" : true, "lan_encrypt_data" : true, "rate_limit_local_peers" : false, "folder_rescan_interval" : 600, "folder_defaults.delete_to_trash" : true, "folder_defaults.use_dht" : false, "folder_defaults.use_lan_broadcast" : true, "folder_defaults.use_relay" : true, "folder_defaults.use_tracker" : true, "folder_defaults.known_hosts" : "", "webui" : { "directory_root" : "/home/rtorrent/btsync", "listen" : "0.0.0.0:8888", "force_https" : false, "ssl_certificate" : "/etc/btsync/debconf-default.crt", "ssl_private_key" : "/etc/btsync/debconf-default.key" } } I do have some weird errors in sync.log: [20160808 13:58:39.652] total physical memory 536870912 max disk cache 2097152 [20160808 13:58:39.653] Using IP address 127.0.0.2 [20160808 13:58:39.655] Loading config file version 2.0.93 [20160808 13:58:39.655] My PeerID: 1099EC3D946C79DD30A8BC5F7AB749FDBB9D16D7 [20160808 13:58:43.878] UPnP: Could not map UPnP Port on this pass, retrying. [20160808 13:58:48.883] UPnP: Could not map UPnP Port on this pass, retrying. [20160808 13:58:51.887] NAT-PMP: Unable to map port with NAT-PMP. [20160808 13:58:53.888] UPnP: Could not map UPnP Port on this pass, retrying. [20160808 13:58:58.894] UPnP: Unable to map port 127.0.0.2:18213 with UPnP. I suspect the problem is where it says it is using IP address 127.0.0.2, but I have no idea why it would do that. This application is installed on a headless VPS running Ubuntu 14.04 x64.
  6. I've got BTsync installed on my Windows 8.1 laptop and my Synology NAS. However, it fails to sync. On my NAS, BTSync indicates that 1/1 peer is online, that is is to get 551 files from my laptop (2GB), but nothing happens, and it has only synced 2 MB thus far. My laptop contains the folder that I want to sync to the NAS, which is about 300 GB large. BTSync indicates that 0 peers are online. I have opened upnp on my router, re-installed BTSync on the NAS, re-added the folder, but nothing helped. The log on my laptop shows, with some repetition, the following errors: [2016-06-18 09:15:29] API: --> getsyncfolders(discovery=1&t=1466234129077) [2016-06-18 09:15:30] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:30] API: --> getsyncfolders(discovery=1&t=1466234130156) [2016-06-18 09:15:31] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:31] API: --> getsyncfolders(discovery=1&t=1466234131213) [2016-06-18 09:15:32] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:32] API: --> getsyncfolders(discovery=1&t=1466234132287) [2016-06-18 09:15:33] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:33] API: --> getsyncfolders(discovery=1&t=1466234133350) [2016-06-18 09:15:33] API: <-- getsyncfolders({ "corestate": [ ], "folders": [ { "archive": "C:\\Users\\Matthijs\\Documents\\Testfolder\\.sync\\Archive", "archive_files": 0, "archive_size": 0, "available_space": 40019746816, "canencrypt": false, "date_added": 1412424696, "down_eta": 0, "down_speed": 0, "down_status": 100, "error": 100, "files": 0, "folderid": "1974905766848768265", "has_key": true, "indexing": false, "ismanaged": false, "iswritable": true, "last_modified": 1442582655, "name": "Testfolder", "path": "C:\\Users\\Matthijs\\Documents\\Testfolder", "paused": false, "peers": [ ], "readonlysecret": "[secret]", "secret": "[secret]", "secrettype": 1, "size": 0, "status": "Kan de doelmap niet openen.", "stopped": false, "synclevel": 2, "total_size": 0, "up_eta": 0, "up_speed": 0, "up_status": 100 }, { "archive": "D:\\Temp\\TestSync\\.sync\\Archive", "archive_files": 0, "archive_size": 0, "available_space": 23114334208, "canencrypt": false, "date_added": 1465800849, "down_eta": 0, "down_speed": 0, "down_status": 100, "error": 0, "files": 0, "folderid": "11104787208742241171", "has_key": true, "indexing": false, "ismanaged": false, "iswritable": true, "last_modified": 1465933316, "name": "TestSync", "path": "D:\\Temp\\TestSync", "paused": false, "peers": [ ], "readonlysecret": "[secret]", "secret": "[secret]", "secrettype": 1, "size": 0, "status": "0 B in 0 bestanden ", "stopped": false, "synclevel": 2, "total_size": 0, "up_eta": 0, "up_speed": 0, "up_status": 100 }, { "archive": "D:\\Matthijs\\.sync\\Archive", "archive_files": 0, "archive_size": 0, "available_space": 23114334208, "canencrypt": false, "date_added": 1465933364, "down_eta": 0, "down_speed": 0, "down_status": 100, "error": 0, "files": 251434, "folderid": "3917473051574594232", "has_key": true, "indexing": true, "ismanaged": false, "iswritable": true, "last_modified": 1466234046, "name": "Matthijs", "path": "D:\\Matthijs", "paused": false, "peers": [ ], "readonlysecret": "[secret]", "secret": "[secret]", "secrettype": 1, "size": 316447035307, "status": "294.7 GB in 251434 bestanden (Indexeren...)", "stopped": false, "synclevel": 2, "total_size": 316447035307, "up_eta": 0, "up_speed": 0, "up_status": 100 } ], "loading": false, "speed": { "downspeed": 0, "upspeed": 0 }, "status": 200 }) [2016-06-18 09:15:34] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:34] API: --> getsyncfolders(discovery=1&t=1466234134417) [2016-06-18 09:15:35] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:35] API: --> getsyncfolders(discovery=1&t=1466234135485) [2016-06-18 09:15:36] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:36] API: --> getsyncfolders(discovery=1&t=1466234136562) [2016-06-18 09:15:37] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:37] API: --> getsyncfolders(discovery=1&t=1466234137619) [2016-06-18 09:15:38] JOURNAL[7840]: Mutex file check failed with error : 100 [2016-06-18 09:15:38] API: --> getsyncfolders(discovery=1&t=1466234138725) I cannot find any additional information about the 'mutex' error. When I created another folder (the 'TestSync' folder, empty on both laptop and NAS), it worked for a little while when adding new files, but it also has stopped syncing now. (Also 0 peers according to laptop.) To me, it seems that connectivity is not an issue, as both systems (at least initially) detected each other and synced some files. Any ideas are welcome! Cheers!
  7. I am running sync on a number of boxes (Ubuntu 14.04), all with the exact same configuration, which you can see here - Recently on one of my laptops, it is asking for a new identity when I visit the webGUI. If I do, it creates a new identity in the storage_path folder where the original .SyncUser is. Is there any way to specify to use the current .SyncUser folder that is in the storage_path folder, rather than try and create a new one?
  8. Hello All - I've been using BTSync Pro for a few months now. I love the concept, but there's only 1 issue that keeps causing me issues: speed. From my home system (Windows 10 x64 / BTSync 2.3.6 (378) Service Mode) synchronizes with a few of my devices over LAN however 99% of the traffic going through it is from a Linux system (Ubuntu 12.04 LTS x64 / BTSync 2.3.6 (378)) over the internet. The two folders it syncs are what is running slowly on a constant basis. Most of the files being synced are larger 3+gb files. When I attempt to download the files from the same host using HTTP or FTP via the CrushFTP server I have installed on the Linux box, I get consistent speeds which reach my fastest download speed of ~3.5Mbps. When syncing between the two computers using BTSync and same files, you never know what you are going to get. It averages around 1Mbps but can range from 300kbps -> 3.0Mbps. It never wildly jumps between speeds, but will stay within 150kbps range of whatever it decideds to download at for the time. I've looked over some settings in BTSync, but nothing I've found or tried seems to help. I've verified that the used ports are open even though opened via uPNP and also added dedicated hosts to the folders being synced. I've even tried to use a service like VyperVPN which sometimes helps a lot, but shouldn't be nessesary. Perhaps Comcast / Xfinity is throttling my traffic even though they generally claim that they do not do so. Does anyone else experience this type of thing consistently when other protocols are working just fine? Any suggestions for what I may do? If potentially throttling, is there any way to mask it? Thanks!
  9. I'm pulling my hair out here. I updated to 2.3.3 to use the new encrypted folders. The set up is quite a bit different, since it doesn't appear to have the dpkg option where you can select the user it runs under. I can get it to launch as user btsync, but cannot for the life of me get the btsync user to access the second hdd on my computer. I have added btsync to my user group that has access, added read/write privileges, everything. It won't even drill past /media/USER/ when trying to add a folder from the web gui, and manually entering a directory says it doesn't have write privileges. I have tried editing the init.d/btsync file to run as my primary user, but it wont start. I have also editied the btsync.service file in /lib/systemd/system to show my primary user, but it still runs under btsync user. I have already spent way to long on this. What am I missing? What do I need to change in order to make it run as a different user from btsync? Edit - I followed these instructions after completely wiping all the previous BTSync files from my computer - https://blog.getsync.com/2016/02/18/official-linux-packages-for-sync-now-available/
  10. Hello, I got a problem with my readynas 102. before I had a working 1.4 on the NAS system with 2 computers syncing. last week i updated to the new 2.3 version (clients) syncink with PCs and android phones works perfectly. the netgear readynas 102 got updates on firmware 6.4.2 and btsync 2.3.2 the nas cant get any peer list, even if i am connected to the internet and access the nas via remote control port forwarding also works on 7099 and the seconds transfer port (20112). i tried to change some directory rights at data/btsync, i also created data/btsync2016. but no luck with connection. tried synology on other network (works!)# any ideas? ps: i also tried v2.00, v1.4, v2.0.5, v2.2.5 .... no way if I uninstall the app, restart my device and the rename the share, I wasnt able to create the share manually again... maybe btsync forces data/btsync ???
  11. Hey Guys - I use BTSync (Pro) to synchronize many folders between multiple devies - one of which is my Nvidia Shield Tablet which runs Lollipop 5.1.1. When first moving to 5.1.1 a few months ago, I rooted it and added a 64gb SD card. I then edited "/etc/permissions/platform.xml" to add the &nbsp;"WRITE_EXTERNAL_STORAGE" string therefore providing all apps with full write to the SD card. I installed BTsync, set up my options, and linked 4-5 folders to various folders on the SD card without issue. Besides BTSync, I use FolderMount to create symlinks on my internal SD so that I may store all my large games / apps externally. Today, I renamed a folder on my PC so had to set up the pair again. The Issue When in BTSync in Android, I choose to link the folder, but could only select a folder from the internal SD - not the external one as before! When I go to select the folder, it asks if I want to use on on the Phone Storage or SD Card, but either I pick show the same thing: a screen with "Recent" as the only choice. From that screen, I can hide / unhide the internal SD, but see no reference to the external one. There are no errors, I just can't see / browse to it! I am sure this is due to a BTSync update from the past few months as I haven't changed the OS or anything else. All other applications still have full access to the external SD, too. How may I get the external SD to show as an option in this newest version of BTSync? If it makes a difference, I still have the default folder path in Advanced Options set to "/storage/sdcard1" (which I believe is the external one and sdcard0 is internal) and Simple Mode disabled yet when I try to even create a new folder from the app; I can't browse to the external SD card either. Please help - Thanks!
  12. Hi, i was wondering why one of my server told me his 100 % rootfs. It is a very light installation of ubuntu server. So i researched the reason and found Btsync as the bad guy. I have 2 other btsync installation and found the same symptom there. The /var/lib/btsync is messing up the rootfs and i got more than 10g there! Why? That's not common in linux to mess up the rootfs with a small programm. I found it on my raspberry as well. There was more than 2,4g antoher installation had 8,5g occupied space by BTsync. So why there are such big db files saved in /var/lib/btsync? Why is there no clean up of them? the db are getting bigger and bigger and will break down any system in the future. What is the workaround for that issue? br DIrk
  13. Hi, Very interesting case ... BTSync on my NAS Synology DS 715 automatically stopps running and is deactivated, without myself having done anything. Every few days I have to manually restart BTSync. I have 2.3 as a version. Any ideas what this could be? Phil
  14. Hey Guys - I've got a basic question to ask, please. I subscribe to BTSync Pro and recently reinstalled the OS (Windows 10 x64) on one of my PCs. When installing BTSync, I saw that I had the option to install it as a service so did so. I set the credentials and am able to access the WebUI via http://localhost:8888. When trying to access the same WebUI from other systems on my LAN (http://newpchostname:8888), it does not work. I looked all through the preferences, advanced preferences, and searched online to find out how (if possible) to enable LAN system access, but so far haven't had luck. So - is there a way to make BTSync for Windows installed as a service accessable from other LAN PCs? My current guess is that the binding would have to be changed, but am not 100% of the format it needs to be in for Windows. The PC it's installed on is pretty basic and just has a single ethernet NIC, bluletooth, and WiFI as adapters. Thanks!
  15. Hey Guys - Just a quick suggestion of a feature often used in SABnzbd. As I download from many different applications on my PC, sometimes I want to pause specific services so that others will have the full bandwidth yet don't want to wait for the downloads to finish (or have to remember) to start them again. I use NetBalancer to assign priorities to specific application's traffic which helps with some of this, but it doesn't work exactly the way you'd hope it would. SABnzbd has a great feature which allows you to pause the entire queue for a set duration of time after which it will automatically resume downloading. It would be great to have this capability as a whole of preferably per shared folder in BTSync. For example, in SABnzbd, clicking this option for the main queue provides you with the following options: 5 minutes 15 minutes 30 minutes 1 hour 3 hours 6 hours Pause for... (Where you may enter a custom minutes value) Is there any possibility of having a similar feature for BTSync? If not, it would be great to at least have some way to instruct BTSync the specific files / folders you wish to be downloaded / uploaded first. Currently, I have to move files around on the host, wait for them to sync, then remaining, lower priority files back to download - or - transfer individually via FTP which is a pain. Any chance for either of these? Thanks!
  16. Setup With Nginx Proxy

    I've encountered this post that kind of explains a workaround. http://forum.bittorrent.com/topic/31556-bug-with-fix-webuijs-has-hard-coded-absolute-url/?hl=nginx#entry107204 However, is there an update where I can get this to work? My current nginx setup is : server { listen 80; server_name "LINK"; root /var/www; return 301 https://$server_name$request_uri; index index.html index.php index.htm; location / { try_files $uri $uri/ =404; } location ~ /\.ht { deny all; }} server { listen 443 ssl; server_name "LINK"; root /var/www; index index.html index.php index.htm; ssl_certificate /etc/ssl/"LINK"/"LINK"_bundle.crt; ssl_certificate_key /etc/ssl/"LINK"/"LINK".key; ssl_session_timeout 5m; location / { try_files $uri $uri/ =404; } include /etc/nginx/sites-available/btsync-loc; location ~ /\.ht { deny all; } } and my proxy file is location /gui/ { proxy_pass http://127.0.0.1:8888/gui; proxy_redirect https://$host:8888/gui /gui/;} Is there something I'm missing? I can get it to work with other apps but can't seem to figure it out here. Any guidance would be appreciated! Thanks!
  17. It would be great if like the camera roll backup feature you could create an automated backup of a particular album. As an example you could have a documentation album and then you could share this with colleagues who would then have access to any images you add into that album.
  18. I've been using version 1.3.109 on OSX and Android for quite some time and it's fast and stable, even for huge data sets, for me. Is there any reason I should consider upgrading my version? Am I missing out on a sweet feature or essential security patch? More reliability, or anything like that?
  19. Hey, I want to setup a vserver with btsync 2.0 automatically with a script and no running btsync webinterface. How does the btsync config file have to look like and how can I automatically link a shared folder to this btsync instance without manually linking it in the webinterface?
  20. Hi everybody, On a Qnap Nas, I just wonder how you can set up BTsync on the folder "/share" (the root one)? During the set up process, BTsync doesn't allow me to do this... See screenshot here : http://phantom.d.pr/1fwPV/4P15wl6B I think it's all about permissions right, even if I'm logged in as "admin" (=root account on Qnap Nas). For the moment BTsync just allow me to choose a subfolder but we already have folders (for example : ADMIN, ARCHIVES, LIBRARIES, WORK) inside the "/share". These folders have been previously synced with RTRR protocol (approx. 3TB of datas). Now we want to manage the syncing process with BTSync... because RTRR is way to slow... If you have any idea, it would be great! Thanks in advance. Regards. John
  21. Hi! Could you please tell me, if I have synced folder on an external drive and I swap that drive with another with same volume name but not same amount of files in synced folder (for example fewer), will Btsync decide that those files were deleted and will remove them from other devices, or it will sync missing files back from other devices? I mean, for example I have external drive named "Brick" and have synced folder on it. Btsync path is /Volumes/Brick/sFolder sFolder contains 10 files and synced with another computer. I swap "Brick" with another drive, also named "Brick", so path /Volumes/Brick/sFolderstays the same, but sFolder contains 8 files. Will Btsync delete 2 files from another computer, or it will download those files from another computer? Thanks! Sorry for grammar mistakes.
  22. Hello, I am new to the forum. I have been running BTSync for around 4 months on my FreeNas box. Yesterday I noticed there was an update available for the Plugin. I went ahead and updated and afterwards i logged into the webgui. I was prompted with the same welcome wizard you get when installing BTSync on a client machine. At the end of the wizard it asks you if you want to create new 2.0 links or you already have one. I chose I already had one but after selecting that option i relies i didn't see the option i wanted. i hit the back or close button and my screen turned to a gray background with a thin line in the shape of a box. I can't seem to get out of this. I have rebooted my NAS box and reset the plugin service. I have tried getting the to webgui page though different browsers and even different pc's. still no change. My links still work but I am unable to add new or do any administration over them. I would rather not have to uninstall/re-install and recreate my links. Any suggestions would greatly appreciated! FreeNAS-9.3-STABLE-201504152200 btsync-2.0.105-amd64
  23. Hi Team, I have a strange anomaly with BtSync 2. The problem arose from version x.104! I have two QNAP NAS and one CentOS server, the two NAS share the same folders while the server only two. After a few days of the starting the two NAS BtSync lose synchronization bringing me back "0 of 0 peers" for some folders. Just that I reboot the BtSync process in one of two NAS and everything goes back to work. The strange thing is that some folders are synchronized, some not. And if I go to Menu> "My Devices ..." I'm not seeing the other devices. But the folders still active synchronizes properly. I am attaching some screenshots! I restarted the process, only in one NAS, and synchronization is active in ALL folders.
  24. Hi, It is my understanding that it should be possible to tunnel BTSYNC through ssh and bypass then any firewall configuration, but I haven't been able to find any guide AND I cannot make it work. What I do: - In my work computer configure putty to tunnel the (source) port 15000 to the IP of my home connection, where the destination is dynamic. - Configure my home router to forward the 22 connection towards my raspberry pi - Start putty and log into my raspberry pi ssh server - In my computer configure BTSYNC to use a socks (4 or 5) proxy pointing to localhost:15000 And that should work or I am wrong? It doesn't as BT doesn't find any peer. And if I configure Firefox to use this proxy server, I do have internet and my IP looks like my home IP, so I'd say putty is working as it is expected. Then, what is the problem? Thanks,
  25. Hello everyone, New to BTS, this forum and Linux! I have BTSync up and running just fine with My Cloud EX2, iOS8 and Windows 8.1. Very nice tool! I've searched high and low for a solution to enable BTS on (restart) boot up for the WD My Cloud EX2 NAS device and cannot find one that will work. I've tried various solutions but ultimately the EX2 doesn't have the chkconfig or update-rc.d commands/modules. I'm running the latest BTS client and WD firmware on the EX2. uname -r - 3.2.40 uname -a - Linux Cloud 3.2.40 #3 Tue Jul 29 18:09:51 CST 2014 armv7l GNU/Linux Thanks for your time and any help you can provide!