Search the Community

Showing results for tags 'linux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 204 results

  1. On Ubuntu Server 16.04.1 LTS (Xenial Xerus) I've installed Resilio Sync and started by: systemctl enable resilio-sync adjusted the /etc/resilio-sync/config.json file: { "listening_port" : 0, "storage_path" : "/var/lib/resilio-sync/", "pid_file" : "/var/run/resilio-sync/sync.pid", "agree_to_EULA": "yes", "webui" : { "listen" : "0.0.0.0:999", "login" : "xxx", "password_hash" : "xxx" } } restarted the service, and everything works fine, on URL http://196.168.666.666:999/gui. Next, I'm creating a certificate in /etc/resilio-sync/ folder: openssl req -x509 -nodes -days 9999 -newkey rsa:2048 -keyout sync.key -out sync.crt and updating config.json: { "listening_port" : 0, "storage_path" : "/var/lib/resilio-sync/", "pid_file" : "/var/run/resilio-sync/sync.pid", "agree_to_EULA": "yes", "webui" : { "listen" : "0.0.0.0:999", "login" : "xxx", "password_hash" : "xxx" ,"force_https" : true ,"ssl_certificate" : "/etc/resilio-sync/sync.crt" ,"ssl_private_key" : "/etc/resilio-sync/sync.key" } } Unfortunately, now when I access https://196.168.666.666:999/gui the connection fails. Any idea what may be wrong?
  2. Hello, I managed to get resilio sync up and running on my new install of OpenSuse Leap 42.2. However, I tried to update my repos and zypper came back with the error: "Permission to access 'http://linux-packages.resilio.com/resilio-sync/rpm/x86_64/media.1/media' denied." I looked in Yast and noticed that there is no GPG key there for resilio, though I did import it using the prescribed method in the documentation. Thinking that might be the problem, I reimported it, to no effect. Any tips?
  3. Hi, Am a new user but loving the look and feel of Resilio sync. Been trying for the last day or two to get it up and running on my NAS but am having no success in accessing the webui. I installed the Linux ARM version onto my NSA 325. It's not an officially supported NAS but this build should work fine. I think I have installed it correctly and it appears to be running (as I can trigger messages such as: Resilio Sync is already running with pid 5097 No matter what IP address I use though I cannot access the webui to set anything up. Based on various forum threads I have tried the addresses listed below. All result in a failed to load/find page message. I have also tried restarting my NAS. Any advice? http://xxx.xxx.xxx.xxx:8888/gui/ (IP address of my NAS) http://127.0.0.1:8888/gui/ http://0.0.0.0:8888/gui/ Thanks, Stuart
  4. I want to try Resilio, because it seems to be the only solution which supports Linux, IOS, and Androiod as well. Unfortunatly my first try on Linux fails. I'd like to install Resilio on a Ubuntu Xenial computer according to this guide: https://help.resilio.com/hc/en-us/articles/206178924 Here is the output of my sources file for resilio: deb http://linux-packages.resilio.com/resilio-sync/deb resilio-sync non-f The Resilio key is in my list: pub 2048R/3F171DE2 2017-12-22 uid Resilio, Inc. <support@getsync.com> apt update is not complaining: Hit:4 http://linux-packages.resilio.com/resilio-sync/deb resilio-sync InRelease But the command sudo apt-get install resilio-sync does not work as described: E: Unable to locate package resilio-sync What's wrong?
  5. Hi all, I received a raspberry pi for Christmas and I am trying to set it up as a home sync/backup server. I have successfully mounted an external hard drive to my Pi and can interface with it successfully, but Resilio Sync cannot access the hard drive. Question is: is this a Sync issue or a Linux/Rasbpian issue? How can I remedy this? Many thanks
  6. I cant get sync to work with "Camera Backup" folders. I want to sync an "Camera Backup" from an Android device to an Raspberrypi running raspbian using an config file. Syncing the "Camera Backup" to an desktop pc with windows and without config-file works perfectly fine, also other "normal" folders on the raspberrypi are beeing synced perfectly even with the said Android device. Here is my config, with changed values for posting: { "device_name": "HOSTNAME", "use_upnp" : true, "download_limit" : 8000, "upload_limit" : 500, "shared_folders" : [ { "secret" : "SECRET", // required field - use --generate-secret in command line to c$ "dir" : "FOLDERPATH", // * required field "use_relay_server" : true, // use relay server when direct connection fails "use_tracker" : true, "search_lan" : true, "use_sync_trash" : true, // enable SyncArchive to store files deleted on remote devices "overwrite_changes" : true // restore modified files to original version, ONLY for Read-Only folders } .... what am i missing?
  7. Stronginthearm

    Weird permission issues

    I'm upgrading my sync installations on my servers from the yeasoft version (btsync 2.0.95) to the new official Debian/Ubuntu version (rslsync 2.4.4) and I'm encountering some weird permission issues. On some of my servers sync seems to ignore group permissions. Example: sync runs as user rslsync, group staff rslsync:x:104:50::/var/lib/btsync:/bin/false staff:x:50: I try to sync the directory /etc/nagios/nrpe.d/ root@Siamorphe:~# ls -alh /etc/nagios drwxr-xr-x 3 root root 4,0K Mär 11 15:10 . drwxr-xr-x 99 root root 4,0K Mär 15 06:44 .. -rw-r--r-- 1 root root 8,1K Jul 15 2014 nrpe.cfg drwxrwxr-x 3 root staff 4,0K Mär 11 18:17 nrpe.d -rw-r--r-- 1 root root 117 Jul 15 2014 nrpe_local.cfg root@Siamorphe:~# ls -alh /etc/nagios/nrpe.d drwxrwxr-x 3 root staff 4,0K Mär 11 18:17 . drwxr-xr-x 3 root root 4,0K Mär 11 15:10 .. -rw-r--r-- 1 rslsync staff 1,8K Mär 11 18:17 custom_checks.cfg drwxr-xr-x 3 rslsync staff 4,0K Mär 15 06:42 .sync On most hosts this works but on one it doesn't, I get "Don't have permissions to write to selected folder" root@Sharess:~# ls -alh /etc/nagios drwxrwxr-x 3 root staff 4,0K Mär 15 09:51 . drwxrwxr-x 90 root staff 4,0K Mär 15 09:38 .. -rw-r--r-- 1 root root 8,0K Mär 11 14:38 nrpe.cfg drwxrwxr-x 2 root staff 4,0K Mär 15 09:51 nrpe.d -rw-r--r-- 1 root root 117 Jul 15 2014 nrpe_local.cfg root@Sharess:~# ls -alh /etc/nagios/nrpe.d drwxrwxr-x 2 root staff 4,0K Mär 15 09:51 . drwxrwxr-x 3 root staff 4,0K Mär 15 09:51 .. If I change the login shell of the user rslsync to bash and manually try to write to this folder that works without problem (as it should, because of the group permissions). The working servers are Ubuntu 16.04 or Debian 8, as is the broken one. The only apparent difference I see is the kernel: broken: Linux Sharess 3.16.0-4-686-pae #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) i686 GNU/Linux works: Linux Deneir 3.16.0-4-586 #1 Debian 3.16.39-1+deb8u2 (2017-03-07) i686 GNU/Linux works: Linux Siamorphe 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux works: Linux Gond 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux Nevertheless, on one of the servers where this folder works (Gond), I get for some other previously working folders the don't have permissions error. Somebody got any idea what could be the problem here?
  8. Hello! I really don't know whether I need to present myself because I found nothing about it. Anyway, It's been about one month since the problem I'm facing first occurred. To be specific, I tried two things: I started the Resilio sync client in daemon mode, then I monitored resource consumption and I noticed it occurred while it was adding event listeners to each file. Then, I decided to try updating the client and reinstalling (I just downloaded the archive from the site and re-extracted). By adding one folder at a time, I noticed that when I added a really big folder (in terms of number of files) the problem reoccurred. I hope to get some help and I'm ready to provide all kind of debug information. Thanks in advance, Eugenio.
  9. Hello, I´ve installed Resilio Sync using the below link. I did the basic configuration and I can access the 8888 webgui successfully. The local user created is rslsync (with group same name), that is different from the Web Gui user. The server I installed Resilio, is a production CPANEL server, and the idea is to have all Cpanel accounts and server configs backed up in another location (sync´d), without the need to use CPANEL backup function (that does not support syncing yet) The problem is that resilio sync can´t access each account of Cpanel (folders and subfolders), nor server configurations as it have their own user/group for each account in system. I don´t want to change each folder permissions with chmod with risk to brake CPANEL. So, based on all this. How to run Resilio (service in linux) as root, and/or have automatically access to all folders in CenOS 6 server, without compromising CPANEL system/server? Thanks in advance! Installation link: https://help.resilio.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux
  10. Hello, I tried add some folder to sync (for example /var/www/) but I see error "Don'thave permissions to write to selected folder" I can't change permissions for this folder, can I up permissions for resilio? Than You! CentOS 7 resilio-sync-2.5.8-1.x86_64
  11. I was facing this issue since few months. Frequently, All my resilio settings were lost and I used some really undesirable workarounds till now. Today I found a perfect solution which works everytime. The Setup: System: Centos 6.6 x86_64 wget https://download-cdn.resilio.com/stable/linux-x64/resilio-sync_x64.tar.gz cd /home/user/bin tar -xf ../resilio-sync_x64.tar.gz ./rslsync Running above commands, I could access the webUI and did all the settings (setting up username and password etc.). After 2 days I logged in to the same machine and ./bin/rslsync The service started. I accessed the webUI and for my surprise, I was asked the username, password and re-enter password which was asked 2 days ago, It looked like all the settings were lost. Same issue while using crontab. Solution: I noticed a .sync directory inside /home/user/bin/ Copied the directory inside the home directory cp -r /home/user/bin/.sync /home/user/bin Killed resilio sync and restarted it. Everything works fine now. Is it a bug? A NO from me. Reason: When you run the rslsync for the first time, The .sync directory which stores all the information about sync is created in the Current Working Directory. While running rslsync, You need to be in the directory which was your pwd while you first ran rslsync Let's say, You are running resilio for the very first time. rslsync binary is stored in /home/user/bin/ , And you did cd /home/Downloads /home/user/bin/rslsync resilio will start and .sync directory will be created in your pwd ie. /home/user/Downloads Next time, If you are in your home directory and you do /home/user/bin/rslsync Resilio will start but settings will be lost. But, cd /home/user/Downloads /home/user/bin/rslsync will work This is troublesome if you only have 1 resilio setup. So make sure you run rslsync in your home directory initially. On the other side, If you want to have multiple resilio setups on the same machine and that too with the same user, This "so called bug" is awesome. You can have multiple different shares with different credentials and different setups. Though only 1 will be running at a time. Hope this helped. Thanks
  12. I installed resilio-sync 2.5.6-1 on a new machine running Debian 9 and the inital sync with a folder does not finish and the resilio process consumes 100% CPU continuously. In the log on the debian machine I see the following error lines over and over for various files: [20170728 10:37:43.179] FC[8022]: Max count of remote files processing achieved. Requeueing VerifyFileSignatureMessage job. [20170728 10:37:43.179] FC[8022]: Failed to get node for parent(Docs/ilogs/HTL Villach/WM6SDK/Samples/Samples/Common/CPP/Win32/CustomForm/EMSCustomForm) of file Docs/ilogs/HTL Villach/WM6SDK/Samples/Samples/Common/CPP/Win32/CustomForm/EMSCustomForm/consts.h The rslsync process on the Debian machine tries to download these files from a Windows 7 machine running Resilio Sync 2.5.6 (1043). The files are available under this subpath on the windows machine and there are no errors to see in the logs of the Resilio process on the windows machine. Maybe it's an issue with the filepath beeing to long? As said already, resilio on the linux machine spins with 100% CPU usage and does not complete and there is no progress but thousands of error log files beeing written. Please help me in resolving this issue!
  13. Is there some way that I can limit the amount of memory (RAM) used by bittorrent sync (btsync) in Linux (Ubuntu). I am syncing about 500 GB of files from one machine to the Linux machine. However, about 90% of the RAM is being used by btsync during this process (which will take many days). I usually only remote to this Ubuntu computer instead of directly controlling it, and when 90% of the RAM is being used, the computer becomes very unresponsive. Is there some way that I can limit the amount of RAM used by btsync? I would be willing to slow down the sync process if I can limit the RAM.
  14. 6o8Vnscc5hZJGQITIWVB5UhFc8

    No https for linux webui?

    Is there really no way to enable/force the webui of the linux btsync to use https/ssl? This is a gaping security hole for a software trying to take pride in security and privacy. That might be fine for communication over a private, trusted network but it's wholly unacceptable for communication over the public internet. I have a remote server I've been using for offsite backup and I've now realized that the credentials to the webui and all my 'secrets' have been transmitted in plaintext on the open internet. Great. As a workaround I can change all my secrets, disable the webui, and exclusively do remote configuration on a config file via ssh, but still... wtf?
  15. My systems are suffering from Major performance- and sync-problems! I've got 2 macOS systems and 2 NASses running first on 2.5.4 and now on 2.5.5 (just upgraded today). The App in macOS just stalls system; Activity monitor gives a lot of times; CPU over 100% and Not Responding. systems have problem with syncing with each other. Arch Linux NAS on my office has been offline for days but is actually running. Now in the office it syncs. Webpage of both Linux systems are terribly slow for a while and then they are fine and back again. This is output of Arch Linux system after restarting; * rslsync.service - Resilio Sync per-user service Loaded: loaded (/usr/lib/systemd/user/rslsync.service; enabled; vendor preset: enabled) Active: active (running) since Sat 2017-07-08 16:14:49 CEST; 19min ago Main PID: 280 (rslsync) CGroup: /user.slice/user-1000.slice/user@1000.service/rslsync.service `-280 /usr/bin/rslsync --nodaemon --config /home/raymond/.config/rslsync/rslsync.conf Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.456] D! 21ReverseHTTPConnection::set_error[0x00007f89e6969270][56] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.458] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][67] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.463] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][55] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.483] D! 17TrackerConnection::set_error[0x00007f89e69877a0][16] 104 (Connectio Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.483] D! 17TrackerConnection::set_error[0x00007f89e697a5f0][17] 104 (Connectio Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.484] D! 17TrackerConnection::set_error[0x00007f89e69648f0][116] 104 (Connecti Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.538] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c04cd0][16] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.538] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c050c0][17] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.920] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][56] 103 (EOF) Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.925] ZIP: Can't locate [css/style.css] in zip, error -100. and after a while; * rslsync.service - Resilio Sync per-user service Loaded: loaded (/usr/lib/systemd/user/rslsync.service; enabled; vendor preset: enabled) Active: active (running) since Sat 2017-07-08 16:39:06 CEST; 1h 31min ago Main PID: 444 (rslsync) CGroup: /user.slice/user-1000.slice/user@1000.service/rslsync.service `-444 /usr/bin/rslsync --nodaemon --config /home/raymond/.config/rslsync/rslsync.conf Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4d634400]: EOF - error: 103 (application protocol level timeout) Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq::set_error[0x00007f1d4d634780][-1] 103 (application protocol level timeout) Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4d634780]: EOF - error: 103 (application protocol level timeout) Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq::set_error[0x00007f1d4ea9d5e0][-1] 103 (application protocol level timeout) Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4ea9d5e0]: EOF - error: 103 (application protocol level timeout) Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.562] D! 10SyncTcpReq[0x00007f1d4ea9d8a0]: EOF - error: 0 (Success) Jul 08 18:10:11 nas rslsync[444]: [20170708 18:10:11.952] D! 10SyncTcpReq[0x00007f1d4d1047a0]: EOF - error: 0 (Success) Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.240] D! 21ReverseHTTPConnection::set_error[0x00007f1d4d1434b0][86] 103 (EOF) Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.343] D! 10SyncTcpReq::set_error[0x00007f1d4c401aa0][-1] 103 (application protocol level timeout) Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.343] D! 10SyncTcpReq[0x00007f1d4c401aa0]: EOF - error: 103 (application protocol level timeout) I'm so annoyed this is my third major problem with Btsync/ Resilio on about 3 years.
  16. I am having Kubuntu 14.4. When I try to add a folder via a key, I get the Status "Database error". Reading the article "Unknown error (Database error)" did not help. I added the relevant log lines and the configs I use. I changed the beginning of resilio-sync to DAEMON=/usr/bin/rslsync SYNC_USER=myuser CONFIG=/etc/resilio-sync/config.json Can you help?
  17. I installed resillio in linux (running feren OS 2017.) following the intructions given in help page https://www.linuxbabe.com/ubuntu/install-resilio-sync-ubuntu-16-04-16-10 It was successful and much more simplified. I almost synced 98% of all my files. My laptop ran out of battery and I had to restart my session. But when I tried to log back in to the webUI,my password and username was not accepted. I am 1000% sure my password was correct and I even verified it as my browser saved it. I tried many other combinations like default password (googled it for resilio),none worked. So I removed it and purged all the config files,deleted all the .sync files...logged out and logged back in....restarted laptop...but every time I install it,even without giving password (for the new installation),it asks again and I cant access webUI. I tried to edit config file but nothing worked...I deleted the settings.old thing as I found in the help page here....none worked....it is repeatedly asking for username and password which first of all I correctly giving and even in new installation after completely removing it,still asking again and again....what can I do? It took 6 hours for me to get to this...I am very new to linux...sorry for my bad english... Pls note that the very first intallation was successful and everything kept running well....I am using resilio in android and windows for a very long time....just hopped into linux and finding it buggy...
  18. Linux currently has a crippled, Dropbox-like Selective Sync implementation that doesn't let me search for yet-to-be-synced files, unlike the Mac OS and Windows versions, which use placeholder files. It would be great if the Linux version handled selective with placeholders exactly in the same way as on other systems.
  19. I wanted to get Sync working on my Raspberry Pi, and used this guide to help me: https://www.resilio.com/blog/sync-wd-raspberry-pi I was able to get the web Gui to work so I could access the sync with Windows, but it wouldn't grant me access to any of the folders I wanted to sync. Using a different guide on this forum, I edited my config file to be this: { "listening_port" : 0, "storage_path" : "/home/pi/data/.syncsystem", "pid_file" : "/home/pi/data/.syncsystem/btsync.pid", "use_upnp" : true, "download_limit" : 0, "upload_limit" : 0, "delete_folder_from_disk" : true, "folder_defaults.delete_to_trash" : true, "webui" : { "directory_root" : [ "/home/pi/share", "shares" ] "listen" : "0.0.0.0:8888", }, "vendor" : "PiDrive", "display_new_version": false } After a reload, the web gui was gone, and this showed up instead: I reinstalled the btsync service, deleted it (and installed again), rebooted several times, and tried to play around with the config, and I could never get back to the web gui that I had originally. It seems not even the Raspberry Pi itself can reach it, and I wonder if it's even on. I'm still fairly new to the Pi, if anybody have any suggestions to solve this, let me know.
  20. HowardSternIsBatman

    PineA64 installation?

    Hello Can this be installed on a PineA64? I'm running Debian Linux Jessie with Mate. https://www.pine64.org/ tx
  21. I'm on a Raspberry Pi 1B and this is what I get. $apt-get install resilio-sync .... Setting up resilio-sync (2.4.4-1) ... Job for resilio-sync.service failed. See 'systemctl status resilio-sync.service' and 'journalctl -xn' for details. invoke-rc.d: initscript resilio-sync, action "start" failed. dpkg: error processing package resilio-sync (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: resilio-sync E: Sub-process /usr/bin/dpkg returned an error code (1) :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::: $sudo systemctl status resilio-sync.service ● resilio-sync.service - Resilio Sync service Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled) Active: failed (Result: start-limit) since Fri 2016-12-16 00:47:27 PST; 5min ago Docs: http://help.getsync.com/ Dec 16 00:47:27 RPi1B systemd[1]: Unit resilio-sync.service entered failed state. Dec 16 00:47:27 RPi1B systemd[1]: resilio-sync.service holdoff time over, scheduling restart. Dec 16 00:47:27 RPi1B systemd[1]: Stopping Resilio Sync service... Dec 16 00:47:27 RPi1B systemd[1]: Starting Resilio Sync service... Dec 16 00:47:27 RPi1B systemd[1]: resilio-sync.service start request repeated too quickly, refusing to start. Dec 16 00:47:27 RPi1B systemd[1]: Failed to start Resilio Sync service. Dec 16 00:47:28 RPi1B systemd[1]: Unit resilio-sync.service entered failed state. :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::: $ sudo journalctl -xn -- Logs begin at Thu 2016-12-15 19:47:48 PST, end at Fri 2016-12-16 00:51:18 PST. -- Dec 16 00:47:27 RPi1B systemd[1]: Failed to start Resilio Sync service. -- Subject: Unit resilio-sync.service has failed -- Defined-By: systemd -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel -- -- Unit resilio-sync.service has failed. -- -- The result is failed. Dec 16 00:47:28 RPi1B systemd[1]: Unit resilio-sync.service entered failed state. Dec 16 00:47:31 RPi1B sudo[4538]: pi : TTY=pts/0 ; PWD=/etc/init.d ; USER=root ; COMMAND=/usr/bin/dpkg --configure resilio-sync Dec 16 00:47:31 RPi1B sudo[4538]: pam_unix(sudo:session): session opened for user root by pi(uid=0) Dec 16 00:47:32 RPi1B systemd[1]: Reloading. Dec 16 00:47:33 RPi1B systemd[1]: Reloading. Dec 16 00:47:34 RPi1B sudo[4538]: pam_unix(sudo:session): session closed for user root Dec 16 00:47:34 RPi1B systemd[1]: Failed to send queued message: Transport endpoint is not connected Dec 16 00:51:18 RPi1B sudo[4614]: pi : TTY=pts/0 ; PWD=/etc/init.d ; USER=root ; COMMAND=/bin/journalctl -xn Dec 16 00:51:18 RPi1B sudo[4614]: pam_unix(sudo:session): session opened for user root by pi(uid=0) :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::: $sudo dpkg --configure resilio-sync Setting up resilio-sync (2.4.4-1) ... Job for resilio-sync.service failed. See 'systemctl status resilio-sync.service' and 'journalctl -xn' for details. invoke-rc.d: initscript resilio-sync, action "start" failed. dpkg: error processing package resilio-sync (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: resilio-sync :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::: I also get this error: $systemctl --user enable resilio-sync Failed to get D-Bus connection: No such file or directory Any idea what's going wrong?
  22. I'm trying to sync between two ubuntu computers. Sometimes I drop a directory into the sync folder, and it shows up on the other computer (yay!), but I can't write to it b/c the normal user isn't in the file access control list. The only user with file access control is the rslsync user under which Relisio is running. So I have to run setfacl every time a new directory is copied over. This can't be an unusual problem. Can anyone suggest a work-around?
  23. Hi, when I start rslsync I get the error: Can't lock pid file. It seems Resilio Sync is already running with pid NNNNN I suppose that rslsync either crashed or was killed and the pid file was not deleted. Now it is blocking any new instance of rslsync. Where is the pid file that I can delete it manually? Thanks!
  24. geoffwea

    niceness - how to set

    hi Is there a way to set the niceness of resilio-sync? If i recall correctly this was a parameter available during the btsync CLI setup process. How do i set in resilio-sync please? OS = OSMC Cheers, Geoff
  25. Here's my setup: Main computer: Windows 10, only one internal HDD Second computer: Linux Mint, one internal HDD for the system, one external usb hdd for all my documents/files/folders I'm syncing some folders from the main computer to the external hdd on the second computer. It's a read and write situation on both. It worked flawlessly for over a year. But since the last Resilio update it stopped. I can't access the external HDD on the second computer via Resilio anymore. So I can't add folder, I can't sync anything. When I try to add the folder, I navigate to the the external hdd, but it never appears, no matter how long I wait. (see picture) Otherwise, this external hdd works well and is accessible via the file explorer of the system. Nothing has changed, apart from the resilio update... Tried and tried to resolve this, but no luck, and I didnt find anything on this forum or on the web to help me. Any ideas???