Search the Community

Showing results for tags 'octal'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello QNAP Model: TS-809U Firmware version: 4.1.0 Bittorrent Sync verison: 1.3.109 Linux version: 3.4.6 (root@NasX86-13) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 Normally, by default, Bittorrent Sync runs on linux as the user: “root” and group: “administrators” and writes these owner:group permissions to syncronized files and folder that it creates. In the case of the QNAP NAS, Bittorrent Sync writes files and runs as the user “admin”. I have successfully managed to enforce all sub-folders and files in my sync folder to inherit the group “btsync” in the file permissions by using: chown admin:btsync /syncchmod g+s /syncThe problem is that Bittorrent Sync creates new files and folders with read-only permissions for the group “bysync” (i.e. wxr-xr-x / octal 0755). From researching I have found that the 2 ways to change this normally would be: 1) Add this line to the btsync.conf file and restart btsync: // DAEMON_UMASK=0022) Use the following command and when prompted enter "002" as the umask dpkg-reconfigure btsyncNeither of the 2 above methods resolve the issue. In the case of item 1, this setting seems to be ignored by btsync. With item 2, “dpkg-reconfigure” is not a command available on the version of linux used by the QNAP NAS. Thank you in advance for your help!