Search the Community

Showing results for tags 'raspberrypi'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 11 results

  1. Hey Sync Team! I have been using Resilio Sync on my Raspberry Pi for quite a long time now. Everything worked fine until I decided to synchronise my photo storage (roughly 60 GB). Resilio Sync is indexing since 3 days (and nights) straight and there is no end in sight. It is also using 70% of the CPU available on my PI. My two other folders still sync without any problems (they are only 5 GB each), only the big one seems to be stuck at the indexing progress (even though everything was transferred just fine). I hope you can help me! Sincerly Alexander.
  2. Hi to everyone, I've followed this tutorial and installed resilio sync on a raspberry model B Jessie (specs below); everything works, but since that moment, when I try to run apt-get update I get an error related to ARMEL architecture, maybe because Raspbian Jessie is ARMHF. These are the error messages (sudo apt-get update): Scaricamento di:1 http://mirrordirector.raspbian.org jessie InRelease [12,2 kB] Trovato http://archive.raspberrypi.org jessie InRelease Trovato http://linux-packages.resilio.com resilio-sync InRelease Scaricamento di:2 http://linux-packages.resilio.com resilio-sync/non-free armel Packages [479 B] Scaricamento di:3 http://linux-packages.resilio.com resilio-sync/non-free armhf Packages [477 B] Ign http://linux-packages.resilio.com resilio-sync/non-free Translation-it_IT Ign http://linux-packages.resilio.com resilio-sync/non-free Translation-it Ign http://linux-packages.resilio.com resilio-sync/non-free Translation-en Recuperati 13,1 kB in 4s (3.278 B/s) W: Impossibile recuperare http://mirrordirector.raspbian.org/raspbian/dists/jessie/InRelease Impossibile trovare la voce "main/binary-armel/Packages" nel file Release (voce in sources.list errata o file danneggiato) W: Impossibile recuperare http://archive.raspberrypi.org/debian/dists/jessie/InRelease Impossibile trovare la voce "main/binary-armel/Packages" nel file Release (voce in sources.list errata o file danneggiato) E: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi. Hardware specifications (cat /proc/cpuinfo): processor : 0 model name : ARMv6-compatible processor rev 7 (v6l) BogoMIPS : 697.95 Features : half thumb fastmult vfp edsp java tls CPU implementer : 0x41 CPU architecture: 7 CPU variant : 0x0 CPU part : 0xb76 CPU revision : 7 Hardware : BCM2708 Revision : 000e Serial : 00000000f54217e7 O.S. Specifications (cat /etc/os-release): PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" How could I solve this issue? Thank you, Alex
  3. I have been trying to run resilio-sync as a personal backup cloud for my phone for a few weeks, using a raspberry pi 2 and an external HDD. I've installed following the instructions here: https://www.resilio.com/blog/official-linux-packages-for-sync-now-available and made sure I enabled automatic startup with: sudo systemctl enable resilio-sync no problems so far, until I try to acess the webgui and setup my folders in the HDD (permission error) So I edited the file in /etc/resilio-sync/config.json and added the line "directory_root" : "/pathtodrive", I stopped the service, and used the config file with: sudo rslsync --config /etc/resilio-sync/config.json At that time everything looks fine and I can add my folders without any problem. Unfortunately, whenever I reboot the pi, or it gets powered down, I always need to stop the service and point it to the config file on reboot, because the configurations get "lost" somehow. My directory_root folder disappers from the preferences in the webgui, and the folders I setup are not longer there. Shouldn't my configurations be used everytime the service starts? Why do I always have to configure sync manually? I think I'm missing something. This is my status report BTW: sudo service resilio-sync status ● resilio-sync.service - Resilio Sync service Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled) Active: active (running) since Mon 2017-01-02 23:14:15 GMT; 8h ago Docs: http://help.getsync.com/ Process: 577 ExecStart=/usr/bin/rslsync --config /etc/resilio-sync/config.json (code=exited, status=0/SUCCESS) Process: 571 ExecStartPre=/bin/chown -R rslsync:rslsync /var/run/resilio-sync (code=exited, status=0/SUCCESS) Process: 561 ExecStartPre=/bin/mkdir -p /var/run/resilio-sync (code=exited, status=0/SUCCESS) Main PID: 657 (rslsync) CGroup: /system.slice/resilio-sync.service └─657 /usr/bin/rslsync --config /etc/resilio-sync/config.json Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable. I've been trying to solve this for weeks now...
  4. Trying to get sync working on Raspberry Pi 3, running the latest Jessie update (Pixel?) I've gotten it all running and folders syncing, but it will only fill in part of the circle and then it stops syncing and displays the error "Don't have permissions to write to selected folder" History shows a lot of "Finished Syncing file [path/file]" then abruptly switches to "Failed to download [path/file] -WriteToDisk" Both the successfully written to directories and the failed are owned by Pi, and permissions are 777. Also, in Preferences, under Web UI is says "Connection settings overwritten by config" but there is no config file in /opt/resilio/bin, only LICENCE.TXT and a files called rslsync (Presumably the executable) Installed via the instructions here: https://www.resilio.com/blog/official-linux-packages-for-sync-now-available I've no idea how it is launching (config or not, what user it is running under, etc) I should add, I am syncing two calibre libraries, one eBooks, one Audiobooks. The ebook lib has synced 2058 of 14,698 items (combined files and directories) and the Audiobook library has synced 543 or 980 items Help?
  5. I am simply trying to get this up and running on my Raspberry Pi A+ (considered a PI 1, armv6), but I get the following error: bash: ./rslsync: No such file or directory. I have execute permissions and all. I am simply running the following steps: sudo mkdir -p /opt/resilio/bin sudo mkdir /opt/resilio/app_files cd /opt/resilio/bin sudo wget https://download-cdn.resilio.com/stable/linux-arm/resilio-sync_arm.tar.gz sudo tar -xvf resilio-sync_arm.tar.gz sudo rm -f resilio-sync_arm.tar.gz sudo ./rslsync --webui.listen 0.0.0.0:8888 I am ultimetely trying to do this in a docker container though, but I have no idea how this would still provide the same error: FROM resin/rpi-raspbian:jessie # Install tools RUN apt-get clean RUN apt-get update RUN apt-get install -y \ curl \ wget \ vim # Install Resilio RUN mkdir -p /app/resilio/bin WORKDIR /app/resilio/bin RUN wget https://download-cdn.getsync.com/stable/linux-arm/resilio-sync_arm.tar.gz RUN tar -xvf resilio-sync_arm.tar.gz RUN rm -f resilio-sync_arm.tar.gz EXPOSE 8888
  6. Hi, On my Raspberry Pi (model B), the version 2.3.0 of btsync cannot run, I have a "segmenation fault" message, even if I only want to show help message. I run it with OpenElec distribution : http://openelec.tv/ I don't have this problem with previous versions. raspberry:~ # wget http://download-cdn.getsync.com/2.3.0/linux-arm/BitTorrent-Sync_arm.tar.gz Connecting to download-cdn.getsync.com (54.192.76.29:80) BitTorrent-Sync_arm. 100% |***********************************************************************************************************************************************| 5097k 0:00:00 ETA raspberry:~ # tar -xzvf BitTorrent-Sync_arm.tar.gz LICENSE.TXT README btsync raspberry:~ # ./btsync --help Segmentation fault I currently use the version 2.2.7 http://download-cdn.getsync.com/2.2.7/linux-arm/BitTorrent-Sync_arm.tar.gz Thanks for your help edit : Of course, I have the same behavior with the URL used on the download page http://download-cdn.getsync.com/stable/linux-arm/BitTorrent-Sync_arm.tar.gz
  7. Hi, I'm not sure whats going on here. I have been setting up my raspberry pi with 2.3.1, but this problem happened on earlier versions too. I'm syncing a folder that has 250+GB of data on my lan between a PC and my RPi. On this version and previous versions I have had the situation where sync says it is syncing and when it finsishes the web ui on the Pi reports it has transferred all the data, but when you look on the drive it has synced the folders themselves but barely any data. I've spent too much time trying to get this to work and its starting to piss me off, this software does not work very well, its unreliable, flaky and tedious. I've gone through several iterations of setup with it now trying to get the same data syncing, on 2 different Rpi. At this point I'm thinking samba and some simple scripts is going to be a lot better that this.
  8. Microsoft just announced that the Raspberry Pi will support Windows 10, and I think this would be perfect for Sync! Any plans for making Sync for Windows 10 on ARM?
  9. Hello, I'd like to sync my Android-Pictures to my Laptop and an always-on-RaspberryPi. Following setup after creating Secrets via API: Laptop: ReadWrite Android: ReadWrite RasPi: EncryptedSecret For testing purposes I closed BTSync on my Laptop, and expected a transmission of pictures to my RasPi. But nothing happened. BTSync showed a connected Peer, even correctly displaying the amount of Data and the numbers of Files, but my Android-Phone just did not want to sync. I turned my Laptop on, and my Phone started syncing to my Laptop - which succesfully synced to the RaspberryPi. Turning my Laptop off after a while - sync from Android to RasPi wont continue. Adding the ReadWrite Secret to the RaspberryPi works like a charm - but other people have access to the attached storage as well, so I would like to store my pictures encrypted.... Any Ideas? Just Reinstalled BTSync without Backup/Restore, did not help. FYI: I'm encountering the "App crashes regulary error" (Already discussed in some other topics) as well, before the reinstallation just as afterwards, stopped crashing when attached to a power source [did not]. Thank you very much in advance Sincerely Dominik edit: after the reinstall BTSync on my RasPi does not receive the correct number of files anymore, on my Laptop it does. edit2: well, it does get the number of files after a while.... and even whilst crashing everytime, the backround-sync does work anyway
  10. Hello I have a Windows 8 x64 with BTSync (1.1.70) on it I have a Raspberry Pi with (1.1.48) On Windows I get these errors (I has synced 12.4GB out of 17.1GB) How do I get a error log for the Raspberry Pi? To help work out why I keep getting these errors. Also if anyone know how to fix this? Thanks
  11. Hi! I checked this twice before I posted, it is still to strange to be real: me@myRaspberry:/home/me/.sync# date && tail sync.log Sat Jun 22 14:45:24 CEST 2013 [20130522 14:44:44.609] SyncFileEntry: got dictionary with bad time 1371893371 0 [20130522 14:44:44.610] Merge: failed to construct file entry received from remote, aborting [20130522 14:44:54.447] SyncFileEntry: got dictionary with bad time 1371893371 0 [20130522 14:44:54.447] Merge: failed to construct file entry received from remote, aborting [20130522 14:45:04.667] SyncFileEntry: got dictionary with bad time 1371893371 0 [20130522 14:45:04.668] Merge: failed to construct file entry received from remote, aborting So what? Well, obviously we have the 22nd of june. And as we can see btsync is up and running, doing as well as it can. But it reports strange problems with a "bad time"- well, indeed it reports those problems one month in the past, that is the 22nd of _MAY_.. Raspi has no RTC, that COULD be related to this, but as you see it IS in sync and it WAS in sync 2 minutes earlier to the occurence of the last log lines Might or might not be related. I don't even care to much about the wrong log-date (sure you'll fix it in coming releases) but I DO care about the bad time, as it seems to prevent my share to sync. As far as I can tell no strange data (datetime) occurs in the source- directory, even more sure it doesn't in the destination- so called since it is readOnly and used for backup only.. Oh, I forgot: Raspi is ARM, Version is 1.1.15. Any feedback is appreciated, Rudi