Search the Community

Showing results for tags 'settings'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resilio Sync
    • Sync General Discussion
    • Sync Troubleshooting
    • Sync for NAS (Network Attached Storage)
    • Sync Stories
    • Developers
    • Feature Requests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 17 results

  1. I want to achieve the following, I have a desktop and a laptop and a Netgear ReadyNas device. I want to sync the My Documents across the laptop and desktop via the Nas i.e. from the desktop to the Nas then from the nas to the laptop and vice versa. I have the latest versions of Resilio sync on all devices. What folder do I add on the Nas as the intermediate folder? When I try an add the My Documents on either the desktop or laptop I get a message saying you don't have permission to write to this folder. I'm not sure I understand the setup really. I want to go via the Nas because that is always on whereas the desktop or laptop may not necessarily be powered on together. Regards Pete
  2. I've installed resilio sync on a couple new devices and I'm seeing inconsistent and incorrect behavior. Each of the last four machines I set to Disconnect state when initializing them, but as soon as I committed the setting, resilio sync started downloading all shares, and not selective. This causes a massive disruption, as the system then slows down so much that it takes forever for me to change each of the 40 shares back to disconnected and delete all the accidental share additions. Is anyone else experiencing something similar? Any ideas on how to fix this?
  3. I was facing this issue since few months. Frequently, All my resilio settings were lost and I used some really undesirable workarounds till now. Today I found a perfect solution which works everytime. The Setup: System: Centos 6.6 x86_64 wget https://download-cdn.resilio.com/stable/linux-x64/resilio-sync_x64.tar.gz cd /home/user/bin tar -xf ../resilio-sync_x64.tar.gz ./rslsync Running above commands, I could access the webUI and did all the settings (setting up username and password etc.). After 2 days I logged in to the same machine and ./bin/rslsync The service started. I accessed the webUI and for my surprise, I was asked the username, password and re-enter password which was asked 2 days ago, It looked like all the settings were lost. Same issue while using crontab. Solution: I noticed a .sync directory inside /home/user/bin/ Copied the directory inside the home directory cp -r /home/user/bin/.sync /home/user/bin Killed resilio sync and restarted it. Everything works fine now. Is it a bug? A NO from me. Reason: When you run the rslsync for the first time, The .sync directory which stores all the information about sync is created in the Current Working Directory. While running rslsync, You need to be in the directory which was your pwd while you first ran rslsync Let's say, You are running resilio for the very first time. rslsync binary is stored in /home/user/bin/ , And you did cd /home/Downloads /home/user/bin/rslsync resilio will start and .sync directory will be created in your pwd ie. /home/user/Downloads Next time, If you are in your home directory and you do /home/user/bin/rslsync Resilio will start but settings will be lost. But, cd /home/user/Downloads /home/user/bin/rslsync will work This is troublesome if you only have 1 resilio setup. So make sure you run rslsync in your home directory initially. On the other side, If you want to have multiple resilio setups on the same machine and that too with the same user, This "so called bug" is awesome. You can have multiple different shares with different credentials and different setups. Though only 1 will be running at a time. Hope this helped. Thanks
  4. Hi everybody, I have two NAS (DS 214, DSM 6.1.3-15152 Update 3) with BitTorrent Sync (Version 2.3.7-1) to synchronize data between distant locations. Now I noticed syncing files (I guess only new ones, but can't ensure) from one NAS to the other one fails since about one month ago, in the log I see lot's of messages like this: [20170826 05:26:49.206] MC[1CCF] [18FC]: processing get_nodes message for /NAS_II/<Path>/<Filename> [20170826 05:26:49.207] MC[1CCF] [18FC]: too many nodes to send 190671, stopping at /NAS_II/<Path>/<Filename> A tipp I found in the internet told increasing max_torrent_metadata_size could probably solve the problem - I tried to do this and suprisingly found the change is undone when I restart BitTorrent Sync (no matter if I use the start-stop script or with reboot). I tested a lot, nearly every modification I make in the WebGui is undone after restarting (allthough it persists when I close/open WebGui without re-starting): all normal and power user preferences additional added rows in the WebGui-overview (i.e. Progress, Last synced) after I removed one connection to a shared folder on the other NAS it was really removed from the list, it wasn's visible anymore after restart, but trying to re-add the same folder again fails with a message 'the selected folder is already added to sync', even after I manually deleted the '.sync' folder, so it seems the removing wasn't done completely. This behavior is the same on both NAS! I attached a ZIP file containing: sync.log which was recorded while I started btsync, waited some minutes, started WebGui, waited, changed some preferences, waited, rebooted NAS, waited, stopped btsync. settings.dat and settings.dat.old as they were after stopping btsync. About the sync.log file: The shared folder in question is /volume1/FC/ Any help is apreciated. Have a nice day, best regards, Zopppo logs.zip
  5. Hello, I'm about to reset my Android phone and before I do that, I would like to be able to backup my Resilio Sync current configuration of synced folders and settings. How can I do this? Thanks in advance, Shai
  6. Hi there! I am hoping someone can help me as I am a bit lost. I have setup Resilio Sync on Linux (Raspbian to be exact) but now I think I have done something wrong and it keeps trying to start Sync as a different user. I have about 7 folders synced with 15gb so I really don't want to start again. It all started when I began trying to get the service to run at boot. It was working fine prior to this point. I tried to edit the service file via the following sudo nano /lib/systemd/system/resilio-sync.service and changed the User & Group variables to pi. I also changed the WantedBy to default.target I edited /usr/lib/systemd/user/resilio-sync.service to also have WantedBy to default.target This was the last point I could see the folders when I checked by opening the gui. I tried a crontab by: sudo crontab -e And adding: @reboot rslsync I think I tried a different function in here to add it to the systemd as another way to try and get it to load on boot, but I can't get my terminal to recall it for some reason. I found a guide that said this may be an issue as I initially set it up under the rslsync user. I changed it to pi after install as I am syncing the files on a USB and rslsync did not have the correct permissions to access the media. So I ran the following: systemctl --user disable resilio-sync sudo systemctl disable resilio-sync systemctl --user enable resilio-sync I found a guide that said when running on headless to always force it to run as the current user to use - sudo loginctl enable-linger pi Now the service does start at boot (which I have checked by opening the gui directly after boot), but it doesn't show my folders - it loads into the setup box asking to set a username and password. Have I destroyed my setup or have I just made a faux par by making it load as a different user? Thanks in advance for the help, I am a bit stressed as I was getting this setup before I depart on a vacation.
  7. maccra

    Saving settings

    Hello, I am running Resilio Sync Pro on Win 10 Pro x64 and am syncing some folders to 2 other machines. I have set up some folders to sync, Some Advance folders, standar folders and encrypted folders. Because I am the onlt one using these 3 mchines I want to set up RW permissions for each folder. Currently some folders have only Read permision and when I change it to RW, it appears that Resilio Sync does not save the configuration. There is no special "save: button anywhere so how do you actually save changes to the settings. Many Thanks
  8. In the new version 2.2.5 I no longer see under 'Preferences' check boxes for 'Status', 'Peers online' , 'Receiving', Sending', 'Progress' and 'Path'. Looks like the UI changed and I am having hard time finding these setting. Any help will be greatly appreciated. Thank you, Michael Abadjiev Well I figured it out - right click on a column gives all the options.
  9. Hi, After upgrading one point release from 2.0.104 to 2.0.105 on both my 64 and 32 bit Ubuntu 14.04 machines the GUI on 8888 welcomes me with Welcome to BitTorrent Sync., create a user name etc. In other words, it seems to have lost my original setup. Further, on the 64 bit machine I went ahead and created an account again. I using my iPhone Sync App to link devices. Unfortunately: - it did not recognise any of the previously sync'd files. - Now I have the same device name twice in the list of devices but only one is online. - There seems no way to unlink the device with the same name that now can never come online. - Its started syncing with my Mac (2.0.105) and Raspberry Pi (2.0.1.04) running Sync and created a load of the same directories appending a (1) at the end not to mention sync'ing gigabytes of data. I haven't proceeded creating a new account on my 32 bit ubuntu machine in case this is a bug. The Mac version seems to be running fine. The only modification I have made recently is to automate the startup of BTSync on the Ubuntu boxes using the following supplied by the helpdesk: 1) sudo su 2) nano /usr/local/bin/bt.sh 3) Put in /usr/local/bin/bt.sh the following lines: #!/bin/bash cd /your_folder_where_btsync_was_unpacked ./btsync --webui.listen 0.0.0.0:8888 4) Ctrl+x 5) Y 6) chmod +x /usr/local/bin/bt.sh 7) nano /etc/rc.local 8) Put the following line above the "exit 0" line (see the attached pic): sudo sh /usr/local/bin/bt.sh 9) Ctrl+x Then reboot your computer and check btsync in proceses. It must start automatically. Here you are. After making the above change in 2.0.104 all my devices were still linked together and thats why I think there is a bug or several in 105. Questions:- Is this a known bug with this release? - how do I recover from it?
  10. I'm looking to adjust the speed of downloading and uploading on a set schedule. During the day I don't want to use too much bandwidth so I limit it quite a bit but at night while everyone is asleep I want it to use all the bandwidth it can. No big deal I just have to update the settings correct? Either I missed the settings location to do this automatically in the web interface or it isn't a feature; I suspect the latter. My other option is to just update the config file automatically to change the speed settings and use CRON to schedule the file change. Any suggestions to a better solution? Thanks!
  11. I've been using BTSync for a while now and it's absolutely fantastic! I've just set it up to sync a load of my files between my computer, an external hard drive in my house connected to a Raspberry Pi, and a second Raspberry Pi and external hard drive in my parents house. This had been working very well but today I rebooted the Pi at my parents house and when it came on the GUI (ipAddress:8888/gui) prompted for an account to be created and then showed the no folders message. On the other syncing devices it shows it as offline. I copied the contents of the .sync folder somewhere else so I could preserve it. Looking inside I saw that there were files called history.dat.old, settings.dat.old and sync.dat.old along side the same files without the .old extension. history.dat.old and sync.dat.old contain different things to their "new" counterparts but settings.dat.old appears to be the same (although it is just one long line so I may well have missed something). I tried renaming the .dat.old files to be the .dat files and the .dat files to be the .dat.old files and then restarting again but basically the same happened again. I've got quite a number of large folders synced between the two so I'd really rather not have to redo all the syncing if I can possibly avoid it. More than that I'd like to know how it happened and how I can stop it from happening again. Any help would be greatly appreciated.
  12. Hi, User story: "As a user I want to restict the syncing only to a branch of a subnet to further increase the security and reduce traffic on other subnets." Background: In the case that you want to keep syncing of multiple machines in a sub-net local to reduce traffic you would want to switch off DHT and tracker servers. If you use LAN discovery there will still be broadcast messages generated. To remove those you would have to specify a list of predefined hosts. BUT it can well be that those are not known because you still have a DHCP server running and so you do not exactely know the IPs that are given to a new (but allowed to sync) machine. So, in a class C subnet you could work around by listing all IP's from .1 to .254 - however this is quite cumbersome and can be come even unpracticable if you have to use a class B subnet. So, it would be handy if there were wildcards that you could add in the nerwork mask. I was trying to set 192.168.100.*:3838 ; 192.168.100.0:3838 ; 192.168.100.1-254:3838 but sync only happened when I defined the unique IP of the other host. Is there a way to use wildcards in this list?
  13. I was wondering if anybody had experience syncing the "/Applications", "~/Library/Application Support" & "~/Library/Preferences" folder in OS X between 2 computers. I'm wondering if theres any caveats I should be aware of or problems that might occur. Thanks, -Eric
  14. manumphoto

    ".syncpreferences" File

    I would like to have a ".SyncPreferences" file where i can set sync preferences for each specific folder or file. If i have the Folders: --> Synced Folder --> Sub Folder 1 --> Sub Folder 2 --> Sub Folder 3 I could say in the ".SyncPreferences" file: Folder2 { relay_server: false; tracker_server: false; search_lan: true;}So that my "Folder2" will only sync over a LAN connection.
  15. Hi people I've been seeing that running the latest provided linux binary (x86_64 and i386) cause a dramatic DNS slowdown and make the system(13.04 and 13.10) unusable, ala http://forum.bittorrent.com/topic/20498-causing-dns-timeouts/. Stopping the service immediately cures the problems. Does anyone have any suggestions for the problem and can changing settings (relay server, DHT, Tracker server) make a difference to this? I know I might be repeating a post or two but can't seem to search the forum to see if others have similar problems and solutions as DNS is only 3 letters long and the forum rejects the search. Thanks Andy
  16. hi, i have to setup my pc to a new installation and want to move my settings from the old machine to the new one. is it possible to copy the folder: c:\Users\blacky\AppData\Roaming\BitTorrent Sync\ to the new pc and start bittorrent sync?? or is this a problem to get my program work on teh new pc ?? or is there another way to save and restore settings ?? please give me a hint .....
  17. Hey guys so here's the question: What I want to/need to do is be able to change computers on which an external drive is syncing. Computer A is syncing a hard drive with another location, but I want to move all my SyncApp settings to Computer B and continue syncing with that same location without having to reindex everything or redownload everything. Any suggestions or help? Thanks in advanced.