If You Have Sync Issue


Recommended Posts

Hi all

 

I have an issue .SyncIgnore is ignored by sync app

I'm trying to sync my Lightroom catalogs but without previews and other temporary data

 

Right now content of .SyncIgnore is identical on all computers and looks like 

 

.TrashesIcon?ehthumbs.dbdesktop.iniThumbs.db*.lrdata*.lrprev*.lock*.lrcat-journal*.db-journaldesktop Previews.lrdataroot-pixels.dbpreviews.dbTemporary Import Data.dbTemporary Import Data-2.dbTemporary Import Data-2.db-jornal
 
 
I now it's redundant but it still doesn't work 
and I see in the history huge amount of strings like 
finished sync zenbook\zenbook Previews.lrdata\0\0005\000525FD-FB4A-4ED6-84C6-0439574444F3-077b070982fd42045ed5e932196fb988.lrprev 
 
 
I've tried  to restar btsync, to remove and add again relder an resync it no luck. I still syncing tones of useless preview data.
 
Is there any suggestions?  
Link to post
Share on other sites
  • Replies 244
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

If you have Sync issue, then we are here to help you. Having right problem description and logs will mean that your problem will be fixed in a matter of hours. Just email us at syncapp@bittorrent.com

A quick suggestion: maybe you should add this info directly into SyncApp, since users may not think about coming to these forums to ask for help.

Would be great! I'm looking forward to test the update (especially the improved secret keys).

I have a very small bug report (or perhaps just an edge case, I think!) 

I have sync on a mac laptop and it moves from my home network to my school network while asleep. When this move is made, sync (I think) does not re-forward ports or whatever is necessary to sync out of a network. This means that sync does not work when I get to school unless I restart sync or my pc (same difference).

 

Can something be changed to check ports or recognize different networks, or in some way detect and handle this case better?

 

Thanks for the great work.

Link to post
Share on other sites
  • 2 weeks later...

I'm having some issues with temporary files. Sync leaves .!sync files stuck when it's trying to copy temporary lock files generated by AutoCAD when opening a drawing. When you open a dwg file with AutoCAD it generates 2 dwl files to avoid the first file to be edited at the same time by another person. BT sync tends to leave a !sync file for those files that are not erased by the user but just disappear when closing the main file.

I experienced the same behaviour with other temporary files from other programs.

 

As a workaround could a rule be established to avoid those files? Maybe in syncignore?

Link to post
Share on other sites

Hi everyone.

 

I have the problem that I cannot set the speed limit of downloads and uploads. I have set it to 150Kb/s because my connection is slow and there are other machines in the network which also need some speed. But Bittorrent Sync will still download or sync with the maximum speed it gets.

 

Is this a bug or is there a fix?

 

Thx

Link to post
Share on other sites

On a setup where the file is updated on an OS X machine, and synced to 64-bit FreeBSD and Linux boxes.

 

With version 1.2.73, I occasionally get an issue where a single file just refuses to update. The file keeps on being re-transmitted over and over. The receiving party shows the following error in the log;

 

PIECE 0 FAILED HASH CHECK

 

It's actually quite difficult to get rid of this error. So far the only thing that has worked for me is to move the file to ~/tmp, stop all clients, remove any remaing !sync and !syncOld files, start all clients, and move the file back into the sync folder.

Link to post
Share on other sites
Hi TumbleCow, could you please send us debug logs from your machines? 

You need: 

Step 1. Turn on Debug Logging. 

Mac: click on BitTorrent Sync icon and select "Enable Debug Logging". 

Linux: create file debug.txt with contents of FFFF in the folder where btsync binary is located. 

Step 2. Reproduce issue. 

Please let Sync collect logs for at least 15 minutes to get enough information. 

Step 3. Attach log files and send to syncapp@bittorrent.com

Mac: ~/Library/Application\ Support/BitTorrent\ Sync/sync.log 

Linux: ./sync/sync.log 

Thanks!

Link to post
Share on other sites

Hello everybody , im new with this program anda i have some issues , i've installed BTSync on my pc and installed the app on two android devices, and when i do a backupfolder on my smarthphone with the first device all works fine but when i try to do a backup folderadding a second folder anything happens just say 0B in 0 Files and never sync can someone helpme thanks 

Link to post
Share on other sites

Using Windows 2008 R2 Server with Bittorent Sync version 1.2.73

 

As per this thread http://forum.bittorrent.com/topic/25076-failed-to-download-postdownload-cannot-create-a-file-when-that-file-already-exists/ , I too am having this issue where I see "PostDownload: Cannot create a file when that file already exists." logged for numerous files, and the modified file is not sync'd.

 

After turning on logging at the affected machine I see numerous entries such as these that explain why: 

 

[2013-11-30 10:10:11.873] TorrentFile: failed to rename \\?\E:\MP07LiveDocBackup\Ahead\4\MRUClients.ini into .SyncOld - 183
[2013-11-30 10:10:11.898] Error: \\?\E:\MP07LiveDocBackup\Ahead\4\MRUClients.ini - PostDownload: Cannot create a file when that file already exists. 
 
I've restarted BTSync several times and the issue returns, I've examined the process via Procmon and can see that the process is failing when it tries to rename MRUClients.ini to MRUClients.ini.SyncOld . (ReplaceIfExists = False)  
The .SyncOld file exists from a previous sync.
 
Manually deleting all the .SyncOld files gets things back on track.
Edited by mrpbdy
Link to post
Share on other sites

Hi all,

thanks a lot for developing this great app!

I have an issue with SyncApp.

 

Title: Do not consider all data in not accessible location as deleted and do not delete files on all synced devices

 

 

Here is a user story if you prefer that:

As a user who has a synced folder on an external drive I would like sync to be stopped for that folder if device is removed so that I do not loose my data on all other devices.

 

This can be quite a big issue. I was only able to restore my data from the external drive when I connected it again. I was lucky that I still had it.

 

How to reproduce:

Precodition:

1. Synced folder is located on device Alpha on a hard drive

2. Synced folder is located on device Beta on an EXTERNAL hard drive

3. Devices have sync app running

3. Folders are completely synced using a secret (not the read-only one)

Action:

1. Remove the external hard drive from the device Beta

Expected:

1. Folder on device Beta is marked as not accessible

2. Sync is stopped for the folder on device Beta

3. Sync is stopped for this folder on device Alpha - just like if device Beta went offline

Observed:

1. Folder on device Beta is marked as not accessible(OK)

2. Folder is cleared on device Alpha. Logs says "Beta removed file XXX". Data is lost(NOK)

 

I think this must be quite easy to reproduce.

 

Hope this helps.

Link to post
Share on other sites
  • 2 weeks later...

version 1.2.82

hi.

my aplication try synchronize in .SYNCARCHIVE folder from other device. I delete it but resynchronize again, again.

is there a solution?

 

 

[2013-12-09 03:22:54.688] Blocked downloading file .SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\.SYNCARCHIVE\xxx.txt due Connection closed

 

Link to post
Share on other sites
You can stop resynchronize .SYNCARHIVE: 
1. Delete the folder from btsync on all devices
2. Quit btsync on all devices
3. Delete the .SYNCARHIVE on all devices
4. Launch btsync and add folder for synchronization
Folder .SyncArchive will be created automaticaly.
Thanks!

PS. Please note that modifying of system files may lead to malfunction of the app.
 
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.