Feedback: BTSync on Linux


dswd

Recommended Posts

I'm getting 100% cpu usage on Ubuntu 12.04. It seems to be working but I cannot get any debug logs.

Works fine on Debian 6 though so I was wondering if anyone has any ideas on what could be wrong?

Same here... Linux deadend 3.5.0-18-generic #29-Ubuntu SMP Wed Oct 24 19:51:55 UTC 2012 i686 i686 i386 GNU/Linux

Link to post
Share on other sites

Please pardon my newbness, but is it possible to run two instances of btsync on Ubuntu Server?

I'm running into permissions issues when syncing folders. I installed btsync on /home/'myuser'/btsync , and use the read only secret as a "backup solution" to push files from my PC and MAC to my NAS (Ubuntu Server). But, when I want to sync another users's files to another directory "/media/documents/'anotheruser' with the owner being 'anotheruser' and chmod set to 775, I still get permission denied.

Even when I changed the owner of that directory to 'myuser' btsync still doesn't sync the files.

Noone wanted to help the newb - eh? j/k. I figured it out. I went ahead and installed btsync on that users directory. Even though I used the configuration file to start the second process, the webgui did NOT work (yes, I changed the port). Therefore, I had to hardcode the folder settings and secrets in the text file. It works for now, and I understand that this is an alpha release. Just wanted to share my experience on linux (Ubuntu Server 12.04 LTS).

Link to post
Share on other sites

Same here... Linux deadend 3.5.0-18-generic #29-Ubuntu SMP Wed Oct 24 19:51:55 UTC 2012 i686 i686 i386 GNU/Linux

Do you have another btsync process running on the same box? I noticed when I tried to run btsync a second time without the configuration file, it started but ran at 100 cpu. I suspect there is an issue when it tries to grab the same 8888 port that's already in use by the first process.

Link to post
Share on other sites

I use this (http://code.google.com/p/spindown/) to spindown and monitor the disks. When i stop the deamon with your script disk accessing is stopped, when i start the deamon, disks are accessed again about every 10 seconds.

Running the deamon with btsync --config spins tje disks up every 10 minutes as programmed by the developers to scan for file changes.

So it's really start-stop-daemon's fault. I'll investigate why this is happening.

This is how I start it as a system job with ubuntu (last LTS version, couldn't remember number) using upstart.

1. Create btsync.conf on /etc/init.d/

2. file contains 2 lines:

# home in my setup is another hard drive.

start on mounted MOUNTPOINT=/home TYPE=ext4

# starts as non-root user

exec start-stop-daemon --start -c myuser --exec /home/myuser/btsync

3. this satisfies my needs.

Sweet! Despite the need to have a separate copy of btsync's binary, it's very simple and good to go!

Upstart has its way to track the daemon's PID and I'm not sure if it can handle multiple PIDs. To run btsync for multiple users we need to specify two services, something like btsync-all and btsync-user. btsync-all is going to start a btsync-user for every user and let upstart control the PID generated in btsync-user instance. (I'm not an Upstart specialist, so I can be very wrong in this case)

Another good thing to do is a safety check for all configuration files to prevent the execution of btsync if webui is enabled and the same port number appears in some of them.

Link to post
Share on other sites
  • 2 months later...

Do you have another btsync process running on the same box? I noticed when I tried to run btsync a second time without the configuration file, it started but ran at 100 cpu. I suspect there is an issue when it tries to grab the same 8888 port that's already in use by the first process.

Hello,

My guess: you may have multiple instances, as long as they

- don't have the same PID file

- don't use the same port

- don't use the same data directory (default ~/.sync)

- don't sync the same directories

This kind of setup may be good for a multi-user use - else, a single instance with multiple directories is far better.

Link to post
Share on other sites
  • 1 month later...

It works generally very good. However I have 1 major problem:

  • My external harddrive spins down after a while. There are about 600 files in the indexed folder on my external harddrive. After a while (and spindown harddrive) BTSync shows that there are 300 files. Then 200. Then 100. Then 10.
  • And when my harddrive spins again it does NOT reindex the files! It's like BTSync completely ignores the files it forgot during spindown. New files it however indexes immediately.
  • I have to delete the shared folder in BTSync and recreate it to reindex it completely.

Please, do you have a solution (I use Version 1.1.70)?

PS: A shutdown button in the web-interface would be nice.

Link to post
Share on other sites

Hi,

Some feedback for Linux:

- have a btsync-client which allows to see the progress on transfers because when we use the config file we have no idea of what's going on (and the logs are not helpful)

- have a command to allow btsync to reload the configuration file (without having to stop/start it)

Otherwise it's a good piece of software :)

Link to post
Share on other sites

Noone wanted to help the newb - eh? j/k. I figured it out. I went ahead and installed btsync on that users directory. Even though I used the configuration file to start the second process, the webgui did NOT work (yes, I changed the port). Therefore, I had to hardcode the folder settings and secrets in the text file. It works for now, and I understand that this is an alpha release. Just wanted to share my experience on linux (Ubuntu Server 12.04 LTS).

I had the same problem (Ubuntu 13.04, btsync 1.1.70). I noticed, however, that the problem occurs only taking two windows open at once in the same browser, each with one of the two GUI. Try opening a GUI at a time.

Link to post
Share on other sites
  • 5 weeks later...

Not works for me, i try on my ARM pc (cubieboard2), "sh btsync" then "btsync: 1: btsync: Syntax error: word unexpected (expecting ")")" error. Any suggestions?

 

I know what's the problem now, the ARM package is simply not an ARM package... it's a synology package, as it not compatible with all arm devices, just with few...

Link to post
Share on other sites
  • 5 months later...

I'm running Debian on server and launched btsync just fine, but there is a big problem. It makes the system slow, load average increases with time up to the limits when the system becomes unresponsive.

 

I tried to decrease the number of syncing peers but it did not help. Actually the system took a bit more time to became slow but at the end I had to recover it from failures.

 

My current clear intension is to limit btsync usage on my server systems, stop all daemons, remove them from autostart and make only manual syncing of big archives when needed.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.