mac2000

Wich ports should be oppened?

Recommended Posts

On the Preferences tab of SyncApp, there's a "Listening Port" setting (by default, this will be a random port, and different for each running copy of SyncApp on your various devices), and also a "Use NAT UPnP mapping" - If this option is ticked, SyncApp will automatically try to open the "Listening Port" on your NAT.

If it is unable to do this, you can manually open a port on your NAT, and then enter that port number into the "Listening Port" setting within SyncApp

Share this post


Link to post
Share on other sites

I got 21992 as listening port

Asked my admin to add it as allowed in our firewall

But in sync.log there is:

[2013-04-17 13:41:42] Got 2 tracker ips

[2013-04-17 13:41:42] Tracker ip 54.225.100.8:3000

[2013-04-17 13:41:42] Tracker ip 54.225.92.50:3000

...

[2013-04-17 13:41:47] Incoming connection from 192.168.5.72:57273

[2013-04-17 13:41:48] Incoming connection from 192.168.5.68:52312

Does 3000 port required to be oppened?

Will all this work without port forwarding on NAT?

Share this post


Link to post
Share on other sites

I would also like to know this, which ports need to open for what options.

I have a device that will not sync behind a corporate firewall, and one device which I tested outside the firewall and it works fine.

I need these ports to punch a hole in the firewall.

Thanks

Share this post


Link to post
Share on other sites

Does anyone know how the protocol initiates? E.G. how I can provoke a reply from the server? I want to verify that it's connecting, although, opening a connection (nc ip listeningPort) doesn't seem to log anything, although, it does seem to connect.

Share this post


Link to post
Share on other sites

Does anyone know how the protocol initiates? E.G. how I can provoke a reply from the server? I want to verify that it's connecting, although, opening a connection (nc ip listeningPort) doesn't seem to log anything, although, it does seem to connect.

This thread was started to ask about what ports BTsync uses.

I suggest looking at the developer documentation if you want to figure out the protocol.

Either that or start a new thread, your question is off topic.

Please and thanks.

Share this post


Link to post
Share on other sites

This thread was started to ask about what ports BTsync uses.

I suggest looking at the developer documentation if you want to figure out the protocol.

Either that or start a new thread, your question is off topic.

Please and thanks.

I think it still fits in this topic, this topic is about setting up connections, mine is about diagnosing connections. Potato Po-tat-o.

Share this post


Link to post
Share on other sites

Enable debug logging, and then check the log files!

I still have to do this, kind of annoying, I have to RDP into my other box.

Currently I have one using port X, the other using port X+1 (just to be safe), both port forwarded, both picked up by nmap as an "option port", but detected on my box running btsync as a open connection from one to the other, and, one of the btsyncs even detects the other two, the other two just don't detect it:-

"Tower UK" POV:-

FhwwtTq.png

"Laptop" POV:-

tJfUaiX.png

"Tower US" POV:-

WI0Bjr5.png

Share this post


Link to post
Share on other sites

Have you also instructed BitTorrent Sync to use this port?

I use listen port 8086 and opened that up on the firewall, and instructed BTsync to use it.

However in debugging it connects to tracker via port 3000, so I also opened that up on the fire wall.

[2013-04-24 15:28:32] Got 2 tracker ips

[2013-04-24 15:28:32] Tracker ip 54.225.100.8:3000

[2013-04-24 15:28:32] Tracker ip 54.225.92.50:3000

[2013-04-24 15:28:32] Got 2 relay ips

[2013-04-24 15:28:32] Server ip 67.215.231.242:3000

[2013-04-24 15:28:32] Server ip 67.215.229.106:3000

Still not working though.

Share this post


Link to post
Share on other sites

I'm an idiot, UDP needs to be open on your listening port, not TCP.

That may or may not help you exist, does for me.

Damn, that was it, as soon as I switched both 8086 and 3000 to UDP it started syncing.

Thanks for that.

Share this post


Link to post
Share on other sites

Ok it also seems to work.

I had the same problem.

I am using a corporate Firewall and configured the BTsync Ubuntu website Client like this:

Website listen to UDP 8888

Sync listen to UDP 9999

Using UPnP

I opened on my firewall:

UDP 9999 and UDP 3000

I don't want that the website is accessible via the Internet.

and now it seems to work....

Share this post


Link to post
Share on other sites

Just for info

We had some sites that outgoing ports were blocked!

As soon as port UDP 3000 was open regardless of the listening port, it worked right away!

 

So, if outgoing ports are blocked, yes port UDP 3000 need to be open for btsync to work.

Share this post


Link to post
Share on other sites

Sorry I don't know how to start a new topic

 

I have 2 uploads movies and 1 dowload movie. Everything was doing ok but suddently I noticed that there aren't any KB/s receiving or sending, and all my downloads and uploads are stucked.

What can I do?

Thanks

Share this post


Link to post
Share on other sites

I was experiencing problems with BTSync on my NAS. Synced perfectly to other devices inside my LAN, but not over WAN. I tested forwarding "listening port" (UDP) + port 3838 (UDP) from router to NAS -  and now I can sync over the internet.

 

I still have 2 questions:

 

(1) Is UDP only sufficient ... or should I go to UDP + TCP on both ports?

 

(2) What is the purpose of opening port 3838? What service does it connect to?

 

Thanks.

Share this post


Link to post
Share on other sites

*** BUMP ***

 

Does anyone have a concise port forwarding setup for btsync installed on an NAS that's behind a residential router; and where UPnP is disabled?

 

Which ports (other than the listening port), and which protocols?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi. Can someone offer any assistance to my issue. I have a computer behind a corp. firewall but can't get it to sync to an outside device/pc. I followed some of the solutions above by opening up UDP ports 3000 and 3838, but no dice. Any thoughts? Thanks! 

Share this post


Link to post
Share on other sites

There is a difference, related to the direction of the traffic, over your router:

 

Inbound (NAT) Enable uPnP on your router & in your Sync preferences, if you do not wish to do this manually

1. the "listening port" needs to be forwarded from your router to your machine

 

Outbound (Usually only on hardware type firewalls, as home router setups normally allows all traffic outbound)

2. Ports 3838 and 3000 needs to be allowed outbound on your router.

 

From titbits I've picked up over the forum, it be best to allow both UDP & TCP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.