NAS Advanced Application Settings


TinMan

Recommended Posts

I'm trying to apply the advanced application settings to a running version of btsync on my NAS. I have it running perfectly without the Advanced Application Settings and I think it's just a formatting error when I try to add them.

I keep getting this error

Error while parsing config file: parse error: after key and value, inside map, I expect ',' or '}'

orrent Sync User Guide. "disk_low_priority" : true, "

(right here) ------^

And the section looks like this

// Advanced preferences can be added to config file.

// Info is available in BitTorrent Sync User Guide.

"disk_low_priority" : true,

"lan_encrypt_data" : true,

"lan_use_tcp" : true,

"rate_limit_local_peers" : false

}

Any suggestions?

Just to clarify, I want to turn on the "lan_use_tcp" advanced setting as I read it helps to lower the CPU usage and my NAS isn't very powerful to begin with.

Link to post
Share on other sites

Tried that, actually tried multiple combinations of comas at different locations and still the same error. I need to know what the format is that btsync is expecting. I noticed other settings have the following format

"webui" :

{

"listen" : "0.0.0.0:8888"

"login" : "admin"

"password" : "password"

}

Is btsync expecting this format for advanced settings? If so, what is the format structure? There is no documentation on it that I can find anywhere.

Link to post
Share on other sites

Tried that, actually tried multiple combinations of comas at different locations and still the same error. I need to know what the format is that btsync is expecting. I noticed other settings have the following format

"webui" :

{

"listen" : "0.0.0.0:8888"

"login" : "admin"

"password" : "password"

}

Is btsync expecting this format for advanced settings? If so, what is the format structure? There is no documentation on it that I can find anywhere.

I got it working by just adding a comma before ,"disk_low_priority"

the app started, whether it took the configs I am not sure yet.

Link to post
Share on other sites

This advice hurts, I really don't recommend "testing with more commas", if you don't understand basic JSON formatting, read up on it. The answer isn't in the comma, it's in the formatting:-

http://www.json.org/

well actually this is the most perfect formatting i could come up with.

but still doesnt work.

do you know what is wrong ?


{
"device_name": "VPS",
"check_for_updates" : true,
"disk_low_priority" : false,
"lan_encrypt_data" : true,
"lan_use_tcp" : true,
"rate_limit_local_peers": false,
"webui" :{
"listen" : "0.0.0.0:8888",
"login" : "INI",
"password" : "***"
},
"shared_folders" :
[
]
}

Link to post
Share on other sites

oh crap its the "" just delete them and write them again. dont copy past


{
"device_name": "VPS",
"check_for_updates" : true,
"disk_low_priority" : false,
"lan_encrypt_data" : true,
"lan_use_tcp" : true,
"rate_limit_local_peers": false,
"webui" :{
"listen" : "0.0.0.0:8888",
"login" : "INI",
"password" : "***"
},
"shared_folders" :
[
]
}

its working now

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.