Sign in to follow this  
wizt

Problem with Buffalo Linkstation Duo (LS-WXL), 100% cpu

Recommended Posts

Hi,

I have a problem running BTSync on my Buffalo NAS. I am running firmware 1.64, and have root access to the device. No other modifications has been done to the firmware. The NAS is arm based:


> uname -a
Linux hostname 3.3.4-88f6281 #2 Mon Dec 10 17:31:41 JST 2012 armv5tel unknown

I installed and ran the program like this:


> wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_arm.tar.gz
> tar zxvf btsync_arm.tar.gz
> chmod u+x btsync
> ./btsync

Now to my problem. The program runs, but I can't access the webui. When I check top it says that btsync is using close to a 100% of the cpu. I left it running for about 5min, but it is still close to a 100% and no webui.

I also tried running with the flag --no-daemon set, in hope of getting some debug messages, but nothing.

Do you guys and girls have any idea of what might be causing this, and is there a possible fix? Is there any way to get some debug info from the application?

post-24312-0-22603600-1366977945_thumb.p

Share this post


Link to post
Share on other sites

Dammit, sorry. Just noticed how to turn on the debug stuff... I will post a log after 15-20min when the program has run for a while...

Share this post


Link to post
Share on other sites

Ok, so I ran the debug and all I get is this:


[20130326 15:09:38] Loading config file version 1.0.116
[20130326 15:09:39] Got 2 relay ips
[20130326 15:09:39] Server ip 67.215.231.242:3000
[20130326 15:09:39] Server ip 67.215.229.106:3000
[20130326 15:09:50] NAT-PMP: Unable to map port with NAT-PMP.
[20130326 15:10:39] Got 2 relay ips
[20130326 15:10:39] Server ip 67.215.229.106:3000
[20130326 15:10:39] Server ip 67.215.231.242:3000
[20130326 15:11:39] Got 2 relay ips
....... Repeats this every minute

Not much to go on there....

Share this post


Link to post
Share on other sites


[20130326 15:09:50] NAT-PMP: Unable to map port with NAT-PMP.

It looks like BTSync isn't able to automatically open ports on your firewall/router - you may have to manually add exceptions to your firewall/router configuration (remember to add UDP expections)

There was a recent discussion relating to ports here.

Share this post


Link to post
Share on other sites

Alright.. find a solution to some of the problems I am having... But first, the NAT-PMP problem was not my mian concern here, as I was not getting into the web interface, and I have a 100% CPU load. But I have to thank you for point that out, as it was the thing that got me thinking about a solution to my problem :)

The solution to the 100% cpu "bug" is to change port that the WebUI is running on OR open the port (8888) on the Linkstation (PS. you don't have iptables). What I did was to change the port to 8080 and the WebUI works and the load went down to a more managable 0-1% (when nothing is happening) :)

Now I will just try to figure out how to properly open the other ports on the Linkstation. Since I don't have access to iptables i will probable have to mess with /etc/services or something similar. I will post back if/when I find a solution.

Share this post


Link to post
Share on other sites

HI Guys

first of Im in terms of sshing my linkstation etc a noob..... I took me one entire day to enable ssh on my device..... anyways, I was able to download btsync, also to run it. However the webui simply does not want to work. I changed the port from 8888 to 8080....which did not work.... i also tried some other ports which did not work as well. Nevertheless no matter what port i try my cpu is at 100% almost the entire time... any help would be a lot appriciated since btsync is a really amazing tool which would make my NAS just worth the money.... :) thanks a lot in advance

Share this post


Link to post
Share on other sites

Hi !

I try to ennable ssh on my LS-WXL but without succes ... As your have already do this whitch method have you used for that ?

Thanks for your help

S.

Share this post


Link to post
Share on other sites

Hi,

 

yesterday I made btsync running on my Buffalo Linkstation -in the end with own config file, because of path errors. It is only working with port 8080. Today I was working on my WOL via FHEM which is also working fine right now.

My problem now is: how can I automatically run btsync with my configuration during booting of my Linkstation. Currently I always have to log in via SSH and start the btsync via ./btsync --config btsync.conf.

Hopefully on of you can help me in that as my linux experiences are quite low

 

Cheers .. Max

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this