Xanza

Very Inconsistent Speeds

Recommended Posts

I've installed and configured btSync on my brand new Raspberry Pi and I have to say it's working great, however, I just tried to transfer a 115MB file into my backup storage (on my Pi; 8GB SD Card). The transfer starts at about 2.2 - 2.8 Mbps for about 10 seconds, and DROPS down to 0 Kbps. Then jumps between 30 Kbps and 0 Kbps until the transfer is complete (about an hour). As you can probably tell, this is pretty crazy, and not efficient at all.

Upon inspection of the BitTorrent Sync application, under the "Transfers" tab, I can see my file "flashing" within the window. When the file is in the window, obviously it starts to transfer, then almost immediately is removed and the transfer drops to 0 Kbps.

Anyone suffering the same symptoms?

Share this post


Link to post
Share on other sites

can i ask for a instruction how to get btsync working on Raspberry Pi ? I'm a newbie with linux - but i managed to untar the pakage and everything. When i'm doing ./btsync in the right directory only following message is displayed : "-bash: /usr/sbin/btsync: No such file or directory" ... file is there ... and i chmod to 0755 .... but nothing happens. Running on Raspbmc ... it would be wonderful if you can post some instructions ... thanks !

Share this post


Link to post
Share on other sites

can i ask for a instruction how to get btsync working on Raspberry Pi ? I'm a newbie with linux - but i managed to untar the pakage and everything. When i'm doing ./btsync in the right directory only following message is displayed : "-bash: /usr/sbin/btsync: No such file or directory" ... file is there ... and i chmod to 0755 .... but nothing happens. Running on Raspbmc ... it would be wonderful if you can post some instructions ... thanks !

Start over.

sudo wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_arm.tar.gz ; sudo tar xvf *.gz ; rm -rf *.gz ; ./btsync --dump-sample-config > sync.conf

Execute that whole command via SSH, it'll re-download the ARM version of btsync, unpack it, remove the tar.gz file, and dump the sample config to the console.

After that, you should be able to setup the config the way that you want and then:

sudo chown u+x ./btsync; ./btsync --config sync.conf

And it should work just fine; at least it did for me. You might have downloaded the incorrect version of btsync (you need the ARM version).

Share this post


Link to post
Share on other sites

Also, check out this link. I had to symlink a lib to get it to run on my Pi. I was getting the same "No such file or directory".

http://forum.bittorr...pbmc#entry28830

Thanks! I'll give it a shot and let you know -- everything seems to be working and I'm not receiving any errors, but a simply symlink won't hurt.

EDIT:

pi@raspberrypi /lib/arm-linux-gnueabihf $ sudo ln -s /lib/arm-linux-gnueabihf/ld-linux.so.3 /lib/ld-linux.so.3

ln: failed to create symbolic link `/lib/ld-linux.so.3': File exists

I guess not. :(

EDIT:

Tried running btsync as root -- same issues. Any transfer that takes longer than 10-12 seconds drops down to near completely stopped, or completely stopped.

SEMI-FIXED:

This issue was caused by the default Raspberry Pi settings. By default the partition size of the disk is only 1.8GB to which I filled up VERY quickly. After attempting to transfer a larger (700MB) file, the transfer peaks at 2.8 Mbps (pretty much my speed cap) then drops all the way down to 20 Kbps, then down to 12 Kbps, then finally down to 0 Kbps.

Before:

$ df -h

Filesystem Size Used Avail Use% Mounted on

rootfs 1.8G 1.7G 0 100% /

/dev/root 1.8G 1.7G 0 100% /

devtmpfs 93M 0 93M 0% /dev

tmpfs 19M 220K 19M 2% /run

tmpfs 5.0M 0 5.0M 0% /run/lock

tmpfs 37M 0 37M 0% /run/shm

/dev/mmcblk0p1 56M 17M 40M 30% /boot

tmpfs 37M 0 37M 0% /tmp

After:

$ df -h

Filesystem Size Used Avail Use% Mounted on

rootfs 7.2G 1.7G 5.1G 25% /

/dev/root 7.2G 1.7G 5.1G 25% /

devtmpfs 93M 0 93M 0% /dev

tmpfs 19M 224K 19M 2% /run

tmpfs 5.0M 0 5.0M 0% /run/lock

tmpfs 37M 0 37M 0% /run/shm

/dev/mmcblk0p1 56M 17M 40M 30% /boot

tmpfs 37M 0 37M 0% /tmp

Read More: http://www.ardupi.com/2013/01/raspberry-pi-raspbian-no-space-left-on.html

All in all, the transfer speeds for smaller files are fine now, but again, anything that takes more than 10-15 seconds to transfer basically drops to a speed where it almost stops.

Any suggestions?

Share this post


Link to post
Share on other sites

I think the memory on your Rpi are running low. I read somewhere that BTSync use a lot of memory.

Have you checked that?

Yes, BTSync consistently uses anywhere between 10-70% of the total CPU power of the Pi unit, however, it never really reaches 100% -- so I don't believe that's the actual issue. (I've monitored during transfer with htop).

Share this post


Link to post
Share on other sites

Yes, BTSync consistently uses anywhere between 10-70% of the total CPU power of the Pi unit, however, it never really reaches 100% -- so I don't believe that's the actual issue. (I've monitored during transfer with htop).

RAM, not CPU ... try 'free -m' while btsync is running, and post results.

Share this post


Link to post
Share on other sites

I don't think this is the case either Yotta. I use a few Pis with Sync, both the 256 and the 512 ram one, and I transfer at steady speeds (1.5MB/sec) without issue, and very consistently. I am using the raspbmc image though, so we have very different setups.

Share this post


Link to post
Share on other sites

I'm using the official Raspbian wheezy build -- once I get home tonight I'll check free memory while transferring a larger file, but I'm pretty sure I did already and they were between acceptable parameters. But to be sure I'll test it again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.