tuxpoldo

Debian And Ubuntu Server Unofficial Packages For Bittorrent Sync

Recommended Posts

Ok, I think I have identified why some users (including myself) are experiencing this as a bug.

"pid_file" : "/home/<ussername>/.btsync/btsync.pid",

When this parameter is supplied in the config file, everything works perfectly. However, when it is not supplied (when you are also spcifying UID/GID and the storage_direcctory) everything stops working - but only when run via the init script. It works just fine if you run btsync-daemon --config=/etc/btsync/<config without the pid_file parameter>. However the init script simply silently fails to start the daemon when it tries to run a config without this set.

...

Thanks for your help identifiying this, and thanks for providing the packages!

Thank you very much for the clarification! In fact I will now try to find out, what btsync is doing, if the parameter is not specified. Stay tuned - I will let you know, what I will do in order to fix (or at least support the user in avoiding) the problem.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.30 - All Debian builds are now online. Unfortunately todays there is high load on launchpad and so Ubuntu builds will be probably available in about 10 hours (launchpad shows 6-10 hours for all builds). I'm sorry, but I can't change this :-(

Changelog:


btsync (1.1.30-1~sid) sid; urgency=low

* New upstream release

-- Leo Moll <leo.moll@yeasoft.com> Wed, 10 Jul 2013 00:31:45 +0200

Is there a repo available for lucid lynx? I'm running several headless servers across 3 different states and it would be nice to use apt-get

 Ign http://ppa.launchpad.net lucid/main Packages                             
Get:3 http://ppa.launchpad.net lucid/main Packages [904B]
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
404 Not Found
Fetched 15.2kB in 1s (10.5kB/s)
W: Failed to fetch http://ppa.launchpad.net/tuxpoldo//ubuntu/dists/lucid/main
/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones u
sed instead.
admiral@USSDallas:~$

This is what lucid returns when running apt-get update and install if at all possible a repo would be nice at the very least I could set one up but don't know how

Share this post


Link to post
Share on other sites

Is there a repo available for lucid lynx? I'm running several headless servers across 3 different states and it would be nice to use apt-get

Yes. It is. If you look at https://launchpad.net/~tuxpoldo/+archive/btsync you will see that there are also builds available for lucid lynx (i386 and amd64).

 Ign http://ppa.launchpad.net lucid/main Packages
Get:3 http://ppa.launchpad.net lucid/main Packages [904B]
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
404 Not Found
Fetched 15.2kB in 1s (10.5kB/s)
W: Failed to fetch http://ppa.launchpad.net/tuxpoldo//ubuntu/dists/lucid/main
/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones u
sed instead.
admiral@USSDallas:~$

This is what lucid returns when running apt-get update and install if at all possible a repo would be nice at the very least I could set one up but don't know how

That's really strange. The repository is maintained by Launchpad - the official build system of Ubuntu and for all Ubuntu developers, so I have no direct influence on the inner workings of the repository.

What architecture are you using? The Ubuntu repository contains only binaries for i386 and amd64. Unfortunately external developers/maintainers like me are not entitled to use the arm, mips and powerpc build machines on Launchpad...

Share this post


Link to post
Share on other sites

MD5sum of files in this repo seems different from official btsync binaries. Why?

It is because the Debian build packaging system strips binaries included in .deb packages in order to make them compliant to the Debian distribution policy.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.69 - All Debian and Ubuntu builds are online.

Changelog:


btsync (1.1.69-1~sid) sid; urgency=low

* New upstream release
- Fixed: Additional error message on startup

-- Leo Moll <leo.moll@yeasoft.com> Tue, 13 Aug 2013 00:41:27 +0200

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.70 - All Debian and Ubuntu builds are online.

Changelog:


btsync (1.1.70-1~sid) sid; urgency=low

* New upstream release

-- Leo Moll <leo.moll@yeasoft.com> Thu, 15 Aug 2013 10:44:11 +0200

Share this post


Link to post
Share on other sites

And now I will give you the evidence, that there is not bug:

[...]

Hi: thanks for going through such an extensive example. It's clear that things work as they should on your end.

My brand new hi-spec laptop arrived, and I am sorry to report I still can't get the service to auto-start properly. I am quite sure I have the config setup properly in /etc/btsync/user.conf:-

//!/usr/sbin/btsync-daemon --config

// DAEMON_UID=andrew

// DAEMON_UMASK=0007

{

"device_name": "WiZHome Sync",

"listening_port" : 0,

"storage_path" : "/home/andrew/.btsync",

"check_for_updates" : false,

"use_upnp" : false,

"download_limit" : 0,

"upload_limit" : 0,

"pid_file" : "/home/andrew/.btsync/btsync.pid",

"webui" :

{

"listen" : "0.0.0.0:8888"

},

"shared_folders" :

[

{

"secret" : "{removed for this post}", // * required field

"dir" : "/home/WiZShare/", // * required field

"use_relay_server" : true,

"use_tracker" : true,

"use_dht" : false,

"search_lan" : true,

"use_sync_trash" : true

,"known_hosts" :

[

"192.168.1.2:44444"

]

}

]

}

When I boot up and logon, just as with my old laptop, BTSync does not seem to fire up and is certainly not syncing folders; nor does not show as being "online". There is no btsync-daemon running per:

ps axu | grep btsync-daemon

If I start the service with 'sudo service btsync start', it fires up straight away, with no problems. It then starts to sync and all is well. I have to start it manually.

This is a new install on a new machine. I am still wondering if it's got something to do with permissions of the pid file. Either way, it's pretty clear to me now that it's not hardware related in my case.

It's perplexing.

I am sure I can set it up to run as I did on my old laptop (not as a service on autostart, but at least to run as an instance when one of the two users on my machine logs in). I'd really like to get this to run when I start my machine up even without anyone logging on.

Regards and thanks for your postings. Sorry for being a "repeat offender" - tis not deliberate.

wizlon

Share this post


Link to post
Share on other sites

after running


sudo add-apt-repository ppa:tuxpoldo/btsync
sudo apt-get update

ubuntu replies


Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 99, in run
self.add_ppa_signing_key(self.ppa_path)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 132, in add_ppa_signing_key
tmp_keyring_dir = tempfile.mkdtemp()
File "/usr/lib/python2.7/tempfile.py", line 322, in mkdtemp
name = names.next()
File "/usr/lib/python2.7/tempfile.py", line 141, in next
letters = [choose(c) for dummy in "123456"]
File "/usr/lib/python2.7/random.py", line 274, in choice
return seq[int(self.random() * len(seq))] # raises IndexError if seq is empty
ValueError: cannot convert float NaN to integer

Share this post


Link to post
Share on other sites

Btsync doesn't come up after running "apt-get upgrade btsync" to upgrade to version 1.1.70 on my arm wheezy system. Is there a command i can run to downgrade to an older but functional version of btsync?

Share this post


Link to post
Share on other sites

Thanks for maintaing this.

Question: how do I do set a read-only key (so that the Debian side backs up to the non-Debian side)? I didn't see any such configuration in the sample.

Share this post


Link to post
Share on other sites

Bug fix for /etc/init.d/btsync :

I'm trying to figure out why btsync isn't starting for me. But the start_btsync() function is not detecting the error properly. A "sleep 1" is needed before "unit test_running". The problem is btsync starts for a bit then stops for some reason. And there's no error.

Share this post


Link to post
Share on other sites

so if you want to set up btsync to run as a specific user do ths

in /etc/default/btsync set : AUTOSTART="user"

than create a file in /etc/btsync with the format

/user.<username>.<group>.conf

username and group can be the same

before you start always do a chown -R /home/<username>/<sync folder>

to the devs: this config is more then suboptimal and should be simplified

Share this post


Link to post
Share on other sites

Tux the system architectur is an I386 Tyan mobo with 2 Xeon CPUs each at 1.3Ghz its an intel chipset nothing out of the ordinary but no luck on getting apt-get to install packages I have also tried on an Intel x64 system and booth AMD x86 & x64 I don't think it will be a problem after upgrading to precise but I'm waiting on a few things to update before I switch if you have any pointers that would be helpfull send them my way ^_^ also just to varify my sources.list file could you post the repo lines I need? It's alwways the little things that kill my servers thanks again for the help android and Microsoft variants work awesome keep up the good work how long till the iOS release is ready?

Share this post


Link to post
Share on other sites

I installed the latest server packages on ubuntu last night. So far I am impressed.

I didn't read the whole thread, so this might have already been covered, but it doesn't look like you can define your shared folders in your user's config file and also have the web gui running at the same time? I could only get the webgui to work when I commented the shared folders definition out even though the shared folder definition was fine (i.e. the shared folders were working/syncing fine).

Share this post


Link to post
Share on other sites

Dear tuxpoldo,

First of all, thank you for your work.

But I had to spend a lot of time to found the solution to start daemon under my username. Fortunatly, the solution is in this topic.

May I suggest you to extend your initial post in this topic, with the fact that we have to change owner of the config file if we want to start the deamon under an other user than root.

Thank you.

Share this post


Link to post
Share on other sites

Is there a repo available for lucid lynx? I'm running several headless servers across 3 different states and it would be nice to use apt-get

 Ign http://ppa.launchpad.net lucid/main Packages
Get:3 http://ppa.launchpad.net lucid/main Packages [904B]
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
404 Not Found
Fetched 15.2kB in 1s (10.5kB/s)
W: Failed to fetch http://ppa.launchpad.net/tuxpoldo//ubuntu/dists/lucid/main
/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones u
sed instead.
admiral@USSDallas:~$

This is what lucid returns when running apt-get update and install if at all possible a repo would be nice at the very least I could set one up but don't know how

http://ppa.launchpad.net/tuxpoldo/btsync/ubuntu/dists/lucid/

it helps to check the address of the file before atempting to use apt-get opening the browser to this address there is a release there for lucid if you look carfully at the previusly posted comment you will see several errors in the URL i have it fixed now and works great using the new link http://ppa.launchpad.net/tuxpoldo/btsync/ubuntu/dists/lucid/

Share this post


Link to post
Share on other sites

Hi,

I installed BTSync described in this thread. After installation, the config-wizard opened and I did same settings, which resulted in /etc/btsync/debconf-default.conf.

I did access the WebGui at port 8888 and added some directories. But where these directories-settings are saved?

In /etc/btsync/debconf-default.conf is no entry about them. There is also not another config file in that folder.

Share this post


Link to post
Share on other sites

First of all, thank you for your work.

Thank you!

But I had to spend a lot of time to found the solution to start daemon under my username. Fortunatly, the solution is in this topic.

May I suggest you to extend your initial post in this topic, with the fact that we have to change owner of the config file if we want to start the deamon under an other user than root.

Strange: the whole procedure is described in the initial topic under USAGE NOTES. Especially your use case (start the daemon under your username) is covered by the provided example ("This example will launch the instance running under the credentials of the user "jdoe" using 0002 as umask")... The solution suggested by user ba1020 a few replies above, is the older way to do it, but it still works...

Share this post


Link to post
Share on other sites

I installed the latest server packages on ubuntu last night. So far I am impressed.

Thanks!

I didn't read the whole thread, so this might have already been covered, but it doesn't look like you can define your shared folders in your user's config file and also have the web gui running at the same time? I could only get the webgui to work when I commented the shared folders definition out even though the shared folder definition was fine (i.e. the shared folders were working/syncing fine).

As far as I know, this two options are mutually exclusive (and this would make sense). Predefining shares in the configuration file, is a configuration scheme used to define a static and immutable (more secure) configuration for obtaining an exact well defined behaviour in a server environment. In any case this question affects the core functionality of btsync and should be be better discussed in a dedicated thread since I do not think that the btsync developers read this thread.

Share this post


Link to post
Share on other sites

http://ppa.launchpad...tu/dists/lucid/

it helps to check the address of the file before atempting to use apt-get opening the browser to this address there is a release there for lucid if you look carfully at the previusly posted comment you will see several errors in the URL i have it fixed now and works great using the new link http://ppa.launchpad...tu/dists/lucid/

That's really interesting! According to my documentation, the additional repository is added to the sources list by the Ubuntu tool add-apt-repository so I'm really wondering how it could happening that the URLs were wrong...

Did you add the repository using the procedure documented in the initial post?


sudo add-apt-repository ppa:tuxpoldo/btsync

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.