raven.warsong

slow transfer speed on lan

Recommended Posts

I all love the sync program so far. However the kph is very slow it tops out at 1.5 to 1.7 but on average gose about 500kph one system is using wireless g at 54mb other is using 100mb hard wire connection. I have a 300n repeater on my 3rd system. If all 3 systems go it goes down to about 150kph. I turned on upnp in my router. Dont think that matters for lan transfers. Turned off encryption For plan transfers. The speed seems very slow. Or is that about right. When I transfer via the lan manual I can push a gig file in around 7 mins Or a little less.

Share this post


Link to post
Share on other sites

For the peer connections are you showing left/right arrows, or cloud?

What is kph? Please try to sanitize the units in your post. It doesn't make sense.

You mention time to transfer a 1 GB file at the end, but all other units are not in time format. So what transfer rate do you see when transferring that file without btsync?

Also what are your system specs? Mainly CPU model and RAM size.

Share this post


Link to post
Share on other sites

AMD Phenom II X6 1090T Processor, Black Edition Ssd 128 drive is sata 3 and contoler on board.16 gigs of DDR 3 Other is x6 phenom ii. 6 core none black. 8 gigs of ram. Labtop is core 2 duo 2 gigs of ram. Wife just called did speed test its crawling now getting like 1mb down. On internet. I don't think the traffing is staying in the lan

Share this post


Link to post
Share on other sites

Indexing compete on all peers? You didn't answer my other questions. Keep in mind the encryption is expensive time-wise for older CPUs. Also UDP is not optimized with some kernels and drivers... try turning encryption off and forcing TCP.

Share this post


Link to post
Share on other sites

Are the computers on the same subnet? Try adding the peer addresses directly in the advanced settings of the shares.

Those computers are plenty fast enough of course.

Share this post


Link to post
Share on other sites

Indexing compete on all peers? You didn't answer my other questions. Keep in mind the encryption is expensive time-wise for older CPUs. Also UDP is not optimized with some kernels and drivers... try turning encryption off and forcing TCP.

encryption is off I tryed with UDP and TCP. Should I disable upnp in my router? I'm only using one dhcp so all on same subnet. I don't know about indexing it did it for like 10 mins but I read other places it can take a long time. So find out IP address from dhcp and put them all in? Under advanced? Thanks

Share this post


Link to post
Share on other sites

I changed it to tcp and it shows they are connection on the lan and not the cloud. I turned upnp off. I don't know what else to to do I don't know what you mean by "Try adding the peer addresses directly in the advanced settings of the shares" I see not place to do that, any way to generate a log file. If not I can do screen shots. I had to shut it down. its been going all day and night and only transferred about 20 gigs if that.

Share this post


Link to post
Share on other sites

same here raven. gigabit network. transfer between laptop core i5 and a freenas 8.3 core2duo tops out at 4 mb/s when i transfer de files with samba i ll get 80-100 mb/s.

there on the same subnet

Share this post


Link to post
Share on other sites

I thank the program just needs a little more time. After a month or so they may have the bugs worked out. i have tried all the settings I don't thank im doing any thing wrong,. I mean there are only a few choices I don't see how I could mess any thing up. Im sure it will be a great program guys just give it time to get patched. It shows arrows not clouds so I know im staying within my lan.

Share this post


Link to post
Share on other sites

Still having this problem.

BT Sync version 1.2.82

The two systems are identical Xeon Quadcore systems (PowerEdge T110)

Gigabit networking (gig cisco switch), Cat 6 wiring.

Shows arrows (not cloud)

I'm getting 400KB/s - 1.4MB/s.  Occasionally It'll hit 2MB/s

These systems have almost no load on them (0-5%)

I get close to 100MB/s when copying with ROBOCOPY between these systems.

 

ugh.

Share this post


Link to post
Share on other sites

Have you tried enabling TCP, and disabling encryption, for the LAN connection? Made a huge difference for me. Theoretically UDP should of course be faster than TCP on a LAN, but I've come to find out that UDP segment processing is usually not offloaded/accelerated while TCP is...

One other thing I've seen cause a slow down is poor hard drive performance (old drives, show SATA, fragmentation, etc.). I don't get anywhere near full speed on gigabit LAN unless I'm using SSD. Not saying it's for sure the problem, because there are lots of variables involved, but just one more thing to check.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.