tuxpoldo

Debian And Ubuntu Legacy Desktop Unofficial Packages For Bittorrent Sync

Recommended Posts

Version 1.0.134-5 has changes that apply only to the server version. Since both packages are the result of the build process, also the desktop package has a new version, but basically nothing changes except for the version number. Here the changelog:

- Fixed: btsync did not start if web gui was configured to

operate with no credentials

- Fixed: btsync did not stop under certain circumstances

if there is more than one btsync.*.pid file in /var/run

Share this post


Link to post
Share on other sites

Thanks so much for these packages! Working great for me on Linux Mint Debian Edition. I had to modify the installation steps a bit though; I needed to add sudo to the second line:

sudo gpg --armor --export 6BF18B15 | sudo apt-key add -

And the output of

lsb_release -cs

on LMDE is just "debian", so I had to manually change that to "wheezy".

The only other thing that would be helpful is to note that, if btsync crashes and needs to be restarted, the script that should be run is

/usr/lib/btsync-user/btsync-starter

Hopefully that's of help to other LMDE users!

Share this post


Link to post
Share on other sites

Thanks so much for these packages! Working great for me on Linux Mint Debian Edition. I had to modify the installation steps a bit though; I needed to add sudo to the second line:

sudo gpg --armor --export 6BF18B15 | sudo apt-key add -

Thank you for the correction! I changed the original posting.

Share this post


Link to post
Share on other sites

Right, thanks for that. The repository tuxpoldo set up will have to add support for 'jessie' as well, though.

As soon as pbuilder is able to setup a jessie build environment (nowadays it does not work, since there is no updates-repository for jessie, but pbuilder create requires one...) I will also create jessie-builds.

In the meantime it seems that sid-builds are OK

Share this post


Link to post
Share on other sites

Down for everyone?


Err http://debian.yeasoft.net jessie/main Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/contrib Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/non-free Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/main amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/contrib amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/non-free amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Ign http://debian.yeasoft.net jessie/contrib Translation-en_GB
Ign http://debian.yeasoft.net jessie/contrib Translation-en
Ign http://debian.yeasoft.net jessie/main Translation-en_GB
Ign http://debian.yeasoft.net jessie/main Translation-en
Ign http://debian.yeasoft.net jessie/non-free Translation-en_GB
Ign http://debian.yeasoft.net jessie/non-free Translation-en
Fetched 394 kB in 14s (27.7 kB/s)
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/main/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/contrib/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/non-free/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/main/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/contrib/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/non-free/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]

Share this post


Link to post
Share on other sites

Down for everyone?


Err http://debian.yeasoft.net jessie/main Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/contrib Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/non-free Sources
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/main amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/contrib amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Err http://debian.yeasoft.net jessie/non-free amd64 Packages
404 Not Found [IP: 77.232.232.105 80]
Ign http://debian.yeasoft.net jessie/contrib Translation-en_GB
Ign http://debian.yeasoft.net jessie/contrib Translation-en
Ign http://debian.yeasoft.net jessie/main Translation-en_GB
Ign http://debian.yeasoft.net jessie/main Translation-en
Ign http://debian.yeasoft.net jessie/non-free Translation-en_GB
Ign http://debian.yeasoft.net jessie/non-free Translation-en
Fetched 394 kB in 14s (27.7 kB/s)
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/main/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/contrib/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/non-free/source/Sources 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/main/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/contrib/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]
W: Failed to fetch http://debian.yeasoft.net/btsync/dists/jessie/non-free/binary-amd64/Packages 404 Not Found [IP: 77.232.232.105 80]

There is no jessie repo yet, use sid iso jessie

Share this post


Link to post
Share on other sites

Released Version 1.0.134.1-1 only for i386 and amd64. Debian builds are available, Ubuntu builds are on the way. It was reported that the iNotify-Interface does not work with the binaries supplied in the previous versions.

btsync (1.0.134.1-1~sid) sid; urgency=low

- Fixed: Replaced binary version for i386 and amd64 with

versions that support the current libc

-- Leo Moll <leo.moll@yeasoft.com> Sun, 02 June 2013 00:51:12 +0200

Share this post


Link to post
Share on other sites

Version 1.1.12-1 is ready. All Debian builds are now online. Ubuntu builds are on the way and should be online in about 2 hours.

Share this post


Link to post
Share on other sites

After updating on ubuntu 13.04 the sync stopped working and sync.log shows a ton of "EncryptionHandler: failed to find decryption key for incoming connection" messages. I tried removing then re-adding the synced folders to no avail. Any ideas?

Share this post


Link to post
Share on other sites

After updating on ubuntu 13.04 the sync stopped working and sync.log shows a ton of "EncryptionHandler: failed to find decryption key for incoming connection" messages. I tried removing then re-adding the synced folders to no avail. Any ideas?

Same problem, nothing is syncing.

Share this post


Link to post
Share on other sites

I concur, not working on Ubuntu. Thanks for going to the effort of making these packages.

Phil

P.s.


$ lsb_release -a
Description: Ubuntu 13.04
Codename: raring
$ uname -a
Linux 3.8.0-23-generic #34-Ubuntu SMP Wed May 29 20:22:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

sync.log:


[20130513 19:28:33.444] Incoming connection from 198.1xx.117.xxx:44444
[20130513 19:28:33.641] HTTP: IP 127.0.0.1: GET /gui/?token=H7uMgTGErsZ5mXljWVTteA-tzR0UmsbF7welGstqmokkH9Shz6fA3tsMulEXXAAA&action=getsyncfolders&t=1371148113640
[20130513 19:28:33.891] EncryptionHandler: failed to find decryption key for incoming connection
[20130513 19:28:34.136] Incoming connection from 2.xx.81.xxx:58509
[20130513 19:28:34.341] EncryptionHandler: failed to find decryption key for incoming connection
[20130513 19:28:34.649] HTTP: IP 127.0.0.1: GET /gui/?token=H7uMgTGErsZXmXljWVTteA-tzR0UmsbF7welGstqXokkH9Shz6fA3tsMulEAAAAA&action=getsyncfolders&t=1371148114640

and so on...

Share this post


Link to post
Share on other sites

After updating on ubuntu 13.04 the sync stopped working and sync.log shows a ton of "EncryptionHandler: failed to find decryption key for incoming connection" messages. I tried removing then re-adding the synced folders to no avail. Any ideas?

Same problem, nothing is syncing.

These problems seems to be due to btsync itself and not to the packaging. Please post this errors as separate threads or directly as bug reports to syncapp@bittorrent.com because I have no possibility to diagnose and fix them.

Share this post


Link to post
Share on other sites

Ah, found the answer at http://forum.bittorrent.com/topic/19228-latest-sync-build-1112/. Where it says: "Please note that 1.1.x builds are not compatible with 1.0.x builds. You will need to upgrade all devices. We are changing protocol to support mobile devices and doing some optimization to it." That was exactly the issue with me. All my other devices except this one ubuntu machine are still on previous build. So, I guess it's best to wait 'till windows clients get updates and update the rest of the linux machines only after. Many thanks for your work tuxpoldo, and sorry for spamming this thread.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.15 - All Debian builds are now online. Ubuntu builds are on the way and should be online in about 1-2 hours.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.22 - All Debian builds are now online. Ubuntu builds are on the way and should be online in about 1-2 hours.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.26 - All Debian builds are now online. Ubuntu builds are on the way and should be online in about 15 minutes.

Share this post


Link to post
Share on other sites

Updated all packages to 1.1.27 - All Debian builds are now online. Ubuntu builds are on the way and should be online in a few minutes.

Share this post


Link to post
Share on other sites

Some user requested the possibility to customise the configuration of the BitTorrent Sync instance. There are good news: the new Version 1.1.27-2 allows to create an optional user specific configuration file for each user. Please see the USAGE NOTES in the main posting for details. New Builds for Debian and Ubuntu are available:

 

btsync (1.1.27-2~sid) sid; urgency=low- Fixed: AUTOSTART in /etc/default/btsync had no effect- Added support for custom configuration files in btsync-user-- Leo Moll <leo.moll@yeasoft.com> Sun, 07 Jul 2013 15:29:51 +0200

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.