tprwrsg

BTSync prevents NAS to enter sleep mode?

Recommended Posts

I've just realized that on my NAS (WD My Book Live 3 TB version), after BTSync is installed and is running, my NAS unit almost (or never) enters sleep mode.

Could it be that the btsync daemon running in the background prevents the system from entering sleep mode ? This could lead to shortened hardware life, and isn't a good practice in general.

What are possible workaround for this ? How about giving an option for btsync to throttle/pause when there is no activity(transfer in/out) after x minutes, so that the system can sleep for a while ?

Share this post


Link to post
Share on other sites

What version of BitTorrent Sync are you running? If it's not the latest build (1.1.12), then please update to this build, which has some fixes which may well resolve your sleep issue!

Share this post


Link to post
Share on other sites

I downloaded it just this week only (Monday 10 Jun 2013) so I'd imagine it's pretty up-to-date, but I'll check.

The new update GreatMarko linked to was just added yesterday. So, you likely downloaded version 1.0.134 and not 1.1.12.

Share this post


Link to post
Share on other sites

Just saw in the logs that the device is leaving standby ~every 10min. I remember that there was a setting to force BTSync to reindex every 10min. If I set this option to 12h, would this be problematic for the BTSync function?

Share this post


Link to post
Share on other sites

Are there any settings I could fiddle around with that could help to get the device to sleep?

Right now I simply can't use btsync on the MyBookLive as it keeps the disk spinning all the time.

btw, I started a thread here as well and it seems that there are more people experiencing problems: http://mybookworld.wikidot.com/forum/t-673470/bittorrent-sync-sleep-problems#post-1821064

Share this post


Link to post
Share on other sites

Seems like I have the same problem with my Synology DS412+. In addition to the HD in the Synology it also does not allow an external Raid I connected to the Synology to spin down. Even if that is just used for backups of the Synology once a day! Not nice :(

Share this post


Link to post
Share on other sites

Hi, i'm new here. Installed version 1.1.70-1 yesterday on my Synology DS413.

Syncing works fine, but it's preventing this NAS from sleep mode as well.

:-(

 

How do you know its not going into sleep? Serious question, is there a log or something?

Share this post


Link to post
Share on other sites

Where do i find that option?

it's not under preferences (next to Add folder) under the tab settings or tab Authorization..

and not in the preferences > general tab or Advanced tab for each folder seperately.

 

 

edit: 

another guy asked the same question like me :-)

 

 


how can I make the NAS folder rescan interval shorter (I haven't found any option in the Web GUI nor any config file on the NAS)?

 

Thanks

 

source: http://forum.bittorrent.com/topic/8578-supported-nas/page-8#entry69242

Share this post


Link to post
Share on other sites

I changed the folder rescan interval on my MyBookLive but it did not help. However what I found in the logs during nights was that it woke up every 30min. 

Right now I increased the folder rescan interval from 0min to 6h on my other PC that is running 24/7. Maybe this PC contacting my MyBookLive woke it up...

Share this post


Link to post
Share on other sites

I know this is an old post but it's top of list in search.

 

I have latest version of BTSync (1.2.91) and this is preventing my MBL from sleeping.

MBL is 1TB version and a few years old also with latest patches on.

 

I decided to use a cron job to switch off BTSync at night in the meantime as it's used in the day. I have updated the rescan to be 12hrs but that made no odds to sleep issue.

 

I used this post to point me in right place as standard cron jobs were not being processed so had to edit the list under the /etc folder

http://community.wd.com/t5/My-Book-Live/Cron/m-p/351295/highlight/true#M8985

 

 

Share this post


Link to post
Share on other sites

derekpickles,

 

Try using freshly released 1.3. It should have fixed the HDD sleep issue and with 12 hours rescan interval it should wake up HDD only once per 12 hours.

Share this post


Link to post
Share on other sites

Dahaniel,

 

Even with fixed issue of waking up HDDs, default value of folder_rescan_interval is 10 minutes. I suggest adjusting it via config file to some bigger value.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.