Sign in to follow this  
GFIScripter

Windows 7 BTSync & Junctions

Recommended Posts

I have been very impressed with the BTSync software. I have been working with it over a month now; But lately I have had a couple of glitches on my Windows 7 Computers.

I am using this as a backup platform for our remote employees to a Server here in the office. There was only one issue and that was I really didn't want to give 10 secrets per computer (for each folder). I found someone on one of these forums where there talked about a smarter way of backing up. Essentially he made a Folder and then a bunch of junctions under it. It WORKED! :)

I have been using it under Windows XP and Windows 7, I had a glitch the other day and lost off of my secrets (oops) and at that time I figured why not upgrade to the latest version (1.1.12) this seemed to work very well for all of the XP computers.

But lately I have been trying to install the 1.1.12 and 1.1.15 on the Windows 7 computers and when the BTSync software checks my folder it says its 45k ... not Meg not Gig (not always but it is always far less that the real byte count.

One time I fixed this by finding a bad junction link I deleted it and it started updating to the correct byte / files could and worked.

But as I continue to the next few computers (W7) I have not had such success and to get it working I had to go back and use a single secret for a single folder does anyone know why this is? And Any solutions? :(

I have found this to happen on Windows 7 (32 Bit) as well As Windows 7 (64 Bit)

And yes I am really anxious when I can deploy this using somesort of command line switches.

To give credit where create is due I was talking about the Post at:

http://forum.bittorr...-the-smart-way/

It really simplified what I was trying to do.. Thanks yottabit

Share this post


Link to post
Share on other sites

Just to post an update to my issue.

I have been playing with this a little more and found out a couple of things...

If I install the newest version of the Software (1.1.15) on any Windows XP computers and install stable (1.0.134.0) on the XP computers the sync works. But upon further study I have decided to go and change them all to the same client (1.0.134.0) Just because some clients dont work as they did when I had everything on the same client.

So long story short, I am moving all my clients back to the stable version, since I am still unclear if this is really getting all my data.

Additional Note:

I have found uninstalling the software from Add/Remove Programs or Programs and Features and then Removing the software without removing the settings seems to leave the secret in tact so you will not have setup your secret and share again.

Share this post


Link to post
Share on other sites

There is no "stable" version as such at this time - all builds are "alpha" builds, the latest of which is currently 1.1.15.

1.1.x builds are NOT compatible with 1.0.x builds - therefore, if you have a mix of 1.1.x builds and 1.0.x builds, the devices running 1.0.x will all sync with each other, and the devices running 1.1.x will sync with each other, but 1.1.x devices won't sync with 1.0.x devices, and vice versa.

So if all your Windows 7 machines are running 1.1.x, but all your Windows XP machines are running 1.0.x, your Win7 devices won't be able to sync with your Win XP devices.

Therefore, I'd encourage you not to carry on running 1.0.134, and instead update ALL your devices to 1.1.15.

1.0.134 is a now obsolete alpha build, and therefore for any issues encountered with this build, the advice from the BitTorrent Sync team & forum community will always be to "upgrade to the latest build and see if this resolves your issue"

So please do update everything to 1.1.15, and feel free to report back with how you've got on! :)

Share this post


Link to post
Share on other sites

I was thinking that was the case but unfortuntely I did run everything on 1.1.15 and when I ran the client on the win7 computers it would not download all the data from all the junctions. Whereas the 1.0.134 it did or I should say it does.

I am a firm believer of keeping up with the latest version(s) but I am in a real pickle and just need someth to work. And as long as this one works I will stick with that and upgrade, once a command line version comes out.

(and then I can script it and deploy it out that way...)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this