gia-btsync

"can't open the destination folder"

Recommended Posts

I installed btsync 1.1.22 on windows xp. I have a boxcrypt partition containing the data (z:\).

With btsync 1.1.15 I had no problem adding z:\ to btsync.

With btsync 1.1.22 I keep getting the error "can't open the destination folder".

I tried to set it up completely new (renamed the bittorrent folder under 'application data'), but that did not solve it.

Switched on debugging:

[2013-07-01 17:08:14] test sha1: AE5BD8EFEA5322C4D9986D06680A781392F9A642

[2013-07-01 17:08:14] test sha2: 630DCD2966C4336691125448BBB25B4FF412A49C732DB2C8ABC1B8581BD710DD

[2013-07-01 17:08:14] test aes: 0A940BB5416EF045F1C39458C653EA5A07FEEF74E1D5036E900EEE118E949293

[2013-07-01 17:08:14] Loading config file version 1.1.22

[2013-07-01 17:08:22] Got 2 relay ips

[2013-07-01 17:08:22] ip 67.215.231.242:3000

[2013-07-01 17:08:22] ip 67.215.229.106:3000

[2013-07-01 17:08:26] Incoming connection from 192.168.1.103:1098

[2013-07-01 17:08:26] Incoming connection from 192.168.1.101:56134

[2013-07-01 17:08:32] NAT-PMP: Unable to map port with NAT-PMP.

[2013-07-01 17:09:22] Got 2 relay ips

[2013-07-01 17:09:22] ip 67.215.229.106:3000

[2013-07-01 17:09:22] ip 67.215.231.242:3000

[2013-07-01 17:10:22] Got 2 relay ips

[2013-07-01 17:10:22] ip 67.215.229.106:3000

[2013-07-01 17:10:22] ip 67.215.231.242:3000

[2013-07-01 17:11:22] Got 2 relay ips

[2013-07-01 17:11:22] ip 67.215.229.106:3000

[2013-07-01 17:11:22] ip 67.215.231.242:3000

[2013-07-01 17:12:22] Got 2 relay ips

[2013-07-01 17:12:22] ip 67.215.229.106:3000

[2013-07-01 17:12:22] ip 67.215.231.242:3000

[2013-07-01 17:13:22] Got 2 relay ips

[2013-07-01 17:13:22] ip 67.215.229.106:3000

[2013-07-01 17:13:22] ip 67.215.231.242:3000

[2013-07-01 17:14:22] Got 2 relay ips

[2013-07-01 17:14:22] ip 67.215.229.106:3000

[2013-07-01 17:14:22] ip 67.215.231.242:3000

[2013-07-01 17:15:22] Got 2 relay ips

[2013-07-01 17:15:22] ip 67.215.229.106:3000

[2013-07-01 17:15:22] ip 67.215.231.242:3000

[2013-07-01 17:16:22] Got 2 relay ips

[2013-07-01 17:16:22] ip 67.215.229.106:3000

[2013-07-01 17:16:22] ip 67.215.231.242:3000

[2013-07-01 17:17:22] Got 2 relay ips

[2013-07-01 17:17:22] ip 67.215.229.106:3000

[2013-07-01 17:17:22] ip 67.215.231.242:3000

post-26990-0-85873200-1372701217_thumb.j

Share this post


Link to post
Share on other sites

It's likely that either, the existing .SyncID file within the folder is corrupt (in which case, delete it, and then try re-adding the folder to Sync), the folder is unreachable (if the drive/partition is disconnected/corrupt), or you've only entered a secret and not also specified a folder when trying to add the folder to Sync

There's also some hints in the Unofficial FAQ

Share this post


Link to post
Share on other sites

The mount can be reached and is not corrupt, because I am working on it/have been working on it all day.

Could it be something with the config file? The debug says "Loading config file version 1.1.22". I tried to locate it in the bittorrent folder under 'application data', but could not find.

It seems to be something with the root. The boxcrypt mount root z:\ cannot be added to btsync. However, I am able to add individual folders. So, I can add z:\folder-1, z:\folder-2, z:\folder-n.

Share this post


Link to post
Share on other sites

gia-btsync, I am not familiar with boxcrypt - Is it mapping a virtual drive to Z: or is this a partition on a local disk? I ask because I am syncing to network shares.

I am also having this issue since upgrading to 1.1.22. The Windows 7 sync client (Folders tab) shows this error on 4 folders that are located on network shares. 2 other folders located on a local drive are OK. See image below:

syncerror.png

This setup has existed unchanged through versions 1.0.116, 1.0.134, 1.1.15 and only had an error starting with 1.1.22.

Logs on this machine reports "SyncFilesController: mutex file check failed", over 1000 times in a 45min log.This is a log entry I have not seen before in prior logs, so I suspect it might be relevant.

Any ideas or input would be welcome.

Share this post


Link to post
Share on other sites

Any ideas or input would be welcome.

Have you tried "mapping" the network path to a drive letter in Windows?

1) From any Windows folder select Tools → Map network drive

2) Select a free drive letter, for example Z:

3) Enter your network path in the "Folder" field, i.e. "\\SHOWME"

4) Select "Reconnect at logon"

5) Click "Finish"

Does this work?

Share this post


Link to post
Share on other sites

andrewb - Boxcryptor, based on encfs, is used to encrypt local data and is used, among services, with google drive. It is creating a virtual drive.

I have no errors at all in my log. It just does not add the drive.

GreatMarko. I also will try your suggestion tomorrow, unless andrewb reports today that does not work either.

Share this post


Link to post
Share on other sites

Have you tried "mapping" the network path to a drive letter in Windows?

The existing 4 folders with the problem are big (20-100G each), so I was reluctant to try that on live data. But, I have now set up a test sync setup for an additional folder. This share (\\SHOWME\download) was already mapped to T: I have now tried to connect with and without mapping:

  • "\\SHOWME\download" fails with "Can't open the destination folder".
  • "T:" works OK.

Does this work?

Yes, thanks for the idea.

Share this post


Link to post
Share on other sites

Have you tried "mapping" the network path to a drive letter in Windows?

1) From any Windows folder select Tools → Map network drive

2) Select a free drive letter, for example Z:

3) Enter your network path in the "Folder" field, i.e. "\\SHOWME"

4) Select "Reconnect at logon"

5) Click "Finish"

Does this work?

Unfortunately, that does not work with a boxcryptor mount.

Share this post


Link to post
Share on other sites

i have same issue

steps to reproduce on windows 7 x64

  1. install truecrypt
  2. create and mount volume x:
  3. create folder x:\data and copy something into it
  4. create folder x:\btsync and copy btsync.exe into it
  5. create empty file x:\btsync\settings.dat
  6. run x:\btsync\btsync.exe
  7. try to add folder x:\data

this problem is not exists if btsync portable located outside of truecrypt volume

p.s any addition information no appears after enabling debug logging

p.p.s i used latest version 1.1.27 but problems began after 1.0.315

please contact with me for any additional information

Share this post


Link to post
Share on other sites

today i found a strange behavour which confirms the problem with portable version, i think it is not due with truecrypt

if you mount true crypt volume in normal mode (not as removable device) so all will works. only one difference: btsync using full path to folder not relative like this "..\..\..\sync folder"

also it does not correct recognize folders with dot in name, for example if folder "..\..\btsync.folder\something" the paste "..\..\.folder\something"

i repeat, these problems started with version 1.0.135

Share this post


Link to post
Share on other sites

I am using a NAS, and have setup BTSync to hit several folders via UNC paths. This has been working fine for many weeks, but after the latest build, if I create a new folder under the share and then try to add the folder to BTSync, I immediately get the same error. (Cannot open Destination).

Also, if I view the Folders tab of the application, looking at all of my existing folders which were working, under 'Size', they now all show the same error message

As for the new folders, I am creating, not adding someone else's secret, so it's not an issue with the sync folder missing on their end.

These are clean, empty folders that are under the same share as the existing BTSync folders that I am currently using/syncing.

Any ideas? On the NAS I have full control (R/W) on the share, and I can go to the share and create / rename, place files, etc. so it's not an apparent permissions issue. I am also logged into the PC as the local admin account.

This appears to be something introduced in the latest build, for sure.

Share this post


Link to post
Share on other sites

Well I have found a "work around" for this problem.... For wherever reason (I suspect a bug) you cannot add the root directory of a volume. I.E. Z:\. It simply errors with "Can't open destination folder."

Try adding C:\ and it will give you the same error.

As a work around I created a junction point from a subdirectory to the root. You can use the Sysinternals junction.exe tool to do the same.

junction z:\JunctionPoint z:\

This simply makes a fake folder JunctionPoint on the Z drive. Then you simply add the junction point to BitTorrent Sync. Not ideal but I believe this proves that there is a slight bug...

Good luck!

Just realised that this is a bad idea unless you add the folder to .SyncIgnore - If not you will find that it will get stuck in a recurring loop ;-P

Edited by JameZUK

Share this post


Link to post
Share on other sites

today i found a strange behavour which confirms the problem with portable version, i think it is not due with truecrypt

if you mount true crypt volume in normal mode (not as removable device) so all will works. only one difference: btsync using full path to folder not relative like this "..\..\..\sync folder"

also it does not correct recognize folders with dot in name, for example if folder "..\..\btsync.folder\something" the paste "..\..\.folder\something"

i repeat, these problems started with version 1.0.135

Could you please try the latest version 1.1.27 http://labs.bittorrent.com/experiments/sync.html?

Please note that 1.1.x builds are not compatible with 1.0.x builds.

You will need to upgrade all devices.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.