Dantounet

SyncDb: failed to execute query to save file info

Recommended Posts

Hi,

I have a lot of "SyncDb: failed to execute query to save file info" in my logs on my arm machines since I upgraded to version 1.1.42.

Is it something I should ignore?

Cheers

Share this post


Link to post
Share on other sites

Hello,

Same problem in here - and it seems to prevent Sync to work normaly - I have about 340G to sync (from a "master" host to 2 "slaves", and it did only 6.8 on one, 6.2 on the second…

These 340G represent about 149541 files (yes, that much… And this is only a part of the directory I want to keep sync-ed between 20 hosts once it's in production).

I don't know if both problems are related.

Cheers,

C.

Share this post


Link to post
Share on other sites

I have a lot of "SyncDb: failed to execute query to save file info" in my logs on my arm machines since I upgraded to version 1.1.42.

What version of Sync were you using prior to 1.1.42? If it was a much earlier version, it may be that the database hasn't upgraded properly when you updated to 1.1.42, or that the database has somehow become corrupt.

You may be able to resolve it by simply removing the folder(s) in question from Sync, and then re-adding it again. This will cause a re-index of the folder, and therefore should rebuild the associated database.

Share this post


Link to post
Share on other sites

Hi,

I am working on the ARM version with a config file. I stopped btsync, removed the .SyncID and restarted it but I still have the same error.

Should I remove the folder from btsync and start btsync without it and then re-add it and restart btsync ?

Share this post


Link to post
Share on other sites

ok - indexing is running (fast) right now - we will see if this solves the problem.

@dantounet: how many files do you manage through sync? Maybe we (or I) reached some limit somewhere?

Cheers,

C.

Share this post


Link to post
Share on other sites

@dantounet: how many files do you manage through sync? Maybe we (or I) reached some limit somewhere?

Unlikely, as there are no restrictions (other than the physical space on your drive) on the number of files you can Sync

Share this post


Link to post
Share on other sites

Getting a lot of these messages as well, on all 3 my machines.

All machines are Archlinux x86_64 (fully up to date) running 1.1.42 (upgraded from 1.1.15 a few days ago)

Since the upgrade sync has stopped working entirely for certain shares,

tried deleting all the metadata in the storage_path and rebuilding the indexes, but same problem shows up.

Haven't tried deleting the .SyncId in the shares themselves, would that make a difference?

Share this post


Link to post
Share on other sites

hmm… seems there's really some issue:

my sync was stuck this night at ~38-40G (about 10%), sync.log was full of SyncDB errors…

I looked in the DB, there are about 3k+ file entries missing in the "files" table - this, for sure, doesn't make 300G, but…

Any hint from the Team would be welcome :).

Cheers,

C.

Share this post


Link to post
Share on other sites

Hi,

As said above it happens on my ARM (yes linux) machines. I have two of them and it happened on both of them.

I have no pb on my linux 64bit though.

I have cleaned the metadata and SyncID on both machines but the error is still logged on the raspberry pi (but it's fine on the synology).

Should I send the logs ?

Share this post


Link to post
Share on other sites

Do you use config file or run Sync with default configuration? Do you use single UID/GID for btsync binary and files?

We saw such error on Android when sqlite was not able to find folder for temporary files. In Linux we set it to the same path where database itself is stored (storage_path in config file or .sync in current process folder by default).

Share this post


Link to post
Share on other sites

Hi,

I use the config file to setup btsync and the folders (web ui is off). I have not moved the default folder (it's in ~/.sync as for default configuration). btsync is ran with pi uid and ~/.sync belongs to pi user (I'm on raspbian).

As it is on a raspberry the performance is very poor (I do not mind but maybe it's the issue).

Share this post


Link to post
Share on other sites

Hi Sergey,

Alright, I am using it. However I have cleaned up the whole btsync setup on my raspberry pi and also stopped using zfs and back to ext4 as it was overkill.

No error for now, I'll send logs if I see any error.

cheers,

Share this post


Link to post
Share on other sites

The same issue:

FreeBSD 9.1

BTsync: 1.1.42

Fresh install, just a few test folders and up to 20 files all together.

config:


{
"device_name" : "fs754",
"listening_port" : 12345,
"storage_path" : "/var/db/btsync/s01",
"pid_file" : "/var/run/btsync.pid",
"check_for_updates" : false,
"use_upnp" : false,
"download_limit" : 0,
"upload_limit" : 0,
"webui" :
{
// "listen" : "0.0.0.0:8888", // remove "listen" field to disable WebUI
"login" : "admin", // remove "login" and "password" fields to disable credentials check
"password" : "password"
},
"shared_folders" :
[
{
"secret" : "Supper-Dupper-key",
"dir" : "/usr/home/share",
"use_relay_server" : false,
"use_tracker" : false,
"use_dht" : false,
"search_lan" : false,
"use_sync_trash" : true,
"known_hosts" : [
"FQDN:12345"
]
}
]

}

sync.log:


[20130621 03:57:15.026] Loading config file version 1.1.42
[20130621 03:57:15.048] SyncDb: Failed to init db
[20130621 03:57:15.048] Loaded folder /usr/home/share
[20130621 03:57:15.051] SyncDb: Failed to init db
[20130621 03:57:15.051] Loaded folder /usr/home/share
[20130621 03:57:15.052] SyncDb: Failed to init db
[20130621 03:57:15.052] Loaded folder /usr/home/share
[20130621 03:57:15.053] SyncDb: Failed to init db
[20130621 03:57:15.053] Loaded folder /usr/home/share
[20130621 03:57:15.054] SyncDb: Failed to init db
[20130621 03:57:15.054] Loaded folder /usr/home/share
[20130621 03:57:16.120] SyncDb: failed to prepare query to save metadata
[20130621 03:57:16.123] SyncDb: failed to prepare query to save metadata
....
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.134] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.135] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.136] SyncDb: failed to prepare query to save file info
[20130621 04:07:15.136] SyncDb: failed to prepare query to save file info

Share this post


Link to post
Share on other sites

I am having this same problem.

I tried removing the .SyncID, but that didn't help. Finally, I commented out the "storage_path" in my config file, and it is still not working.

I am using the i386 linux build trying to sync from OS X 10.6.8. Using btsync 1.1.42.

What is the best way to exit btsync, since I'm not using the web gui? I've just been using "pkill btsync" but I'm thinking that might cause the problem?

Share this post


Link to post
Share on other sites

I'm getting this exact same issue with the LInux i386 build on a Debian Squeeze VPS. It's causing all kinds of sync issues - new files not all getting added etc. I have another amd64 box (also with Squeeze) which works fine - both running 1.1.42

The only noticeable difference is that the i386 machine doesn't run the web interface - configured through a config file. The other box is configured through the web.

{
"device_name": "Data Server",
"listening_port" : 0,
"storage_path" : "/home/user/.sync",
"check_for_updates" : true,
"use_upnp" : true,
"download_limit" : 0,
"upload_limit" : 0,
"shared_folders" :
[
{
"secret" : "xxxx",
"dir" : "/home/user/data/",
"use_relay_server" : true,
"use_dht" : false,
"search_lan" : false,
"use_sync_trash" : false
}
]
}

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.