sync stucks at a just a few kb to go?


Recommended Posts

Guest idef1x

I have several sync folders wich seems to be stucked at just a few kb or even bytes to go. Is there a way to find out what it still thinks need to sync? The logfile doesn't show much.

I am in the impression that it might be a locked file or so and might need to put it in the .SynIgnore, but can't find what :(

Link to post
Share on other sites

I ran into this same problem today and I found a solution and came to the forums to register to share it. For me, I was trying to sync from a linux box to windows and one final file would not sync. It was 73.7KB. I went to the root dir on the linux box and searched for a file of that size. -R is for recursive searching, -h is for human readable file sizes (74K, 244M, etc)


ls -laRh | grep ' 74K'


-rw-r--r-- 1 pi pi 74K May 24 20:02 Ron Paul on the boston bombing and military response.jpg
-rw-r--r-- 1 pi pi 74K May 4 03:51 ron paul on the boston bombing and military response.jpg

based on the results, you can see that I had two files that were different in linux (case sensitive), but the same in windows (not case sensitive). I deleted the duplicate file on the linux box (or change the name if they aren't dups) and then everything was fine.

Look for weird characters in the filename or duplicate names based on the OS.

Link to post
Share on other sites
Guest idef1x

Thanks for the hint...that solved at least a few syn folder issues, bud sadly not all.

Apparenlty all my Android devices are still stuck for the final 800 and a few bytes, which seems to be exactly the size of .SyncID and .SyncIgnore! I put a .* in the .SyncIgnore (both sides of the syncdevices), but still it looks like those files have to be synced according the Androids. Maybe .SyncIgnore is not working on Android?

Link to post
Share on other sites

What happens when you create a new secret folder with nothing in it? Will they sync? I didn't have any problems getting my android device to fully sync.

Are there any other files in any of your directories of similar size to .SyncIgnore and .SyncId? I'd start by doing a sub-dir by sub-dir verification that the same number of files and bytes exist on each host to narrow it down a bit more.

Link to post
Share on other sites
Guest idef1x

Well I started with an empty directory on my laptop and started to create a syncdir and scanned the code on my Nexus4, did the same in a seperate sync dir for my Galaxy Ace, and Galaxy Tab 10.0 and all three syncdirs give the 807 bytes still to sync, which is exactly the size per device of the .SyncID and .SyncIgnore file. Even after changing the .SyncIgnore on both sides to ignore .* and restarting btsync on both my laptop and Android, will keep the same result, so my guess is that .SyncIgnore is ignored on Android, but didn't test this thoroughly yet though..

edit: Just a quick test

- create new empty directory on my laptop

- create a .SyncIgnore with

nosync

nosync/*

in it

- create syncfolder on laptop

- create testfolder (with data in it) on Nexus4

- create same .SyncIgnore as above

- create nosync subfolder and put data in it as well (from root of syncdir)

- scan QR code from laptop

- sync

and.....

nosync dir and files get synced! :(

Can I conclude now that .SyncIgnore is not affective on Android?

edit2: Hmmm putting /nosyncdir and /nosyncdir/* in .SyncIgnore before initial sync, does work, so .SyncIgnore IS working on Android....

Beats me what it is then....will try later with adding /.* to .SyncIgnore then to see if that helps, although it didn't want to sync .SyncID I think

Edited by idef1x
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.