Sign in to follow this  
ignasigarcia

WebUI not accessible from the Internet

Recommended Posts

Hi there. I have btsync running on my home server and some of my computers all running Linux. On my home server, config file has a value of 0.0.0.0:8887 assigned to the listen variable, so I can access the WebUI on port 8887. However, that only happens on my LAN or through my VPN. I punched a hole on my firewall to access it from the outside as well, but I always get a connection refused error. The punch is active, but there's no access to the WebUI from the internet. Any ideas on why this may be happening?

Thanks in advance,

Ignacio

Share this post


Link to post
Share on other sites

On my home server, config file has a value of 0.0.0.0:8887 assigned to the listen variable, so I can access the WebUI on port 8887. However, that only happens on my LAN or through my VPN. I punched a hole on my firewall to access it from the outside as well, but I always get a connection refused error. ... Any ideas on why this may be happening?

You will likely need to change "0.0.0.0" in your config file to reflect your external IP address. For more information on what 0.0.0.0 is see this article

Share this post


Link to post
Share on other sites

Does your server have direct connection to the Internet? (maybe you have a router and didnt set port forwarding)

Did you set login&pass in the config file or via webgui?

Firewall rules? From any to destination port 8887? Right?

Please, do a screenshot of your 'refused' error.

Share this post


Link to post
Share on other sites

You will likely need to change "0.0.0.0" in your config file to reflect your external IP address. For more information on what 0.0.0.0 is see this article

0.0.0.0 when binding on a server is equivalent to asking to bind to all addresses. Attempting to bind to an IP address that isn't directly on the device will fail.

Share this post


Link to post
Share on other sites

ignasigarcia,

Some likely possibilities,

  1. You've not correctly configured the port forwarding on your NAT box, it needs to redirect external TCP port 8887 to port 8887 on your internal machine. ("DMZ mode" can be used for testing, but that mode also disables all the firewall like properties of your NAT router)
  2. You have a share currently defined in the config file; for some reason BTSync doesn't start the webui if there are any shares defined directly in the config file.
  3. There is another firewall messing with you, for example, "windows firewall" will treat connections from the local network differently to those from other networks.

The 0.0.0.0 is the correct IP address to bind the webui to in most cases. Generally, you only change it if you want to restrict where the webui is accessible from. The 0.0.0.0 address means no restrictions and BTSync will accept a connection from anywhere.

PS: Some NAT boxes require a reboot even more often than Windows !!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this