GUI and log not agreeing (file size remaining to sync)

Recommended Posts

Hello there,

I've set up btsync using a two-way secret, trying to keep a folder on my laptop (running Ubuntu 13.04) with my home computer (running Windows 8). The gui reports that I have 42.1 GB in 64392 files in this folder.

For some reason, the web (and Windows desktop) GUI report that there is still 122.7 MB remaining to upload from my laptop. In spite of this, there is no transfer activity reported on either GUI, and after enabling debugging output, I see that the log reports "State sync finished for folder..."

When checking the results of the sync, I see that most things are synced as expected, but there are a few differences resulting from the SyncIgnore file (correctly ignored), and from the lack of symbolic link support on the NTFS drive. My question is: could these be causing the difference? If so, I don't believe that the GUI should report this remaining file size, and should rather say "fully synced".

I have tried removing and re-adding the folder from scratch (letting it fully re-sync from nothing), and this did not help.

Thanks in advance!

Link to post
Share on other sites

I'm having a similar issue here. Windows 7 on one side, W8 on the other. Read only 220GB share from 7 to 8. On 8 it shows synced while on 7 there are 47.2MB left to upload.

As you I tried to remove shared folders from sync and re-add and also deleting all files from W8 and re-sync, with the exact same result. Maybe it's just one conflicting file...

In my case I don't have ignored files.

Link to post
Share on other sites

I have similar problem. I use one central computer and several computers as read only. Sometimes all this read only computer says correct, but central computer indicates that one file must sync (i think is one file after looking size). Ihave compare with exteernal tools and is all sync, so is not a real problem.

Link to post
Share on other sites

Just figured it out! Turns out I had two files that had the same name, but different capitalization. This is allowed on linux (ext4), but not on Windows (NTFS). After I deleted one of the files, everything synced up perfectly, and the gui is now reporting that the folder is fully synced.

Sounds like this is likely an issue with particular problem files. Perhaps instead of just leaving a "file size remaining to upload" display, the GUI could display some sort of error pointing to the file that is having problems, so the user can manually intervene without having to search around the debugging logs to figure out the issue.

Link to post
Share on other sites

In my case it's Windows-Windows so I looked for something different and found some .!sync files in one of the computers. Deleted them but nothing seemed to change so I deleted the folder and re-created the share to force re-indexing everything. Now it looks good and synced on both sides and I'm happy again. :)

The !sync files seemed related to some temporary files that some programs create when working with them.

Link to post
Share on other sites

The .!sync file belong to btsync, so indeed some program ;)

Anyway those .!sync file represents files being synced, but not completed yet.

What I meant is that btsync was trying to copy a temporary file made by another program. I work with a render engine that creates big files and updates them frequently. There were some *.part.!sync (made by the render engine when creating those big files but are erased or renamed when the copy is finished) and some *.sv$.!sync (security temporary file made probably by AutoCAD for recover).

My intention was to point out some possible error prone situations. (I wasn't very clear on that, I guess)

So what does it mean when sync is completed and an !sync file is still there in the target folder?

That's the point. Probably the files disappeared before they could be fully synced and instead of getting deleted also they just got stuck there.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.