iziizi

Slow sync between UK server and OVH (French) server

Recommended Posts

I have a server in London with 1Gbit/s connection and one in France with 200mbit/s connection.

I am transferring ~300GB of files and only getting ~100 kB/s from the UK server to the OVH server.

Now I know it is the French server that is the problem, because I am also syncing to my home server @ 3.3 MB/s from the UK server.

How do I go about finding out why the French connection to the UK server is so slow? All settings are defaults.

Thanks.

Share this post


Link to post
Share on other sites

BTsync uses the torrent protocol, maybe there are some limitations regarding P2P traffic on the french side? Maybe try to set up a VPN/SSH portfw on the French server and see if it improves the speed.

Share this post


Link to post
Share on other sites

Now I know it is the French server that is the problem, because I am also syncing to my home server @ 3.3 MB/s from the UK server.

How do I go about finding out why the French connection to the UK server is so slow? All settings are defaults.

This is somewhat off-topic as it isn't really a problem with Sync, rather an issue with your servers/connections.

Share this post


Link to post
Share on other sites

BTsync uses the torrent protocol, maybe there are some limitations regarding P2P traffic on the french side? Maybe try to set up a VPN/SSH portfw on the French server and see if it improves the speed.

Thanks I suppose this is a last resort.

This is somewhat off-topic as it isn't really a problem with Sync, rather an issue with your servers/connections.

I am having issues with slow sync speeds, hardly see how its off-topic.

Share this post


Link to post
Share on other sites

Yeah, I just did an FTP transfer from UK server to french server 20MiB/s.

 

However, it remains the upload from UK is 100 kb/s for file syncing.

 

The files are all zips between 1kb and 3gb.

Share this post


Link to post
Share on other sites

Smaller files tend to transfer slower. If the files you're transferring lean towards the smaller end, they will be slower.

Additionally, transfers using Sync are nonlinear, so you may be hitting random seek transfer limits.

Share this post


Link to post
Share on other sites

I have a server in London with 1Gbit/s connection and one in France with 200mbit/s connection.

I am transferring ~300GB of files and only getting ~100 kB/s from the UK server to the OVH server.

Now I know it is the French server that is the problem, because I am also syncing to my home server @ 3.3 MB/s from the UK server.

How do I go about finding out why the French connection to the UK server is so slow? All settings are defaults.

Thanks.

Have you solved your problem? I also have problems of slowness from a server Kimsufi on OVH. Maximum 1MB/s upload.

Share this post


Link to post
Share on other sites

What are the specs of that VPS at OVH? Singlecore 1ghz 1GB ram just won't do it lel

No no, I have dedicate server.

Intel i5 quadcore And 16Gb of RAM!

Strangely if I use Transmission I reach 10MB/s. Yet the protocol should be the same.

Share this post


Link to post
Share on other sites

@drego85

What is the bandwidth? Average file size? Also, have you tried to disable "low_hdd_priority" setting to ensure HDD sharing is not a bottleneck?

Share this post


Link to post
Share on other sites

@drego85

What is the bandwidth? Average file size? Also, have you tried to disable "low_hdd_priority" setting to ensure HDD sharing is not a bottleneck?

 

The bandwidth is 100 Mb/s, usually I transfer the ISO of BackBox Linux (they are a team member). So files from 700Mb to 2Gb.

I never tried to change the value of "low_hdd_priority", I try and I'll know.

Thank you

Share this post


Link to post
Share on other sites

I have two servers in kimsufi. From Spain, in one of the servers it synchronizes 10MBs in another to 1MBs.

Between the two servers synchronize between 7-8MBs

The cpu is the same on both servers

Share this post


Link to post
Share on other sites
On 8/31/2013 at 4:50 PM, stim said:

FWIW I have one of those cheap atom servers from OVH and I've had no problems running BTSync on it since last week. No speed issues.

Hi

Sorry for the OT: could you please say me which firewall ports you opened to achieve a good resilio-sync btween your OVH (kimsufi, I presume) machines?
Private message would be ok too :-)
Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.