Sign in to follow this  
magicmike

Confusing issue with Mac to Synology sync- Indexing stuck

Recommended Posts

Hi all,

 

Firstly thank you very much to the devs for creating this app- it's a great way to backup data across remote shares. A quick description of my setup:

 

Mac OS X (10.8.5) running BTSync (1.1.69)

Synology DS1513+ (DSM 4.3) running BTSync (1.1.70)- Synocommunity package

 

I have set up a sync on my music folder on my mac (410.6GB/15156 files) to my music folder on my Synology (/Volume1/music)

 

I have established the Synology sync with Read only secret from Mac so that sync is one way, as I make all my changes and run music from my Mac.

 

The problem:

 

It's syncing completely on my Synology (shows last synced date and time) but is stuck indexing. It's showing slightly less files (about 25 less) and 670MB less than what is in the folder. It's chewing up 20% cpu and shows no sign of completing the indexing. The file size and number of files jumps up and down, i.e. from 15131 to 15130 and the file size constantly changes from 409.9GB to 410Gb and back again. Like is stuck in a loop.

 

On my Mac it shows that there is 670MB left to sync (this goes up and down as well) under the status tab, presumably because the NAS has not finished indexing.

 

I have tried to follow instructions to enable debug log on my NAS- the file locations are different to normal linux boxes. There is no /.sync folder. There is:

 

@appstore/btsync

                          /app

                          /bin

                          /var

 

I have tried creating debug.txt with FFFF in all three subfolders, but nothing happens. There is a sync.log file in the var subfolder, but I can't make much sense of it (see http://www75.zippyshare.com/v/63612541/file.html) The file is 4mb compressed so I cannot attach it here.

 

I have attempted to stop and start the BTsync service on the NAS, I have deleted and added the folder, and I have tried stopping services like iTunes server that may have been conflicting/using files but no joy. 

 

Any help/suggestions/thoughts would be much appreciated from the community and devs. If anyone has succeeded in getting a debug log to work on Synology please let me know.

 

Share this post


Link to post
Share on other sites

.sync folder is located in btsync working directory. You should create debug.txt with FFFF in .sync folder and restart btsync. After that you can check sync.log

Share this post


Link to post
Share on other sites

Thanks to Support for helping me figure this out. It's an issue with read only secrets having to be synced into a fresh folder or a fully synced existing folder. So I whilst the majority of the files in my two folders were the same the were about 25 that weren't and that was causing the issue. Solved it by doing full access between the two folders and monitoring what was being changed back and forth.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this