Sign in to follow this  
gpops

Disabling at startup - Linux

Recommended Posts

I'm running Kubuntu 12.04 and would like to stop BTSync from launching at startup. I don't see any settings in the WebUI. Thank you.

EDIT:
There is no option in "Autostart" under System Settings either. Normally I just change using the GUI configuration tool there.

EDIT:
I also manually quit BTSync from the taskbar before logging out. So it is not saved to my session.

Additionally, I tried adding "btsync-starter" to my exclusions in session management to no prevail.

Share this post


Link to post
Share on other sites

Through the repository (ppa:tuxpoldo/btsync). I installed btsync-user rather than btsync (for servers?).

My linux-savvy friend helped solve my problem. He found "/etc/xdg/autostart/btsync-agent.desktop" which had the line "Exec=/usr/lib/btsync-user/btsync-starter". It appears that even though I previously added "btsync-starter" to my list of start-up exclusions, the "/etc/xdg/autostart" directory still loads afterwards. This makes sense because BTSync is always the last to boot in my taskbar.

Removing the file worked for me. I'm not sure of any repercussions but I've experienced none. Mods, please correct me if I'm wrong.


sudo rm /etc/xdg/autostart/btsync-agent.desktop

Done.

Share this post


Link to post
Share on other sites

Removing the file worked for me. I'm not sure of any repercussions but I've experienced none. Mods, please correct me if I'm wrong.

...

sudo rm /etc/xdg/autostart/btsync-agent.desktop

 

This method is OK if you do not want BitTorrent Sync to be autostarted on logon. In any case I have a question regarding the use case: do you want to not start BitTorrent Sync because you do not want it to use network resources, or do you really want to start it only on demand?

 

I ask this question because I'm thinking about making the paused state persistent across sessions. In that case, if you pause btsync from the indicator menu, after restarting your system the btsync engine would not restart but the indicator would still be present. In order to resume syncing, you could resume it from the indicator menu. (See Issue #12)

Share this post


Link to post
Share on other sites

This method is OK if you do not want BitTorrent Sync to be autostarted on logon. In any case I have a question regarding the use case: do you want to not start BitTorrent Sync because you do not want it to use network resources, or do you really want to start it only on demand?

 

I ask this question because I'm thinking about making the paused state persistent across sessions. In that case, if you pause btsync from the indicator menu, after restarting your system the btsync engine would not restart but the indicator would still be present. In order to resume syncing, you could resume it from the indicator menu. (See Issue #12)

 

I use BTSync to keep my phone's music library synced with my computer's collection. I also use it to do one-time transfers with family members (as I am away at school).

It's a mixture of both not wanting BitTorrent Sync's activity detected and I'm a bit meticulous... I like programs to run only when I need them. I assume that every few seconds BitTorrent Sync must be pinging any device with a matched secret and I don't want my ISP to see this (I'd like to stay as incognito as possible).

I love your idea. That's exactly what I would like. To have the program enter a dormant state (through pausing) and continue that through sessions would be awesome  :D

P.S. I made a backup of the "btsync-agent.desktop" file, however it lost permissions. Am I remembering correctly that it was a symbolic link with rwx for everyone? I'm asking because I read online that instead of deleting I can add the line "NoDisplay=false" and it will appear in my GUI to disable at start-up.

Share this post


Link to post
Share on other sites

I use BTSync to keep my phone's music library synced with my computer's collection. I also use it to do one-time transfers with family members (as I am away at school).

It's a mixture of both not wanting BitTorrent Sync's activity detected and I'm a bit meticulous... I like programs to run only when I need them. I assume that every few seconds BitTorrent Sync must be pinging any device with a matched secret and I don't want my ISP to see this (I'd like to stay as incognito as possible).

I love your idea. That's exactly what I would like. To have the program enter a dormant state (through pausing) and continue that through sessions would be awesome  :D

P.S. I made a backup of the "btsync-agent.desktop" file, however it lost permissions. Am remembering correctly that it was a symbolic link with rwx for everyone? I'm asking because I read online that instead of deleting I can add the line "NoDisplay=false" and it will appear in my GUI to disable at start-up.

 

If you deleted btsync-agent.desktop from /etc/xdg/autostart I can tell you, that this was only a symbolic link:

 

leo@ubupoldo:/etc/xdg/autostart$ ls -latotal 120drwxr-xr-x 2 root root 4096 Nov  6 17:41 .drwxr-xr-x 4 root root 4096 Oct  2 12:20 ..-rw-r--r-- 1 root root  305 Apr  4  2013 at-spi-dbus-bus.desktop-rw-r--r-- 1 root root  407 Mar  8  2013 bluetooth-applet.desktoplrwxrwxrwx 1 root root   44 Nov  6 17:41 btsync-agent.desktop -> /usr/share/applications/btsync-agent.desktop-rw-r--r-- 1 root root  369 Mar 28  2013 deja-dup-monitor.desktop

 

 

The original file is saved in /usr/share/applications

 

Please make a test with this NoDisplay=false - if it is displayed in a startup manager, it would be better for anybody. In order to edit the file in /usr/share/applications/btsync-agent.desktop you must be root:

 

sudo nano -w /usr/share/applications/btsync-agent.desktop

Share this post


Link to post
Share on other sites

I made a new symbolic link inside /etc/xdg/autostart so I'm back to stock installation.

I added NoDisplay=false to the file /usr/share/applications/btsync-agent.desktop and restarted my computer. There was no additional option inside System Settings>Start up & Shutdown>Autostart as I hoped there would be. So I removed the NoDisplay=false line and saved. Stock installation again.

For the time being, I will remove the symbolic link. This works.


P.S. This looks like it has nothing to do with it:
~/.local/share/applications/btsync-user.desktop

gpops@gpops-PC:~/.local/share/applications$ cat btsync-user.desktop [Desktop Entry]Name=BitTorrent Sync Web UIComment=BitTorrent Sync management interfaceExec=sensible-browser http://127.0.0.1:9999Icon=btsync-userTerminal=falseType=ApplicationCategories=Network

But I added the line NoDisplay=false anyway. I restarted my computer and the line was removed.

I have an exam to study for, but I will keep tinkering with this later after my test.  ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this