pruppert

Certain Bt Sync File Names Are Not Encrypted In A Encfs Raw Folder

Recommended Posts

I am using encfs to encrypt a folder that is synced via BT Sync. I have noticed that the file names of the following BT Sync files/directory are not encrypted within the raw encfs directory:

 

.SyncArchive (directory)

.SyndID (file)

.SyncIgnore (file)

 

The file names are readable despite all other file names in the raw encfs folder being encrypted.

 

Has anyone else noticed this behavior? Can anyone provide an explanation of the how and why the names of these files/directory are not encrypted by encfs?

Share this post


Link to post
Share on other sites

These files are created by BTSync. .SyncArchive contains deleted files, .SyncID I assume identifies what share it is part of. And .SyncIgnore is there to tell it what files to ignore. I don't belive any of them are actually synched. (and appart from syncID none should contain anything if configured correctly).

Share this post


Link to post
Share on other sites

I understand all of that. My question is why/how are the file names for these files not encrypted when in a encfs folder. Does anyone with encfs knowledge know the answer?

Share this post


Link to post
Share on other sites

I understand all of that. My question is why/how are the file names for these files not encrypted when in a encfs folder. Does anyone with encfs knowledge know the answer?

 

I am assuming you gave BTSync the encrypted folder? If so then the answer is pretty obvious. It is a normal folder, files and folders written to it won't be encrypted. The FUSE mounted folder on the other hand, it works as a transparent layer between the encrypted files and the folder you see. This is not a normal folder, the folder containing the encrypted files is a normal folder, it can be written to directly.

Share this post


Link to post
Share on other sites

Ha, you're right. That is exactly what is going on. That should have been completely obvious, but I was just not thinking of it correctly. Thank you for setting me straight.

Share this post


Link to post
Share on other sites

Ha, you're right. That is exactly what is going on. That should have been completely obvious, but I was just not thinking of it correctly. Thank you for setting me straight.

You're welcome.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.