Bittorrent Sync Corrupting Filesystem


unlimitedbacon

Recommended Posts

I have a Raspberry Pi running Raspbmc (based on Raspbian) which I use as a media center. I also wanted to use it as a BTSync server, so I installed it via the instruction in the Debian Unofficial Packages sticky thread. The Raspbmc installer makes the root filesystem F2FS, but all my sync folders are on an external hard drive with EXT4.

 

After installing, configuring, and adding all my folders, everything seems to work initially. Sync will index all the files and do its job. However, over time the system becomes slow and applications start freezing or crashing. This is not unexpected for a machine with such limited resources. What is unexpected thouth, is that the problems persist even after I disable the Bittorrent Sync daemon.

 

Typically the system will boot and run for an hour or two, then XMBC will freeze. I can still SSH in and do things but other applications will often freeze up (i.e. "apt-get update" will never finish). Also I will occasionally get kernel error messages on the terminal. Not a full on kernel panic, but just an error with some hex values.

 

The most important symptom though, is that the system becomes incapable of shutting down cleanly. If I do "shutdown -h now" or shutdown from inside XBMC (if it hasn't frozen yet) then it will just sit there and do nothing until I do a hard reset. If I take the SD card out and mount it in another computer, it can read from the drive but files written to it will sometimes dissapear. Also that computer won't unmount the volume and won't shutdown on its own either.

 

Things will continue to get worse until the pi becomes completely unbootable. Remember all this keeps happening even after the btsync daemon is disabled.

 

I've tried different SD cards and changing power supplies. I've formatted and reinstalled the OS 4 or 5 times now. The problem definitely starts when I run BitTorrent Sync. To me this smells like a filesystem/kernel issue, especially since its using an oddball filesystem like F2FS. fsck.f2fs doesn't seem to help. I would upload sync.log but its over 500KB and I'm not sure it would help much anyways. Sync works ok. Everything else is what breaks.

Link to post
Share on other sites

Hi unlimitedbacon,

 

BTSync access to file system only using OS API. It is not a kernel-space application, so it is very unlikely that it damages filesystem unless OS does that.

 

I see that F2FS is relatively fresh file system and it keeps update by it's creator. According to Wiki the latest unstable release was in Feb 2013 and stable is yet to be done. It also depends on which kernel version do you use in your Raspbmc, as there are still commits related to F2FS.

 

The only role I see BTSync can do here is to read and write data extensively.

 

I can advise you to set up your Raspbmc using traditional ext file system instead of F2FS and see if issue persists. 

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.