Baraqyal

Glacial Sync Speeds

Recommended Posts

Hey guys,

 

Been using btsync for a while and it's always been a bit sluggish for me. So I finally decided to do something about it and hopefully fix that.

 

I'm running the latest version (1.2.82), on two machines that are:

 

Locally - running Ubuntu 12.04.3

Remote - server running Gentoo

 

My connection is an ADSL2+ connection (20Mbps down / 1Mbps up roughly) located in Melbourne, AU

My remote machine is sitting in a data-centre with a 150Mbps port located in The Netherlands

 

For reference, I can max out this connection downloading via HTTP but Btsync is much nicer in that it's automated. Unfortunately using Btsync means I only get ~200KB/s (500 on a good night) while using HTTP means I can get at least 1MB/s off the server.

 

Here's the log:

[20140204 01:35:39.824] total physical memory 536870912 max disk cache 2097152[20140204 01:35:39.824] Using IP address 10.1.1.12[20140204 01:35:39.824] Loading config file version 1.2.82[20140204 01:35:39.962] Loaded folder /mnt/raid/download/-snip-[20140204 01:35:39.986] Loaded folder /mnt/raid/download/-snip-[20140204 01:35:40.025] Loaded folder /mnt/raid/download/-snip-[20140204 01:35:40.146] Loaded folder /mnt/raid/download/-snip-[20140204 01:35:40.906] UPnP: Unable to get external IP.[20140204 01:35:40.935] UPnP: Device error "http://10.1.1.1:49152/description.xml": (-2) [20140204 01:36:17.856] UPnP: Device error "http://10.1.1.2:1990/WFADevice.xml": (-2) [20140204 01:36:17.864] UPnP: Device error "http://10.1.1.1:49152/description.xml": (-2) [20140204 01:36:17.889] UPnP: Unable to get external IP.[20140204 01:36:28.824] NAT-PMP: Unable to map port with NAT-PMP.-- lots of 'piece complete' notifications ---- more UPnP errors (same as above) ---- repeat ad infinitum --

So the .1 address is the modem, the .2 address is the access point.

 

I hope I've provided enough info. Any suggestions guys?

Edited by Baraqyal

Share this post


Link to post
Share on other sites

Well, from your log, it looks like there's a problem with UPnP on your router, and also given your devices are in two different locations (i.e. on two different LANS, as you've not indicated that you have a VPN between them?) it's most probably that Sync is making relayed connections (rather than direct connections) between your devices.

 

Relayed connections are generally a lot slower than direct connections (as they are "relayed" through an intermediary).

 

Therefore, to improve your transfer speed:

  1. Resolve your router's UPnP issue(s)
  2. Consider setting up a VPN between your two locations so that your two devices in different countries appear as though they are on the same physical LAN

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.