Root Drive Sync


Recommended Posts

Hey guys


Thanks for the great product. Right now, my son and I are using BTSync to maintain our own cloud. We both have servers with the family's pictures, videos and files at each of our homes and sync them with BTSync.  Works great with one exception. I've tried several times to figure out how to sync the root of a drive.  I also sync my primary computer (the data drive) with the server using BTSync.


My main work computer has an SSD and a data drive like most of us. I want to back up the entire data drive which has many directories. While I could move it down a level, I've got a number of programs installed to it and it would probably be easier to just wipe out Windows and start over.  I've searched the forums repeatedly and tried to include the Recycle Bin and System Volume Information folders in .SyncIgnore but to no avail. I keep getting errors in the log (error 5) and it stops. 


Is there any way to sync the root of a drive?


Any guidance/clues or help would be greatly appreciated!



Link to comment
Share on other sites

You can sync a root drive, BUT you need to be aware of the following general issues:

  1. Sync can't sync files that it can't access, either because it does not have the necessary permissions (i.e. System Volume Information folders etc), or the files are open/locked/in use by other applications or the operating system (i.e. pagefile.sys).
  2. Some files on your root drive may need to remain "unique" to that device - for example, if you've installed Sync on the drive you wish to sync in its entirety, you'll want to exclude %AppData%\BitTorrent Sync from syncing as this folder needs to be unique on each device, as it keeps track of which files are in sync on that device.

Now, If you're just syncing a drive that contains data only and no system/program files/user profiles, and the files on the drive are not open/locked/in use, then there's no reason your root drive can't sync (as long as you exclude system/protected entities like System Volume Information, etc)


Perhaps if you could provide details of the errors you're seeing, we can provide more insight into your issue?

Link to comment
Share on other sites

I've just been round this loop in the context of backing up my cloud based vps.

Both my host and offsite backup service providers agree that we can never 100% back up an envelope from within. 

There are always some elements that neccessarily change during the course of the course of the backup.


It is possible to snapshot from outside the envelope while the system is not running.

This is what Norton Ghost and similar disk imagers do. 

They run under unix/linux or dos and take a snapshot of the windows partition.

They are easy to run and work just fine.


Their draw backs are the lack of granularity - and the substantial run time involved to copy or restore such large volumes.


My approach is take a disk image of a clean (provisioned) install to recover the system itself. 

And then to use conventional backup from within the system envelope to secure current copies of user data.

This is more convenient to administer if you can segregate system and data to different disk partitions.



Link to comment
Share on other sites

Thanks for the thoughts guys.


I was having problems with the System Volume Information folder. I changed the permissions on the folder itself to allow BTSync access but a subfolder was giving me problems.  After doing everything I could think of, I ended up deleting the offending folder by booting into Linux and then BTSync happily went to work syncing the remainder of the drive. 

Link to comment
Share on other sites

  • 7 months later...

I am having similar problems- however it's the behavior or BTsync that I don't understand: when syncing the root of a Data-only drive, BTsync performs the initial indexing and tells me everything is up to date. Then, I will add a file or folder to one computer- but it does not sync to the other computer. I have had a similar problem before where it would simply stop syncing files after a certain letter.

Can anyone offer advice?

Ford- what did you delete exactly to get things to work?

I am running win 7/8

Link to comment
Share on other sites


Before Sync get stuck into some folder it actually cannot access to (usually - System Volume Information). Though, starting from version 1.3 this was fixed and indexer is no longer blocked with folders it can't access to.


Do I understand correctly that in your case it does not sync even a single file after indexing?

Link to comment
Share on other sites

  • 8 months later...

Hi again!


Annnnd... almost a year later, with Version 2 I am having the same problem: I am trying to sync the root of my D drive and sync just... stops. It reports no problems, but only syncs three folders in my drive. I have excluded the Recycle bin and any pagefiles, System Volume Information,etc but nothing seems to help.

Can I sync a root folder / Drive in Sync 2 on Windows 8?

Link to comment
Share on other sites


Actually, the issue was fixed long, long ago - 1.4 should contain the fix for sure. We've tried to Sync non-system drive on Win8 in lab with no issues.


I'll be happy to look into debug logs and find out why your Sync does not want to sync all the other folders.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.