Recommended Posts

Hello,

 

At first, let me say your app is FANTASTIC! Really genial, the last sync/backup app whats ever needed!

 

I´m using it to sync 4 PC´s, with backups on 2 Server. And i ran into strange behaviors:

 

A few month ago, something really nasty happens. I was coding, the files are on the sync folder and synced with 2 pcs and the 2 backup server. I was always working on the same project files, cause i thought btsync would handle that (even versioning!). After i stopped i noticed that my new changes where overwritten with the old built! Wasted a hour of lifetime..

Now i´m making copies of the project every time i do a major change, it never happend again. But since this moment i lost my trust in the application :mellow:

No logs available for that, just happend one time. But another problem occurs sometimes:

 

Second, from time to time btsync thinks that it has to resync a whole folder even if there are no changes! Thats really weird, i´m syncing one folder with just images where no changes happend for a few month. Logfiles says then "pcx added file ...". Truly, it´s not. Files are on all clients the same for months..

 

 

I think both bugs come from the system time. The two servers are linux and synced over ntp, the windows pc´s are synced over time.windows.com. I set the max time diff to 100 secs and put a time-sync-script into autostart. I haven´t checked yet if that helps.

 

But that shouldn´t happen at all i think? The few secs time diff should be compensated by just that setting, otherwhise it´s useless and all clients need the exact same system time??

 

I´ve started to give my backup server just read access, so there are not so many "players" in the game, mabe it´s getting more stable. BUT i´ve never seen that one of my servers ran into problems, only the windows workstations!

 

Maby you can write me some lines and bring my trust back.. ;)

 

 

with best regards,

Andreas

 

Link to post
Share on other sites

Hi Andreas,

 

Thank you for the positive feedback. BTSync is in Beta now, so we are doing our best to catch and fix bugs in real environments. Usually such bugs with files coming back are happening indeed due to significant time difference between peers. Could you please turn on debug logging for a day or two to catch the issue if it comes back? Don't keep debug logs longer, as they are going to occupy a lot of disk space.

 

As for the second issue - couldn't it happen that some of image viewer is meddling with files? For example. updating some thumbnails / DB files in your folder? The fact that BTSync decided to re-sync folder means that the hash of the folder has changed, i.e. either some files are changed, or new ones appeared.

Link to post
Share on other sites

Hello,

 

Yeah i know, i know what hard work debugging is.. especially with such random errors..

but I´m sorry, it only happened 2 times within 4 month.. i think i won´t catch that in the logs.. But it only happened to rapidly changed files, like when you save it every 30 seconds..

 

But i´ve got a theory for that:

 

Workstation make a new file, it gets synced to Backup

Backup actualises his time, he was "in the future" and sets the clock back

Backup´s btsync rescans the folder. Due to the creation with the "future" time now it thinks that the file got changed.

The old version overwrites the new one, because the change of timestamp happened after the real file change.

 

Could it be that btsync takes the change of time stamp/system clock as an file change event??

 

 

That scenario would also explain why that second issue happen from time to time. sometimes one pc syncs his complete folder (24gb) with all files in it. But that files have definitly got not changed by anything! The only changing thing can be the system clock due to clock sync.

In fact the files get not really transferred (i think). btsync seems to recognise that the files are exactly the same (hash?) and only sets the timestamp or whatever to be happy.

 

Men thats hard to explain in english.. i hope you understand what i mean^^ I don´t know how windows/btsync handles time stamps, but i really think that´s the point where to look

 

offtopic question, can you say when v1.3 is released? really lookin forward!

 

with best regards

Link to post
Share on other sites

the more i think about it the more i know that that´s the problem,

 

when one pc thiks his whole directory is a new version it overwrites all changes that where made on other pcs

 

mabe i can get you a log of that, cuz the syncing of the wohle directory takes time.. do you need the logfile from the "bad" peer or of any of them?

Link to post
Share on other sites
  • 2 weeks later...

sent you a mail with the update-bug log.. nothing special.. but today i updated btsync and got tons of following errors, at the same behavior, tons of files get updated, added by "myself", but they werent touched...

 

 

[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
[2014-03-20 22:34:34.777] SyncDb: failed to execute query to save file info - 1
 

any suggestion

Link to post
Share on other sites

andi,

 

I did not receive any logs. Could you please re-send them? If you are sending to syncapp@bittorrent.com - please put there a link to this forum topic as well,

 

The messages you see are important indeed - looks like we failed to contact our DB at all. It might happen if BTSync lacks the permissions to read-write Sqlite DB files.

Link to post
Share on other sites
  • 7 months later...

Hello,

Just wanted to say that this bugs did not happend any more since a long time, seems like you got it fixed!

 

But ive got another problem, WEB-GUI is not showing on my Raspberry Pi since the last update. I get the login, but then there´s only a white page without content.

Tried to change the login data, restarted the box, restartet btsync.. any suggestions, except of re-installing btsync?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.