Btsync Server - Backend Working, Webpage Frontend Blank


Gyzer

Recommended Posts

I installed BTSync on my Ubuntu Server 12.04 install over 6 months ago. Everything was working just fine while I used it with multiple people syncing data to my server.

 

About 2 months ago I ran a large amount of updates on my server. I believe one of these updates was for btsync as well, but I'm not 100% sure. After these updates I found that the BTSync server webpage frontend wasn't working. It asked me for my username and password but when it would load it would load a blank page, similar to just freshly installing BTSync without any shares setup.

 

For the next month or so I thought BTSync was dead on my server, but then I started noticing syncing happening from my desktop to the server. I had a few friends who had been syncing data with my server try it on their end and it worked. Still though, the webpage front end is all blank.

 

I'm not at a place where I need to add more shares and I'm unaware on how to do this with the current state of the webpage frontend.

 

What steps can I take to get the webpage front end to work again? Or is there a manual way via some config files where I can create new shares? 

Link to post
Share on other sites

Gyzer,

 

Try opening a web UI with a different browser or clear cookies. And yes, there is a way to run BTSync thru a config instead of WebUI. You can dump sample config with 

 

./btsync --dump-sample-config

 

command. After you are done preparing config file, you can run BTSync with command

 

./btsync --config <path_to_your_config>

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.