Beware, Bt Sync Propagated Oldest Versions

Recommended Posts

Running BT sync on 2 Macs (1.2.82) and 2 Qnap Nas (1.1.82). As reported on this forum before sync suddenly stopped between the Macs and the two Nas. Macs were kept in sync and according to the config screen on the Nas also the two Nas. However, the between macs and Nas no sync took place.


A couple of weeks ago I tested to remove the catalogs on the two Nas and then set them up again. Yesterday I found that some files on my Macs had been reverted back to older versions, the versions they had on the Nas.


Luckily I have TimeMachine backups on my Mac so I can restore the files I have identified, but I have found no easy way to identify all reverted to older version.

Link to post
Share on other sites



Old file versions are also stored in .SyncArchive folder. The fact that older version was synced to your Mac means that BTSync decided it was modified / moved to dir later, thank on your Mac.


Could you please share more details? What kind of files? Are they modified on Mac / NAS by some apps? Was BTSync running / sleeping?


Also please make sure that the time on your NASes and Mac is also synced.

Link to post
Share on other sites

My recollection is not 100%, but here is what I remember


Sync stopped beginning January. I tried to get it going then by removing/including  the both Nas at the time with no success


In February I tried again to get sync between the Macs and the two Nas to work.

Beween Macs it worked fine and according to the panel on my local Nas the remote Nas was in sync, but there was an arrow, up or down and 56GB for the connection to the Macs.


I checked the .cache and .SyncArchive on both Macs and local Nas before disabling. They were empty or had 1 or 2 files.

On the setup panel on the local Nas I removed both Macs and the remote Nas. When I checked the .cache and .SyncArchive files were gone from the catalog.


I the set up the Macs and remote Nas for sync. After indexing I could se some transfers, but after a while II was back square one.


Sync setup on remote Nas was NOT disabled/enabled, only the local


The files that I found with versions bumped back are txt files (source code). By checking versions in Time Machine I found snapshots feb 20 OK and feb 28 wrong. I was gone for a week and tried to get sync work the last thing before leaving.  As the files was updated Feb 15, the reversion to older date must have been my latest attempt.


The files were only modified on my Macs. BTsync has been running all the time and the time was synced.



There is probably other files modified since beginning of 2014 when sync with Nas stopped. The good news is that new files created on Macs since that time was not removed.

Link to post
Share on other sites



Thanks for the feedback. Do I understand correctly, that after you realised that files were reverted to older version - .SyncArchive on Macs were empty and did not contain previous versions?


BTSync should save all the files it overwrites to .SyncArchive, so it can help you realising which files were actually rolled back.


Also, did you had a chance to grab a log from NAS-es / Mac? This could help us to find the root cause of the issue.


If your NASes still does not see Macs - please check your router settings and firewall settings (if any). For local network discovery we use multicast address over UDP 3838, to contact tracker server - UDP 3000, they must be allowed in firewall / router so devices can "see" each other.

Link to post
Share on other sites

Thank you! Your answer pointed out how to identify files reverted back to older versions. I should have thought of that myself. .syncarchive on my mac contains the latest version of the files and I can now restore  affected files.


.syncarchive was empty BEFORE I tried to restart sync and before files were reverted.


Unfortunately debug logging was turned off.


Nas-es and Macs do see each other. they show up at setup panels.


I will make a new attempt to get sync working in a few days and will use the following steps

  • Make a full backup of my iMac
  • Disconnect MBAir from BTsync. The I have a working computer during the process
  • Disconnect remote Qnap from BTsync
  • Remove sync connection on local qnap. Make sure all BTsync system files are deleted
  • Restart local Nas and Btsync
  • Reconnect iMac an local Qnap. Debug logging on iMac


Any comment on the process are appreciated.

Link to post
Share on other sites



Looks okay. Couple of comments on debug logs:

1. If issue occurs, the probability to catch issue is much higher if we have logs from all peers involved in issue (usually, 2).

2. Don't keep debug logs on for too long, as they are going to consume really much space. We are working to make log rotation in future releases, but it is not yet present in 1.2.

Link to post
Share on other sites

Performed the test as described. Older file was restored from Nas to iMac. See word attachment. I had debug logging on the but the two log files (sync.log and sync.log.old )was only covering the last hour or so.  Sync took place 4 hours earlier.


Then I tried the radical method. described in next post as attachment would not fit here.



Then I tried the radical method. On local Nas , remote Nas and mbAir i deleted all files in the BengtData catalog. I realized afterwords that hidden files was not deleted. I removed the catalogs from BTSync and restored them.


Synchronization started but after som time it stopped. This was the original problem. It seems as the two NAS-es are in sync and the the two macs even if there is a discrepancy between the Macs.


Just now long after sync stopped I made some tests.

Adding files on iMac was propagated to MBA, but not to either Nas.

Adding a file to to local nas was replicated to remote Nas and to both Macs.


Enclosed pdfs shows status on all devices. Note that numbers on data remaining do not match

Reading my post I should clarify that the order was removal of catalogs from BTSync followed by deletion of files and then connecting catalogs to BTSync

BTSync old file propagated.pdf

BTSync lock-up 2014-03-18.pdf

Link to post
Share on other sites



Seems I've found an answer to the issue why your NASes overwritten more fresh files on one of your screenshots. Your NASes are using 1.1.82 build, which is rather old. For every file BTSync stores very important information in DB: change time. This time might differ from mtime (for example, if you grabbed old file and put it into sync folder - mtime won't be modified, while Sync must understand that user believes that this file is more important for him).


1.1.82 contained a nasty bug: when you added a folder to sync folder, "Change time" was set not to mtime, but to the moment of adding folder, making all files in added folder automatically more fresh than any other files.


So, all you need to do is to update your BTSync on NAS devices to the latest available. 

Link to post
Share on other sites

This may append to previous message although it is a new message 8 hours later. I don't understand this message board but sometimes it merges several messages into one.


Anyhow, I have repeated the the lock-up problem and I believe it to be a bug in BTSync. I did the following:

1 I disconnected the iMac, MBAir and both Nas-es from BTSync,

2 I deleted the cataloges on MBAir and both Nas-es

3 Deleted .syncarchive on iMac

4 Created new cataloges on MBAir and local Nas

5 Set up sync in the folling order iMac (which had the files), MBAir and local Nas.


About an hour ago BTSync history tab reported "Finished syncing with Bengt's Macbook Air" and on the MBAir it was the corresponding message "Finished syncing wit Bengt Svenssons iMac"

Since then there has been no further activity. The Devices tab on iMac correctly states the the MBAir was synchronized but showslocal Nas (QNAPXM_1)  with an up arrow and 6.5 GB.  On the iMac the catalog is 21,4 GB on the Nas 17 GB


During the sync I noticed that the MBAir vas building the catalog faster than the Nas,




Looks like a bug


Link to post
Share on other sites

Got help and tried to install 1.2.92. 

Downloaded and unpacked btsync_x64

found qnap catalog containing btsync and renamed it to btsync_orig

ftp-ed the new version into the catalog

changed permissions to reflect orig file 


Restarted NAS and then btsync from app center

Impossible to log in 

Checked via ssh and app is not running see below


[/share/CE_CACHEDEV1_DATA/.qpkg/BitTorrentSync] # ls -l           

-rw-rw-r--    1 501      502            155 May 29  2013 LICENSE.TXT

-rwxrwxr-x    1 501      502        4377720 Mar 19 21:35 btsync*

-rw-r--r--    1 admin    administ      1607 Feb 20 15:19 btsync.conf

-rwxr-xr-x    1 admin    administ      1939 Oct  8 06:24*

-rwxrwxr-x    1 501      502        3115116 Sep 20 12:49 btsync_orig*

-rwxr-xr-x    1 admin    administ      9612 Jul 24  2013 chattr*

drwxrwxrwx    2 admin    administ      4096 Jan 11 17:43 html/

[/share/CE_CACHEDEV1_DATA/.qpkg/BitTorrentSync] # ps -ef | grep btsync

18236 admin       548 S   grep btsync 

[/share/CE_CACHEDEV1_DATA/.qpkg/BitTorrentSync] # 

Maybe update is more complex that substituting the btsync executable?
Any advice??
Link to post
Share on other sites

[/share/CE_CACHEDEV1_DATA/.qpkg/BitTorrentSync] # uname -a

Linux QnapXM-1 3.4.6 #1 SMP Wed Oct 23 05:17:04 CST 2013 x86_64 unknown

[/share/CE_CACHEDEV1_DATA/.qpkg/BitTorrentSync] #


Did that before selecting executable. Maybe I should have selected Linux_x64 instead of x64

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.