RomanZ

Bittorrent Sync 1.3

Recommended Posts

I just have one question:

 Now, it is simply confusing, as I have some folders with the same name but in totally different paths, and so, when I switch tabs back and forth, I'd like to see the whole picture all at once with full path names instead of using tool tip just to find out which exact folder it is.

Move your mouse over the folder icon, wait 1 second, absolute path to folder will be displayed in tooltip

Share this post


Link to post
Share on other sites

Desktop changes

  • Support TCP connectivity between peers, tracker and relay (work when UDP is not available)

 

That's fine, because my router crashes with UDP fullspeed. In the moment I limited the up/download.

 

How can I enable TCP? Only blocking UDP doesn't work.

Share this post


Link to post
Share on other sites

Did you have a chance to grab any logs / core dumps? Could you also please share more info on what kind of damage happened: newer files replaced with older or something else?

No logs or core dumps. My server shows it's been up for 14 straight days, so it wasn't a server reboot. The app must have crashed somehow. The re-started app overwrote all files that were changed on other clients past a certain time with its older versions of those files. Presumably, that certain time was when the app must have crashed, which was about twelve hours before I discovered it. So I was saved a lot more work than if I'd gone days without noticing it.

Share this post


Link to post
Share on other sites

Since there are now columns would it be to harsh to ask wether you could make an option to turn on a "View full path" column?

 

We do have the option to add more adjustable columns to BTSync planned for one of the next releases.

 

I know it feels like a "dumping ground" - but really it's not! The developers do frequent that thread and are using it as a basis to determine the popularity of suggestions from the community. That's why you don't have to first trawl through it to see if you're suggestion has already been made by someone - just make it again! The more suggestions a particular feature receives, the more popular the suggestion is to the developers.

 

This is true. Your suggestions are valuable, especially when describing real life use cases (so that we can fine-tune the UI).

 

Thanks.

 

Share this post


Link to post
Share on other sites

 

We do have the option to add more adjustable columns to BTSync planned for one of the next releases.

 

 

This is true. Your suggestions are valuable, especially when describing real life use cases (so that we can fine-tune the UI).

 

Thanks.

 

 

Thanks for stopping by and telling us.

Since there is no real feedback from the Team about what they like as an idea it is hard to know if the suggestions are being processed by the team. But your response proves that you care - "we' good" ;-)

Share this post


Link to post
Share on other sites

Updated 3 computers and we hit the first problem...

 

Folders configured to only "Search LAN" (tracker disabled), each computer only sees 2 (out of 10) folder from each other.

 

Not cool... Folders using tracker or hosts seem to be working.

 

No configuration changes have been made, just update and run BitTorrent Sync. It was working before the update.

 

I hope there is a quick update for this soon...

 

Similar problem here.  Two computers on the local network.  One is also visible from outside (my always on RaspberryPi) and the other a Windows laptop.  Three shares on the laptop were "Search Lan" only (all shares on the PI are "use tracker"), and two of them wouldn't sync to the PI. (Everything on the PI is "Read only" in case that matters.)  I wasn't sure what the problem was, and my wife would want to kill me if I destroyed 10 years worth of digital photos (syncing to the PI as backup), so I downgraded everything to 1.2.92 which has been working perfectly for me.

 

I also had one old file reappear on the laptop with the 1.3.67 upgrade -- it didn't overwrite anything because it had a unique name (I had just deleted it a copule of weeks ago), but it was disturbing enough to scare me.

 

Hopefully these issues can be resolved soon -- looks like there are a lot of good updates in 1.3.

 

(Unfortunately, no logs of the above problems).

Share this post


Link to post
Share on other sites

I upgraded to 1.3 and I get a message that "All syncing devices went offline". Now files keep getting removed. I don't see them in my .SyncArchive here. I am hoping they will be on my other machine in a remote location. The remote machine is still running 1.2 as I haven't had a chance to upgrade that one yet. I think I'm done using Bittorrent Sync with this frightening result.

Share this post


Link to post
Share on other sites

The same problem here! 12 Macs OSX 10.8.5 and PCs Windows 7, only LAN. Each one just sees 1 or 2 out of 12. With version 1.2.92 did not happen...

Share this post


Link to post
Share on other sites

Updated my OSX & windows clients to 1.3.67 with no issues so far.

 

My linux (CentOS 6.5) client advertises itself twice to the network (including itself as a hostname and ip address in the devices list!) in the list of devices & also regularly crashes.

Share this post


Link to post
Share on other sites

Kai,

The discovery mechanism in LAN has changed, so it looks like there is some issue in it. Thanks for reporting, we are looking for solution.

 

sunk818,

Was the files removed bigger than 1Gb? Is your sync folder on SMB share / removable media? Did you have any chance to grab debug logs?

 

Thanks!

 

UPD.

File size does not matter while deleting - it will still get to SyncArchive, if was deleted by syncing data from remote peer. If bigger than 1 Gb it won't keep many versions. So files deleted by BTSync always get to .SyncArchive

kamborio, Kai, Bwainscott,

 

Did you try to restart missing clients? Does it help? If no - can I please get debug logs for your peers (at least 2 logs needed from PCs that do not see each other).

 

Thanks!

Share this post


Link to post
Share on other sites

Was the files removed bigger than 1Gb? 

 

No, they were no bigger than 1GB.

 

> Is your sync folder on SMB share / removable media?

 

No, hard drive.

 

> Did you have any chance to grab debug logs?

 

Sorry, no.

 

All the deleted files originated from the remote machine. It was a matter of moving them back to the original folder... although I had to filter out files older than 2 hours to not move back files I actually did not want. Its going to take some time to sync back 50GB of moved data.

 

I don't blame you guys for this... it is beta software and this is an acceptable consequence.

Share this post


Link to post
Share on other sites

If I turn off tracker server and relay server on the linux client I only see one entry in other devices and the linux client no longer see's itself twice as an available device and works as expected.

Share this post


Link to post
Share on other sites

kamborio, Kai, Bwainscott,

 

Did you try to restart missing clients? Does it help? If no - can I please get debug logs for your peers (at least 2 logs needed from PCs that do not see each other).

 

Thanks!

 

When my PI didn't see the shares from the laptop, I tried unshareing and reshareing it on the PI, and even created a new secret on the laptop -- nothing helped.  I think I stopped and restarted sync on the laptop a couple of times, but I was focused on the PI, thinking it was the problem (seems I was wrong in this).  I may be able to duplicate this and grab some logs, but it won't be before tomorrow night at the earliest.

Share this post


Link to post
Share on other sites

As RomanZ has indicated, the ability to "sort" lists is on the roadmap, so will happen at some point! Yay! :)

 

Great! Hope it will come with more GUI updates... I am preparing a list of things I would like to see to post as "Wish List".

 

 

kamborio,

All your 10 PCs are in the same subnet?

 

But of course! :-)

 

kamborio, Kai, Bwainscott,

 

Did you try to restart missing clients? Does it help? If no - can I please get debug logs for your peers (at least 2 logs needed from PCs that do not see each other).

 

Thanks!

 

I tried everything... to no joy. My configuration is with "lan_encrypt_data = false", but changing it to true in all clients did not have any effect. At the end I entered the local hostname and port on the hosts list and that did the trick. So it looks like as if the search LAN without tracker does not work.

 

Regards,

 

David

Share this post


Link to post
Share on other sites

Great! Hope it will come with more GUI updates... I am preparing a list of things I would like to see to post as "Wish List".

 

 

But of course! :-)

 

 

I tried everything... to no joy. My configuration is with "lan_encrypt_data = false", but changing it to true in all clients did not have any effect. At the end I entered the local hostname and port on the hosts list and that did the trick. So it looks like as if the search LAN without tracker does not work.

 

Regards,

 

David

Hi,

 

I have the same problem described here.

 

PLUS:

I have upgraded to 1.3 on one of my machines and, after switching on another (still on 1.2.91) the speed over wifi was good (30Mb/s)

Once I have upgraded the second to 1.3, the speed has dropped to around 0,5Mb/s.

From a quick test, it seems the synchronization is not happening over the internet, but...

 

EDIT: I found the reason. On the first laptop I had configured max upload speed AND rate_limit_local_peers=false. Previously it was not affecting the speed over LAN (though I never tested the WAN) but now it seems broken.

 

PLUS: in the tab "devices" shares keep on disappearing/reappearing (though some shares on the same laptop still remain visible while other misbehave)

 

PLUS: some folders now show some old files as "to be synched". And for some files I know for sure that it's impossible (I'm referring to photos backup, which I shared with another computer where I watched them and never modified)

 

PLUS: it keeps on crashing on two of my computers!!!

 

All in all, this version seems a big step backward in terms of stability. I think you should pull it back.

 

Nicola

Edited by nickluck

Share this post


Link to post
Share on other sites

 

kevinsky25, unsignedint,

Note - Linux has a limitation for xattr to 4kb, while Mac is capable of storing much more data. This might be a reason why some xattrs can't be synced.

 

 

Maybe some way to disable extended attributes, and file streams would be a great feature. I guess some people find this feature useful, but I just can't think of any use cases that this feature would be useful. Alternative stream on Windows are even known to be hive of some virus as well. Or maybe they should be stored somewhere like .SyncAttr instead of causing errors...

Share this post


Link to post
Share on other sites

All in all, this version seems a big step backward in terms of stability. I think you should pull it back.

Nicola

I would agree to that.

There is one interesting release related issue here.

In my experience and understanding, beta is basically a nearly stable official release of the product.

At beta phase, no new bells and whistles are added and no new functionality and, especially, the changes of behavior are to happen.

The very definition of term beta is bug fixes ONLY. It is a final problem resolution phase of the product.

Secondly, not making releases in small and gradual improvements, and accumulating massive amounts of changes and/or bug fixes, you risk to be exposed to the bomb effect, when things massively do not work and you see tons of issues appearing out of nowhere, as it happened with 1.3.67 release.

For me, personally, probably the worst "improvement" was replacing folders in both, Devices and Folders view with only the last element of the path.

That is a disaster for me, since I have several shares that now have exactly the same name and once I switch to one of those tabs, I have to start thinking, moving my mouse around and trying to recall what relates to work.

That is just an additional load on perception.

There is such a notion as "burden of perception". Perception is not "free". It takes energy and concentration, and, in this case, utterly unnecessary.

I work with several totally different projects in totally unrelated area as a normal mode. That means, when I switch from the text editor, or coming back from site status statistics and some other things, it is like coming from a totally different world. Sometimes, it is not even easy to type as you just worked with totally unrelated language.

And, most importantly, what does this new folder presentation IMPROVES?

What does it add?

What does it clarify?

Instead of providing MORE useful information, it makes it LESS useful.

When I switch to Devices or Folders tab, which, in my opinion, more appropriate name for what is called My Sync. Because EVERYTHING in BTSync is about "My Sync", every single parameter and every tab in every dialog page.

When I switch from one tab to another, I'd prefer to have as complete of a picture of everything as possible without making ANY additional efforts on my part. I do not have spare or idle energy to throw around.

So, to me, to call this product beta stage is simply misleading.

About the only thing that is of any use or changes anything, as far as our own situation is concerned, is that additional tooltip that shows pending transfers. I like that one indeed. Because it really ADDS more information and gives a fuller picture of the state of the nodes.

I helped me to see exactly the reason I consistently see the incomplete sync with couple of nodes. Because it shows exactly which files remain to be uploaded, even though they were uploaded at one point, but were modified on the r/o node and they do not even realize what they did, most likely.

So, if BTSync still continues to develop and/or add all sorts of new bells and whistles, for marketing purposes or otherwise, it would be more appropriate to reclassify BTSync as Alpha state.

In beta state, you are dealing with basically a releasable product where only the final touches remain in terms of fixing bugs ONLY. It is a state of the product when massive testing occurs with all sorts of test suites or otherwise.

I am still willing to run it for a day or two, the way it feels right now, just to see what other changes of BASIC behavior I see in other nodes.

And it looks like I am risking some very unpleasant potential consequences, looking at all the posts on this tread and other 1.3 related threads.

Share this post


Link to post
Share on other sites

RomanZ:

 

First: thanks for the work you have put into this wonderful software.  

 

I have a similar issue connecting to peers, but not on my LAN.  I have eight nodes across four LANs (all Win. 7 updated to 1.3.67).  However, when I take my laptop to my school's network, it cannot locate any peers while all 8 are online.  I'm sure my school has a restrictive firewall, but with version 1.2.91 of BTSync, I was able to sync from the restrictive firewalled network.  Just curious, does the tracker facilitate a handshake among peers so that BTSync traffic can get through NAT by publishing peer IPs and internal and external ports?

 

I have not yet had a chance to restart any computer since the update (except the laptop), so I will try that first tomorrow.  If that doesn't work, I can send debug logs.  

 

Again, sincerely, thanks for this awesome software.  I think the BT team is really onto something.  

Share this post


Link to post
Share on other sites

This is warning to all: 1.3 is buggy. Not everything is syncing. It crashes. Too many problems. I am reverting to 1.2.92 and I hope the problems get fixed. 

Share this post


Link to post
Share on other sites

Nickluck,

Thanks for reporting. Seems we identified the root cause of both crashes and LAN issues, I'll update the forum soon.

 

unsignedint,

Thanks for proposal - we'll consider making an option to disable xattr sync.

 

Stanha,

I've got your feedback about beta status and folder list. For folder list - it is in discussion now and is likely to be changed soon. Also, I would appreciate your feedback in more compact form for future. Thanks for understanding.

 

pjmsullivan,

I'll pass by your thanks to devs team :). Are you using tracker to connect your PCs in different LANs or you have properly set up routers which let multicast pass?


wimbit,

 

For crashes I would appreciate crash dumps. Could you please share more info on what is not syncing? Also, which other problems are you facing?

Share this post


Link to post
Share on other sites

At some point, 1.3.67 stopped running on one of my Linux clients, I don't know why. When I manually restarted btsync, I had a lot of data destruction where old overwrote new. It took about 30 minutes working with the history file to sort everything out. But I'm concerned that this will happen again when the Linux client restarts, possibly after it crashes. And then, the longer it takes before you notice it needs a restart, the more painful the restore session will be.

Same thing just happened on my other Linux client. I have no clue what suddenly happens to the btsync process. Any suggestion of what diagnostic information to collect and how to collect it in case it happens again?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.