Sign in to follow this  
MrFish

Sync Never Ends After V1.3, Crashes When Adding New Folder

Recommended Posts

After upping to v1.3.67 on Mac and Linux, most of my folders have never stopped syncing. It's almost like it's re-scanning the file structures, similar to if one was to re-add a sync folder that already resides on disk. No real data is being passed around, but it's been going for 2 days now.

 

I thought something got tweaked out of line, so figured I'd delete each sync folder on the RO "clients" and re-add them (Linux webUI), and leave Mac "master" alone. The issue now is that after adding the secret, entering the disk path and hitting Add in the webUI, btsync shuts down. K'boom. So I can either sync forever, or not at all. :)

 

During the never-ending sync, I'm seeing the following in the log, repeatedly:

 

[20140326 16:37:49.171] Error downloading file <path>

[20140326 16:37:49.394] <IP:port>: did not pick any blocks. blocking peer temporarily

[20140326 16:37:49.500] TorrentFile: failed to copy stream suffix <path>

[20140326 16:37:49.500] TorrentFile: failed to delete stream suffix file <path>

[20140326 16:37:50.018] Error: <path> - PostDownload: hostname not found

 

There's no log output for the crash, the log just ends.

 

Help a noob?


Interestingly, I just found that btsync won't stay running for more than a few seconds anymore. The "crash when I click Add" was just a wicked timing coincidence. Think I'm going to blow away btsync and start from scratch on one machine. If that works, I'll do the other one. But I'll hang for a bit, see if anyone has some tasty nuggets of wisdom ...

Edited by MrFish

Share this post


Link to post
Share on other sites

Hi MrFish,

 

I think it is the same issue that I have with the extended attributes, which are turned on by default to sync from the Mac since 1.3.67. A remedy might be to exclude these streams on the Mac master shares in the .SyncIgnore file, as described in my post here . This is only a short time fix, as some users would very much like xattr to sync as well.

 

HTH

Share this post


Link to post
Share on other sites

Thanks nils, that took care of the perma-sync issue between the Mac and the Mint box. I haven't had any luck getting 1.3.x running on my other slot, it just crashes as soon as I run it. No more info than that for now.

 

I wiped btsync and went back to 1.2.x over there, seems to be running really well. I'll see what info I can put together about that Linux environment, it might be useful to the btsync devs.

 

Thanks SO much for your tip about .SyncIgnore. As others have mentioned, this isn't a great solution for multi-Mac environments, but it's ok with me for now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this