wck

Btsync Not Syncing

Recommended Posts

Hi forum,

 

I have been using btsync for months with no problems. This week though, one computer I use is not syncing with the rest. It's my office computer, so I suspect there is something which might have changed with the network here which is causing the issue. (Though, strangely, when I connect to the wifi network here I *can* sync...)

 

I was running Ubuntu 12.04, and upgraded to 12.10 and that has had no effect.

 

The tail of /var/lib/btsync/sync.log is below:

[20140402 14:15:53.579] Using IP address **.**.**.**[20140402 14:15:53.580] Loading config file version 1.3.77[20140402 14:15:54.108] Loaded folder /media/storage/teaching[20140402 14:15:54.109] bind port is 18685[20140402 14:16:18.600] NAT-PMP: Unable to map port with NAT-PMP.[20140402 14:16:53.587] NAT-PMP: Unable to map port with NAT-PMP.

So, something is fishy with the port mapping. Any thoughts on how to fix it?

 

Share this post


Link to post
Share on other sites

wck,

 

If your office BTSync can't "see" other devices in device list - this is a connectivity issue and it is likely your office admins changed firewall policy.

 

BTSync uses TCP and UDP port 3000 to connect to tracker server, configured port (see preferences) to contact remote peers directly, UPnP / PMP to map ports your PC stays behind the NAT.

 

The fact that PMP failed does not necessary means it is a root cause: it is possible that UPnP succeed, or you just don't use NAT at all.

Share this post


Link to post
Share on other sites

Thanks for the reply, RomanZ.

 

Hmm. So should I check to see if port 3000 is blocked on my network?

 

Even so, how can we explain that my laptop connected to wifi at work is able to sync, but my desktop wired to the network cannot?

Share this post


Link to post
Share on other sites

Wck,

 

It depends on your office security policy. It is very common policy that wifi is less strict network (and has access to less amount of resources) while wired network considered to be safe, has more limitations - and full access to internal resources.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.