KindOne

1.3.80 - Ubuntu - 100% Cpu

Recommended Posts

1.3.80 will sit at 100% CPU after an hour of two of running. Never experienced this in earlier versions.

 

https://dl.dropboxusercontent.com/u/16148324/btsync/sync.txt part of /var/lib/btsync/sync.log I redacted the IP of the server this is on.

 

4:30 - 5:40 - 100% spike - No bandwidth usage
10:20 - 10:40 - 100% spike - No bandwidth usage


Folder one: ~670MB in ~4600 files.
Folder two: ~8GB in 19 files.

Share this post


Link to post
Share on other sites

1.3.80 will sit at 100% CPU after an hour of two of running. Never experienced this in earlier versions.

 

https://dl.dropboxusercontent.com/u/16148324/btsync/sync.txt part of /var/lib/btsync/sync.log I redacted the IP of the server this is on.

 

4:30 - 5:40 - 100% spike - No bandwidth usage

10:20 - 10:40 - 100% spike - No bandwidth usage

Folder one: ~670MB in ~4600 files.

Folder two: ~8GB in 19 files.

 

I'm having this same issue. problem started with version 1.3.80 using btsync-user on ubuntu linux. how would I make a core dump?

Edited by shawnv

Share this post


Link to post
Share on other sites

Upon further inspection, it seems like it is fine when there is a 4.1GB directory by it's self. Once I add a 200GB file it stops syncing, uses a high cpu amount, and starts reporting "Don't have permissions to write to the selected folder." on both directories after a couple of minutes of scanning, and appears to have stopped scanning the large 200GB folder after 6.6GB. Also, after reading the logs, it seems that the issue is "ReadFromDisk: Too many open files"

Edited by shawnv

Share this post


Link to post
Share on other sites

Hi! I've the same problem with 2 folders. I haven't got problems with small folders, but the content of 2 of them are around 1GB, and at few second of start to sync the CPU is at 100% and web interface says "Don't have permissions to write to the selected folder."

 

Paste my log: http://pastebin.com/2SzbK4ar

 

BtSync are running on Ubuntu 12.04 x86 with 1GB of RAM

 

I hope that anyone can help my solve this. Thanks (and sorry if my english is bad)

 

Share this post


Link to post
Share on other sites

Oneclick,

 

According to logs you suffer the handle leak issue, just like in this topic. We are preparing a fix for the issue, for now as a workaround you can roll back your btsync to 1.3.77.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.