Sign in to follow this  
suntear

Bt Sync On Android

Recommended Posts

Hello I have been having an issue since upgrading to Android version 1.3.19 and Windows desktop version 1.3.77 and 1.3.80.  The Android client has issues seeing the Windows desktop client (both version 1.3.77 and 1.3.80) when on the LAN.  The folder properties is set to Search Lan, no other options.  This folder is to only sync when the Android client is on the LAN.  If I enable Use tracker server than Android client has no problem seeing Windows Desktop client.  I don't want to sync this folder when not on the LAN.  This only started happen since upgrading to 1.3.77 and still is a problem in 1.3.80.  If end Windows client and restart it then Android client will see if but then after going to sleep for a while if I open Android client again it no longer sees the Windows clients.

Share this post


Link to post
Share on other sites

Suntear,

 

Do you have auto-sleep option ON on your Android device? If yes - could you please try to turn it off to see if this is a root cause?

Share this post


Link to post
Share on other sites

RomanZ,

 

Yes it is on.  I will turn this off and restart my BT Sync clients on Windows and retest.  BTW once Android stops seeing the other Windows client, the only want for it to see it again is to restart the Windows client.  Restarting the Android client does not correct the issue.

Share this post


Link to post
Share on other sites

RomanZ,

 

I turned off auto-sleep and it no longer has the problem.  Looks like that was the problem and required restarting Windows client before Android would see them again.

Share this post


Link to post
Share on other sites

Update:  I left my house and was out for a bit, when I came back I check the BT sync client on Android and noticed that it can no longer see the Windows client.  I have BT sync set to not use Cellular Data so that it only syncs on Wifi.

Share this post


Link to post
Share on other sites

Suntear,

 

When auto-sleep is ON and there is no actual transfers ongoing, BTSync unloads the sync engine. When the auto-sleep period expires, BTSync loads the code, and checks if there is anything necessary to sync. If it is - it syncs. Once the sync is complete and no events happening for around 1-2 minutes, BTSync again unloads the core for another sleep period.

 

Of course, all of other peers will see that the Android device is gone when engine is unloaded.

Share this post


Link to post
Share on other sites

Thank you for the clarification.  I understand that part.  What I was wondering is:

1) With Auto-Sleep on - why does it no longer see the other clients when it wakes up and other clients do not see it.  Exiting the app on Android via the menu and relaunching it does not correct the problem, it cannot see other clients and other clients cannot see it.  The only way to get it to see the other clients is restarting the other clients.

2) I disabled Auto-Sleep as suggested and it worked until I left the house and came back then it no longer saw the other clients and again the only way to get it to work again was to restart the other clients, restarting the Android client does not fix the problem.  Mobile Data is set to off.

3) With Auto-Sleep off and leaving the phone overnight, when I check in the morning it again stopped seeing other clients until they were restarted, again restarting the Android client does not fix the problem.

 

The interesting part is this only happens to shares that are set to Search Lan only.  I have another share that has Search Lan and Use tracker server and it does not have any issues.  Throughout the entire testing the share with Search Lan and Use tracker server always was seen by Android and Windows client.  Only appears to be a problem with Shares that are set to Search Lan only.

 

BTW this was working fine in 1.2.x.

 

Kind Regards,

Suntear

Share this post


Link to post
Share on other sites

Suntear,

 

The local discovery mechanism has changed in 1.3 to reduce amount of generated service traffic in LAN. Let's try to find the answer in debug log. Please turn it on for PC (it is always on for Android device) and once issue reproduces - collect both logs on PC and on Android (on android it's enough to send feedback and agree to send logs, note the forum link in feedback form).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this