Sign in to follow this  
zkyevolved

Raspberry Pi Problems

Recommended Posts

Hello everyone. I got my Raspberry Pi today and I followed the following instructions followed on this website. 

 

http://jack.minardi.org/raspberry_pi/replace-dropbox-with-bittorrent-sync-and-a-raspberry-pi/

 

The instructions were really easy to follow. But I ran into a few issues that I'd like to hear your opinion about. 

 

  1. I would like to change the trash time. On windows and Mac OS it's easy to change from 30 days to 45 or 180 or whatever.  How can I modify it?
  2. I ran into a storage problem. I used the following command lines to format the USB drive to test it out.
    df -h # find your drive here, e.g. `sda1`sudo umount /dev/sda1 # replace sda1 with your drive name !sudo mkfs.ext4 /dev/sda1 -L BTSync # replace sda1 with your drive name !
    It created a volume called BTSync just like in the guide. I didn't have BTSync_ until after I restarted. I don't understand why there are these 2 folders were created (BTSync and BTSync_). Can someone explain why there are these 2 folders when I only created one? 

    Well, to the main issue: I have multiple folder secrets and I want to sync multiple secrets! I can't. I went into the file explorer and tried to create the folder and it said I didn't have permission. So the next thing I did was with my very little knowledge of the OS I opened the command line and moved myself to the BTSync folder and used "mkdir Documents" and it said the same thing, no access.  How can I create a folder in that drive? I want to create multiple folders. One for each "Secret" that I have: One for documents, one for pictures, one for mobile, etc. 

Thank you very much for your time. 

Kind regards.

Share this post


Link to post
Share on other sites

OK I have fixed the majority of the problems. I flashed the card and then started anew and this time I used FAT32 and I have no issues now. I created the folders from within the GUI and since it was fat32 I didn't have any issues. I'm sure Fat32 had NOTHING to do with it, but this time it worked :) I didn't mount it or anything like that! So yay.

 

The second issue is that I extracted the config and then added: “sync_trash_ttl”: 120, 

 

It might be overkill but I can always change it later! So... yay again :)

 

 

Share this post


Link to post
Share on other sites

@zkyevolved

 

Note that FAT32 system is rather old and has numerous limitations comparing to EXT4. Probably the most nasty ones:

1) FAT32 is not journaled FS. So, if you encounter sudden OS reboot / crash, drive unmount without flushing buffers, etc - the file system may be damaged.

2) FAT32 uses 32 bits to address the file size - which means it can't be larger than ~4Gigs. BTSync won't be able to sync any bigger files.

3) FAT32 is very plain in terms of access permissions (there are none, actually).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this