Not Generate Secret Key In Web Interface.


Recommended Posts

Hello, I am zaxius.


Sorry, my English is very limited, I will detail my problem:


SO: Ubuntu Server 14.04

Steps I followed to install Bittorrent Sync:

$ sudo apt-get install -y software-properties-common$ sudo add-apt-repository ppa:tuxpoldo/btsync$ sudo apt-get update$ sudo apt-get install -y btsync$ sudo dpkg-reconfigure btsync

The last command I've done it 3 times, changing the user and group assignment : root, btsync and zaxius.


The problem occurs when adding a directory to synchronize with any directory you selected.

Pressing the button "Generate" to get a key and nothing appears worse, if I update the website does not work and I have to restart the service from the console.


Previously use Bittorrent Sync install and configure the same way and had no problem.


Where is the problem? Can I create directories in sync from the console?


PD: Thanks for reading, I hope your answers



Link to comment
Share on other sites



Could you please try to open a "Web-developer / Javascript console" in your browser (the console name might slightly differ depending on the browser) - and provide me an output of what do you see there after you clicked the "Generate" button?


The console interface is very limited for BTSync, so you won't be able to add/remove folders there. However, there is HTTP-based API which allows even better control over BTSync functionality.

Link to comment
Share on other sites

I've used Chrome, the text copy is not well understood it so I put a picture.


Link image: btsync-js-console.png



I understand that there is a javascript error, shame that my current level JS programming is null.

Thanks for your interest, to see if we solve it together.

Edit: I doubt the fault of the browser, I've tried it in Firefox (my PC), Chrome (my PC and the PC of a friend) and Dolphin (my smartphone).

Edited by zaxius
Link to comment
Share on other sites

It seems to happen only on fresh actual Debian 7  and Ubuntu 14.04 installations. On one computer with a ubuntu, which has been dist upgraded to the latest version (precise->saucy->trusty), btsync is running as expected.


If you add a folder and click Generate Key or you add a Existing Key to an folder and click ok the btsync application is terminating silently.

Link to comment
Share on other sites

I have a clean install of Ubuntu 14.04. It fails the key General and do not accept keys already created, I suppose that you because of the same error. I don't want to install an older version then upgrade it.

- Where can the error be? Program base or interface web?

- How can I skip the web interface?

- Is there any way to fix it?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.